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1. Introduction to IDCubePro® – Interactive 
Discovery Cube  

Multi- and hyperspectral imaging modalities encompass a growing number of spectral techniques that find 
many applications in geospatial, biomedical, machine vision, and other fields. The rapidly increasing 
number of applications requires convenient easy-to-navigate software that can be used by new and 
experienced users to analyze data, develop, apply, and deploy novel algorithms. Herein, we present our 
platform, IDCubePro®, an Interactive Discovery Cube that performs essential operations in hyperspectral 
data analysis to realize the full potential of spectral imaging. The strength of the software lies in its 
interactive features that enable the users to optimize parameters and obtain visual input for the user in a 
way not previously accessible with other software packages. The entire software can be operated without 
any prior programming skills allowing interactive sessions of raw and processed data. Similar to the 
launched 2020 IDCubeLite®, a free version of the software1 available from https://www.idcubes.com/, 
IDCubePro® presents many benefits and offers structural flexibility to discover new, hidden features. 

Multi and hyperspectral imaging (HSI) modalities have emerged as an exciting opportunity to explore the 
optical properties of objects and discover hidden features not accessible by other techniques. In contrast to 
                                                      
1 Mishra D, Hurbon H, Wang J, Wang ST, Du T, Wu Q, Kim D, Basir S, Cao Q, Zhang H, Xu K, Yu A, Zhang Y, 
Huang Y, Garnett R, Gerasimchuk-Djordjevic M, Berezin MY. IDCube Lite: Free Interactive Discovery Cube 
software for multi- and hyperspectral applications. J Spectr Imaging. 2021;10: doi: 10.1255/jsi.2021.a1. 

https://www.idcubes.com/
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the traditional spatial images produced by conventional cameras, spectral imaging generates 3D datasets 
(datacubes), with spatial and spectral dimensions. With each pixel containing information of the entire 
medium or high-resolution spectrum, spectral imaging provides abundant information about individual 
chromophores and their interactions that contribute to the location, intensity, and alteration of the optical 
signal, significantly better than monochromatic or traditional color cameras. This spectral imaging approach 
leads to a vastly improved ability to classify and differentiate the objects based on their spectral features, 
enabling even small, otherwise unnoticeable, features to be amplified.  

In the last decade, spectral imaging expanded from the narrow niche accessible only to a handful of 
organizations in academic and governmental research facilities to a broad range of commercial institutions. 
As spectral imaging hardware (benchtop scanners, handheld HSI cameras, imaging satellites, drones, etc.), 
has become more available, the number of spectral imaging applications has tremendously increased.  

Meaningful analysis of datacubes is the most critical and time-consuming step in many current applications. 
The high dimensionality of spectral imaging data and their large data sizes (often > 1 GB) gives an excellent 
opportunity to learn more about the subject; however, the extensive and efficient analyses (i.e., 
pretreatments, algorithms, visualizations, etc.) of these datasets present the strongest barrier to the imaging 
workflow. IDCubePro® breaks this gap by bringing a universal, powerful computational platform that 
enables comprehensive and rapid data analysis for a variety of spectral imaging platforms.  

  



v. 2.78   

11 
 

2. Getting Started with IDCubePro®  
IDCubePro® is a highly versatile software that performs a large number of essential operations in the 
spectral imaging domain and enables image analysis for users across a range of technical proficiencies. The 
goal of the software is to make spectral imaging accessible to new and current users that focus on obtaining 
useful results rather than (but not excluding) developing algorithms. The strength of the proposed software 
lies in its intuitive design that enables the user to perform high-level data analysis as well as develop new 
algorithms via a visual, interactive interface. Built around a collection of spectral imaging algorithms, the 
software facilitates the search of hidden information inside large datasets providing a new experience of 
data analysis.  

The overall workflow of the IDCubePro® in multi- and hyperspectral (or any three-dimensional data, i.e. 
time-lapse data, fluorescence lifetime imaging data, etc) is illustrated in this diagram.  

 

3. Representing Hyperspectral Data 
The values measured by a hyperspectral imaging sensor are stored in a binary data file in a variety of formats 
such as ENVI, tiff, png, mat (matlab), excel, Dicom (dcm), NIFTI (nii) and others. The data file is often 
associated with a header file that contains ancillary information (metadata) like sensor parameters, 
acquisition settings, spatial dimensions, spectral wavelengths, and encoding formats that are required for 
proper representation of the values in the data file. 

For hyperspectral image processing, the values read from the data file are arranged into a three-dimensional 
(3-D) array of form M-by-N-by-C, where M and N are the spatial dimensions of the acquired data, C is the 
spectral dimension specifying the number of spectral bands/channels such as wavelengths used during 
acquisition. Thus, one can consider the hyperspectral image as a three-dimensional (3D) dataset in the form 
of a stack composed of a set of two-dimensional (2D) monochromatic images. This type of dataset is called 
a hyperspectral datacube or simply a datacube. 

IDCubePro® extracts the data from the datasets and constructs the datacube by reading the data file and the 
metadata information and combining them in one file. The generated by IDCubePro® single file stores the 
datacube and spectral wavelengths. Additional header information can be extracted and stored separately.  

Note, that while IDCubePro® can handle a variety of formats and sources, each hyperspectral imaging 
system is unique and might need a distinct plugin function to be developed separately. 

https://www.mathworks.com/help/images/ref/hypercube.html
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Color Representation of the Datacube 
To visualize and understand the object being imaged, it is important to represent the datacube as a set of 
2D images by using a variety of color schemes. The color representation of the datacube enables you to 
visually inspect the data and facilitate interpretation. You can select a colormap from an extensive menu 
and use interactive sliders to visualize false color monochromatic and Red-Green-Blue (RGB) 
representations of the datacube. In addition, IDCubePro® offers a variety of 3D plots to represent the 2D 
image (such as surface plots). Finally, the user can employ a powerful 3D Viewer Toolbox to visualize and 
process the entire datacube.  

Preprocessing 
Hyperspectral imaging sensors are typically characterized by high spectral resolution and low spatial 
resolution. By analyzing the pixels of the acquired hyperspectral data, we can determine the spatial and 
spectral characteristics. Pixels, when viewed individually, are vectors of values that describe the intensity 
of a location (x,y) along z different bands. Pixel spectra are critical elements of spectral data analysis. These 
pixel spectra are often distorted due to factors such as sensor noise, uneven light conditions, the presence 
of spectral artifacts, and low resolution. In addition, there is a number of spatial artifacts that distort the true 
image. You can identify anomalous pixels and assess the quality of the image to judge where it is useful. 
The IDCubePro® software offers a wide range of preprocessing techniques for removing undesirable 
artifacts.  

 
To enhance the spatial resolution of hyperspectral data, you can use image fusion methods. The fusion 
approach combines information from the low-resolution hyperspectral data with a high-resolution 
multispectral data or panchromatic image of the same scene. This approach is also known 
as sharpening or pansharpening. IDCubePro® offers several functions for sharpening hyperspectral data 
using high spatial resolution multispectral images. 

Dimensionality reduction is another preprocessing step that is necessary for all hyperspectral imaging 
applications. A large number of bands in the hyperspectral data increases the computational complexity of 
data processing. At the same time, the contiguous nature of the band images results in redundant information 
across bands. Neighboring bands in a hyperspectral image have a high correlation, which results in spectral 
redundancy. These bands can be removed without losing important information. You can visualize the 
redundancy by building a correlation matrix and removing the redundant bands, thus decreasing 
dimensionality.  
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Compression methods include powerful methods based on Principal Component Analysis, Independent 
Component Analysis and Wavelets transformation techniques.  

IDCubePro® offers several approaches for reducing the spectral dimensionality of a datacube from 
relatively straightforward band removal and spectral binning to orthogonal transforms using principal 
component analysis (PCA) and maximum noise fraction (MNF). PCA and MNF toolboxes transform the 
original datacube into a new datacube where the bands/channels are replaced with principal components. 
The total number of principal components is equivalent to the number of bands/channels in the original 
dataset. The software presents principal components in descending order of the amount of total variance, 
with the most important components coming first. The newly generated datacube can be saved for further 
hyperspectral data analysis. To reduce the size of the datacube, the user can perform ‘spectral’ cropping 
keeping only the most important components (i.e., the first 10 components). Spectral dimensionality 
reduction using PCA or MNF is implemented in several toolboxes such as Endmembers Extraction and 
t-SNE. Alternatively, you can apply PCA or ICA (independent component analysis) compression.   

Spectral Unmixing and Classification 
In a hyperspectral image, the intensity values recorded at each pixel in the region specify the spectral 
characteristics of the region. The pixels that belong to a homogeneous profile with a relatively pure spectral 
signature are known as pure pixels. These pure pixels constitute the endmembers of the hyperspectral data. 
Heterogeneous profiles are a combination of two or more distinct homogeneous surfaces. The pixels 
belonging to heterogeneous profiles are known as mixed pixels. The spectral signature of a mixed pixel is 
a combination of two or more endmember signatures. This spatial heterogeneity is often due to the low 
spatial resolution of the hyperspectral sensor but might also represent a physical mixture of two signals.  
Spectral unmixing is the process of decomposing the spectral signatures of mixed pixels into their 
constituent endmembers. The spectral unmixing process involves two steps: Endmember extraction and 
Spectral Matching implemented in Endmember Extraction and Spectral Matching Toolboxes. 

Endmember extraction — The spectra of the endmembers are prominent features in the hyperspectral data 
and can be used for efficient spectral unmixing, segmentation, and classification of hyperspectral images. 
Convex geometry-based algorithms, such as pixel purity index (PPI), fast iterative pixel purity index 
(FIPPI), and N-finder (N-FINDR) are some of the efficient approaches for endmember extraction. Once the 
endmembers are identified, you can estimate the fractional amount of each endmember present in each 
pixel. This can be achieved by constructing the abundance maps for each endmember, which represent the 
distribution of endmember spectra in the image. 

Spectral matching — IDCube enables the user to interpret the pixel spectra by performing spectral 
matching. Spectral matching identifies the class of an endmember material by comparing its spectra with a 
reference spectrum. The reference spectra usually represent pure spectral signatures of materials, which are 
available as spectral libraries in the ECOSTRESS format2 available from https://speclib.jpl.nasa.gov/.  With 
IDCubePro®, you can also generate your own reference spectra and save them in the ECOSTRESS format. 
Then, you can compute the similarity between the saved spectra and the entire datacube. 

Hyperspectral image processing applications include classification, target detection, anomaly detection, and 
other types of analysis. 

• You can segment and classify each pixel in a hyperspectral image through a variety of unmixing 
algorithms, such as Spectral Angle Mapping, Phasor, k-Means, t-SNE, or Contrast Maximization. 

                                                      
2 Meerdink, Susan K., et al. "The ECOSTRESS spectral library version 1.0." Remote Sensing of 
Environment 230 (2019): 111196. 

https://speclib.jpl.nasa.gov/
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• You can perform target detection by matching the known spectral signature of a target material to 
the pixel spectra in hyperspectral data.  

• You can also use hyperspectral image processing for anomaly detection and material analysis. 

You can also perform machine learning techniques for advanced segmentation.  

Search Documentation  
Typing in this field allows you to search the documentation right from the IDCube interface. Start typing 
any of the terms and you will be connected with a relevant section of the technical documentation on our 
IDCube website. 

  
For example, typing PCA will give a list of links to the website-located information.  

 

The information from the website will be open: 
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Keyboard and Mouse Shortcuts 
The implemented keyboard and mouse shortcuts can be applied to most images and plots, including image 
display, spectral plots, and histograms. The following shortcuts enable quick manipulation of the image 
space. 

Shortcut Description 

Help with shortcuts 
      H Press ‘H’ at any time to display Help. Dismiss by pressing ‘H’ again. 
Image zoom shortcuts 
      Z Zoom In 
      Shift+Z Zoom Out 
      X Zoom in X Dimension 
      Shift+X Zoom Out in X Dimension 
      Y Zoom in Y Dimension 
     Shift+Y Zoom Out in Y Dimension 
Directional Control 
     Arrow Keys  Arrow keys can be used for Pan 
Image modifications shortcuts 
      N Normal Axes/Expand Image 
      E Equal Axes/Normal Image 
      G Toggle Grid 
     Spacebar Toggle Axis Ticks 
Mouse Controls 
     Left Click Activate Zoom/Pan Functions 
     Right Click Pan in any direction 
     Scroll In/Out Zoom In/Out 

4. Main Interface 
The software is built using a modular architecture. The heart of the IDCubePro® is the Main Interface that 
is composed of the following panels: 
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Panels in the Main Interface:   

1. Toolbar Panel, 2. Image Display Panel, 3. Data Reduction Panel, 4. Data Export Panel, 5. 
Datacube Mathematics Panel, 6. Interactive Band/Channel Selection Panel, 7. Spectral Analysis 
Panel, 8. Image Adjustment Panel, 9. Frame-By-Frame Panel, 10. Directory Information Panel, 
11. Computer Information Panel (might not be available in Mac OS). 
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5. Toolbars 
Features: Many of the toolboxes and features have accompanying icons. This manual covers each type of 
icon in the corresponding sections. 

 

Icon Function 

 
Plot Edit Mode 

 
Open IDCube format 

 
Close the file with or without saving the changes.  IDCube interface returns to the original view 

 
Save As… 

 
Flips the main image horizontally 

 
Flips the main image vertically 

 
Rotate clockwise 

 
Rotate counterclockwise 

 
Activates crop 

 
Measures the distance between two points using a straight line and visualizes the profile (see Area 
Information Toolbar) 

 
Measures the area of the rectangle in a specific region of interest 

• Provides mean, standard deviation, and pixel area (see Area Information Toolbar) 

 
Measures the area of the circle in a specific region of interest 

• Provides mean, standard deviation, and pixel area (see Area Information Toolbar) 

 
Measures the area of the polygon in a specific region of interest 

• Provides mean, standard deviation, and pixel area (see Area Information Toolbar) 

 
Measures area of freestyle shape in a specific region of interest 

• Provides mean, standard deviation, and pixel area (see Area Information Toolbar) 

 
Activates Principal Component Analysis (PCA) toolbox 

 
Activates Maximum Noise Fraction (MNF) toolbox 

 
Activates Classification toolbox 

 
Activates Spectral Signature Matching (SSM) toolbox 

 
Activates Endmembers toolbox 

 
Activates Vegetation Indices toolbox 

 
Activates Maximize Contrast Between Two Regions toolbox 

 
Activates t-SNE Clustering toolbox 

 
Activates Phasor Clustering Segmentation toolbox 
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Activates Correlation Matrix (R-squared plot) toolbox 

 
Activates 3D Viewer toolbox 

 
Opens Get 3D Slice under the 3D Viewer toolbox 

 
Opens Get orthogonal slice under the 3D Viewer toolbox 

 
Opens the Data Fusion toolbox 

 
Opens the labeling tool for machine learning 

 
Activates Machine Learning toolbox 

 
Resets to the original dataset 

 
Opens a LUT generator 

 
Stop calculations 

 
Keyboard shortcuts 

 
Information  
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5.1. Working in the Plot Edit Mode 
The IDCubePro® supports a point-and-click editing mode that you can use to customize the appearance of 
your graphs, panels, and entire windows. This section describes how to enter the Plot Edit mode and 
perform basic editing tasks, including selecting, cutting, copying, pasting, moving, and resizing objects and 
modifying other images, plots, and panels properties.  

Starting Plot Edit Mode 
Before you can select objects in a figure by clicking on them, you must activate the plot-editing mode. 
There are several ways to activate a Plot Edit mode: 

Choose the Edit Plot icon  on the figure window Main Toolbar menu or select Edit Plot from the 
Edit menu. You can also use a hot key Ctrl+E. 

 
When an interface window is in the Plot Edit mode, the Edit Plot button in the toolbar is depressed and 
turned blue. 

Exiting Plot Edit Mode 

To exit the Plot Edit mode, click the selection button . When the Plot Edit mode is turned off, this 
button is no longer depressed, and its color is grey. 

Selecting Objects in a Graph 
To select an object in a graph, move the cursor over the object and click it. 

To select multiple objects at the same time, move the cursor over an object and press Shift+Click to select 
it. Repeat for each object you want to select. You can perform actions on all the selected objects. For 
example, to remove a textbox annotation and an arrow annotation from a graph, select the objects and then 
click Delete. 

Deselecting Objects 
To deselect an object, move the cursor off the object onto the figure window background and click the left 
mouse button (this deselects all selected objects and selects the one you clicked). You can also Shift+Click 
on a selected object to deselect it (doing this will not deselect any other object). 

Copying and Pasting Annotation Objects 
In the Plot Edit mode, you can copy and paste annotations such as textboxes, text arrows, rectangles, and 
ellipses, in various combinations. If any such objects happen to be pinned to their axes (see Pinning a Point 
in the Image), their copies are pasted unpinned. 
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Moving and Resizing Objects 
To move or resize an object in a graph in the Plot Edit mode, perform these steps: 

• Select the object. 

• To move the object, drag it to the new location. You can also move it one pixel up, down, left, or 
right with the appropriate Arrow key on your keyboard.  

• You can Shift+Click to select multiple objects and move them as a group. Arrow keys work well 
for this. However, when you resize one of several selected objects, only that object changes size. 

NOTE:  There are some restrictions on moving and resizing the objects such as panels. You can resize 
some panel objects, but you can only move them by dragging their edges, one at a time. 

Undo/Redo — Eliminating Mistakes 
Pressing Ctrl+Z enables you to undo a recent operation. 
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5.2. Area Information and Statistics: ROI Toolbar 
The ROI Toolbar allows the user to select different areas of interest and acquire statistics from the selected 
area.  

 
Line Measurement: Provides linear pixel measurement of selection. Allows the user to measure 
the distance between the points and generate the XY plot of pixel intensities. 

Rectangle Measurement: Creates a rectangular region of interest. Allows the user to collect 
statistics from the ROI and generate a histogram of intensities. 

Elliptical Measurement: Creates an elliptical region of interest. Allows the user to collect statistics 
from the ROI and generate a histogram of intensities. 

Polygon Measurement: Creates a polygon region of interest. Allows the user to collect statistics 
from the ROI  and generate a histogram of intensities. 

Freehand Measurement: Allows the user to freely draw a region of interest. Allows the user to 
collect statistics from the ROI  and generate a histogram of intensities. 

Line Measurement 

1. Click the Line icon  from the ROI Toolbar menu. 

 

NOTE: In the Main interface, activation of the Line icon automatically places the line inside the image 
panel. For the IDCube toolboxes, you might need to choose a specific panel by clicking on the panel first 
and then clicking Line.  

2. You can change the length of the line, its direction, and location by dragging the line or line ends 
to a new position.   

The number inside the line yields the distance between the points. The distance is measured in pixels.  

3. Use the right-click to activate a menu with several additional functions shown. 
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NOTE: Function Export to Workspace… is not available for IDCubePro® users. 

Selecting X-Y Plot creates a graph of intensity across the line. Moving the line will update the X-Y plot 
accordingly. 

 

Area Measurement 
This tool provides basic statistics of the selected region: mean signal intensity, standard deviation, area, 
area % from the total image, intensity maximum and intensity minimum.  

1. Select a region of interest with a Rectangular, Ellipse, Polygon, or Freestyle. A frame will be 
formed. 
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The region of interest will automatically display the region’s mean pixel density, standard deviation, 
minimum, maximum, and area (and area percentage of the entire image).  

2. Drag the corners or the frame to a new location.  

3. Right-click on the frame to open a selection menu.  

 

a) Copy Position enables the user to record and store a position. Click Copy Position and 
then Paste in your document. For the rectangular frame. The location coordinate will be in 
the following form: [X Y Width Height]. 

b) Set Color Selecting histogram creates a graph of intensity vs the number of pixels. 

c) Select the color of the frame from the dropdown menu. 
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d) Fix Aspect Ratio enables the user to move the frame without accidentally changing its 

shape. 

e) Visualize the histogram from the selected area. NOTE: Moving the region of interest will 
update the histogram accordingly. The number of bins in the histogram can be adjusted by 
moving the slider above the plot. 

 

 

References 

Yi Sui (2022). Add an ROI toolbar to your figure.  

(https://www.mathworks.com/matlabcentral/fileexchange/41120-add-an-roi-toolbar-to-your-figure). 
MATLAB Central File Exchange. Retrieved April 30, 2022. 

  

https://www.mathworks.com/matlabcentral/fileexchange/41120-add-an-roi-toolbar-to-your-figure
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5.3. Color Toolbar (LUT) 
The Color Toolbar provides color adjustment through the variety of Look Up Tables (LUTs) options 
including a custom LUT generator and User-defined LUT:  

 
The first selection window displays the original color scheme, which is set to “jet” as default. The second 
selection window displays the previously selected color scheme. The following color schemes are available 
and are listed below in order from left to right: User Defined LUT, Autumn, Bone, Cool, Copper, Gray, 
Hot, Pink, Spring, Summer, Winter, Jet, HSV, Colorcube, Flag, Lines, and Prism. 

LUT generator and the User defined colormap   is described in a corresponding section (LUT 
generator) and enables generating LUT and save it for future use.  
Custom color schemes are also available (custom 1-4 LUT).  

Examples: 

Jet” Color Scheme 

 

“Gray” Color Scheme 

 

“Custom 2 LUT”

 
 

References 

Based on: US (2022). lutbar: a pedestrian colormap toolbar/context menu creator 
(https://www.mathworks.com/matlabcentral/fileexchange/9137-lutbar-a-pedestrian-colormap-toolbar-
contextmenu-creator ), MATLAB Central File Exchange. Retrieved April 30, 2022.  

  

https://www.mathworks.com/matlabcentral/fileexchange/9137-lutbar-a-pedestrian-colormap-toolbar-contextmenu-creator
https://www.mathworks.com/matlabcentral/fileexchange/9137-lutbar-a-pedestrian-colormap-toolbar-contextmenu-creator
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5.4. Camera Toolbar  
The Camera Toolbar enables you to perform a number of viewing operations interactively in 3D. You can 
select the type of camera motion control by clicking on the toolbar buttons. 

Position the cursor over the Image Display and click, hold down the right mouse button, then move the 
cursor in the desired direction. The display updates immediately as you move the mouse. 

The toolbar contains the following parts:  

 

• Camera Motion Controls: These tools select which camera motion function to enable.  

• Principal Axis Selector: Some camera controls operate with respect to a particular axis. These 
selectors enable you to select the principal axis or to select a no-axis-constrained motion. The selectors 
are grayed out when not applicable to the currently selected function.  

• Scene Light: The scene light button toggles a light source on or off in the scene (one light per axes). 

• Projection Type: you can select orthographic or perspective projection types. 

• Reset and Stop: Reset returns the scene to the view when interactions began. Stop causes the camera 
to stop moving (this can be useful if you apply too much cursor movement).  

• Camera Target: Push to select a surface point in your 3D scenery as a new camera target. This point 
becomes the center of the field of view and stays there when orbiting or rolling the camera. Clicking 
into the background restores the default camera target. 

• Axis Marker: Provides an axes marker at the chosen camera target to facilitate orientation when plot 
box boundaries are out of sight.  Colors are blue/yellow/red for the x/y/z-axis, respectively.  The length 
of the spikes is proportional to the size of the plot box. 

• Perspective: When enabled, dragging the mouse vertically changes the perspective effect of the view. 
This is achieved by simultaneously modifying the distance and the zoom factor of the camera such that 
the size of objects in the projection plane remains unchanged. 

Steps: 

1. In the default vie Camera Toolbar is on. You can remove it by clicking Open a file and select View 
→ Close Camera Toolbar or to put it back go to View → Camera Toolbar. 
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Alternatively, go to the Plots tab and select a 3D plot such as Mesh 3D, Surface 3D, Contour 3D, or 
Hybrid 3D. This action will activate Camera Toolbar.  

 

 
 

2. You can select the functions from the Camera Toolbar icons or activate the same menu using a 
right-click menu on the IMAGE DISPLAY panel. When the right click is applied the following 
menus will appear:  

Zoom: Rotation axis: 
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Camera reset:

 

Projection: 

 

Additional information:  

Once activated, the Camera Toolbar can be also used for manipulations of 2D datacube representations. 
The number of functions however is limited and might vary between the types of images. An example 
below, shows how the Zoom Camera function can be used to increase the size of the image beyond the 
image display.  

When the file is open and the Color Toolbar is activated, click the Zoom Camera icon  or select from 
the right-click menu. 

 

Position the cursor over the Image Display and click, hold down the left mouse button, then move the 
cursor toward the center to zoom.  
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3. You can reset the image back to the original by using one of the two methods: 

• Click Reset Camera and Scene Light in the Camera Toolbar. 

• Click Restore View in the Strip Toolbar, located in the right corner of the image panels.   

     or       

References: 

The algorithm is built in part using BetterCameraToolbar developed by Ulrich Reif, 2022, 

https://www.mathworks.com/matlabcentral/fileexchange/70605-bettercameratoolbar, MATLAB Central 
File Exchange. Retrieved May 2, 2022.  

https://www.mathworks.com/matlabcentral/fileexchange/70605-bettercameratoolbar
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5.5. Strip Toolbar 
Hovering over the right corner of image and plot panels reveals a drop-down menu with options for 
reversing (flipping) spectral axes, exporting the images and spectra, moving, zooming, and panning the 
image as well as viewing information about individual pixels. 

• The images and plots used in IDCube feature a hidden Strip Toolbar that can be activated by 
hovering over the right corner of the image or plot. 

• Strip Toolbar houses individual buttons. If checked the buttons turn blue.  

• The buttons from this toolbar have priority over other commands. To continue working with other 
functionalities implemented in IDCube, uncheck any buttons from the Strip Toolbar that are 
checked.  

  

Button Name Icon Description Availability 

Flip Vertical 
 

Flips Y axis on the spectral plot Only for spectral data 

Flip Horizontal  Flips X axis of the spectral plot Only for spectral data 

Save As 
    

Export options  Everywhere 

Brush 
 

Toggles data brushing mode. Only for scatter and spectral data 

Data Tips 
 

Toggles data cursor mode. Everywhere 

Rotate 
 

Toggles rotate mode. Only for 3D objects 

Pan 
 

Toggles pan mode. Everywhere 

Zoom In 
 

Toggles zoom-in mode. Everywhere 

Zoom out 
 

Toggles zoom-out mode. Everywhere 

Restore View 
 

Restores original view of axes or tiled 
chart layout. 

Everywhere 

Hovering over the 'export' button reveals a drop-down menu with options for exporting the content of the 
chart or image: 

Button Name Icon Description 

Save As 
 

Save the content as a tightly cropped image or PDF. 

Copy As Image 
 

Copy the content as an image. 

Copy as Vector Graphic 
 

Copy the content as a vector graphic. 
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Flipping spectral axes 
The direction of the axes in the spectral windows can be reversed. The default direction is from low to high 
values. Pressing ‘flip’ buttons reverse the directions of axes. Blue colors of the flip icon indicate ‘reverse’ 
direction as shown in the spectral images below. The spectral view can be returned to the original by 
pressing the buttons again.  

Y axis flipping                                                    X, Y axes flipping 

  

Adding DataTips 
Data tips are small text boxes that display information about individual data points. By default, the data tips 
include the data specified during chart creation that correspond to the individual data point.  

• Activate the DataTip icon by changing the line color to blue (or another color depending on the 
color theme of the software).  

• Interactively create data tips by clicking on data points in a chart, for example, line and scatter 
plots. Press Shift+Click to put additional DataTips. 

  
Right-click on the DataTip activates the following menu. 

Action Hotkeys Description 

Selection Style  Based on a Mouse Position.  
Snaps to Nearest Data Vertex (default). 

Display Style  Places a frame inside the figure (see the picture above on 
the right). 
Data Tip (default) (see the picture above, on the left). 

Create New DataTip   Shift+Click Creates new DataTip in addition to the existing. 

Delete Current DataTip Delete Deletes the current single DataTip. 

Delete All DataTips  Deletes all single DataTips. 

Export Cursor Data to Workspace  Only available for developers of IDCube. 
Some of the described buttons might perform additional task specific functions. The descriptions of these 
functions are considered in the corresponding applications. 
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How to do Brushing 
Brushing enables the user to interactively mark, delete, modify, and save observations in graphs. Selection 
of one or several groups of data points as shown below with single or multiple brushing groups or several 
spectra. 

   

NOTE: Not all charts support data brushing. The absence of the brushing icon indicates that this chart is 
not supported. For example, brushing for the Multi-Spectra mode is not supported. 

Mouse Gestures for Data Brushing 
You can brush graphs in several ways. The basic operation is to drag the mouse to highlight all observations 
within the rectangle you define. The following table lists data brushing gestures and their effects. 

Action Gesture Result 

Select data 
using a Region 
of Interest 
(ROI) 

ROI mouse drag ROI rectangle (or rectangular prism for 3-D axes) appears during the 
gesture and all brushable observations within the rectangle are 
highlighted. All previously made brushing marks are removed. The 
ROI rectangle disappears when the mouse button is released. 

Select a single 
point 

Single Left click on a 
graphic object that 
supports data brushing 

Produces an equivalent result to ROI rectangle, brushing where the 
rectangle encloses only the single vertex on the graphical object closest 
to the mouse. All other brushing annotations in the figure are removed. 

Add a point to 
the selection or 
remove a 
highlighted one 

Single Left click on a 
graphic object that 
supports data brushing 
with the Shift key 
pressed 

Equivalent brushing by dragging an ROI rectangle that encloses only 
the single vertex on the graphic object closest to the mouse. All other 
brushed regions in the figure remain brushed. 

Add to or 
subtract from 
ROI 

Click on ROI drag 
with the 
Shift or Ctrl keys 
pressed 

ROI grows; all unbrushed vertices within the rectangle become brushed 
and all brushed observations in it become unbrushed. All brushed 
vertices outside the ROI remain brushed. 

Work with Brushed Datapoints 
After brushing is performed, the right-click activates the following menu:  

Action Result 

Replace with Replaces the values either with Not a Number (NaN) values or constants.  
Color Enables the user to select the color. A Color Picker will be activated. The color 

will be applied with the next brushing. 
Removed Brushed Deletes brushed points. 
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Action Result 

Removed Unbrushed Deletes unbrushed points. 
Export Unbrushed... Only available for developers of IDCube. 
Paste Data to Command Line Only available for developers of IDCube. 
Copy Data to Clipboard Enables copying the data and exporting it to Excel and other software. 
Clear All Brushing Removes brushing. 
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5.6. Annotation Toolbar 
Allows the user to add text and shape outlines to the image for presentation purposes. 

Activate the Annotation Toolbar by clicking one of the icons on the toolbar. This action will activate the 
Edit Plot mode where you can move most of the objects including buttons and frames.  

 

Exit the Edit Plot mode by clicking the button   located in the Main Toolbar. NOTE: the changes 
made in the Edit Plot mode can be undone using Ctrl+Z. See more about Edit Plot mode in the dedicated 
section. 

Enclosing Regions of a Graph in a Rectangle or an Ellipse 
You can add a rectangle or an ellipse to draw attention to a specific region of a graph. While either object 
is selected, you can move and resize it as well as display a right-click context menu that enables you to 
modify behavior and appearance. Insert the rectangle or ellipse by clicking the corresponding button 

 in the Annotation Toolbar. The cursor changes to a cross indicating you can click down, drag, 
and release the left mouse button to define the size and shape of the object. 

Pinning Rectangles and Ellipses 
You can attach the rectangle to a particular point in the Image by pinning it to that point. First, click on the 

object, then select the pin icon- button in the figure toolbar . A black pin will appear. Move the pin 
close to the lower corner where the white square is and click. Pinning attaches the lower left corner of the 
rectangle or ellipse to its current location in the axes data units. You can move the point of attachment by 
clicking the corner and dragging the anchor to another point. The cursor changes to a pin while you are 
dragging. You cannot drag or resize a rectangle or an ellipse when it is pinned. 

 

 

 

 

 
Activate pin Attach pin Move pin 
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Textbox Annotations 
A textbox annotation is a rectangle that can contain multiline text. You can attach the textbox to any point 

in the figure. Insert a textbox by clicking the textbox button in the figure toolbar , then click where you 
want to place the text. The default behavior for textboxes is for them to automatically resize to accommodate 
the amount of text you enter. You can also resize the textbox after typing or click and drag the box to a 
certain size when you create it (when you do this, the textbox stays that size no matter how much text you 
place within it). 

You can also select Add Textbox from the Edit →Annotation menu. 

             

This action also activates Edit Plot mode. To exit the mode and return to the main features press icon  
located in the Main Toolbar.  

Selecting Textbox Objects 

The textbox must be first activated using the Edit Plot button located in the Main Toolbar : 

• To move the textbox, click the text once to select it. 

• To edit the text, double-click within the box. 

Pinning the Textbox 
You can attach the textbox to a particular point in the Image by pinning it to that point. Select the pin button 

 in the Annotation Toolbar and click a handle of the textbox. By default, pinning attaches the lower 
left corner of the textbox to its location in the axes data space. Move the point of attachment by clicking on 
the corner and dragging the anchor to another point, but you cannot drag the textbox when it is pinned. 
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Annotation Lines and Arrows 
Add lines and arrows to a graph and attach them to any point in the Image. The three types of arrows 
include: 

• Single-headed arrow 

• Arrow with attached text box (text arrow) 

• Double-headed arrow. 

Insert a line or arrow by clicking the appropriate button in the Annotation Toolbar , then 
click down, drag the line or arrow to the desired point, and release the mouse. The arrowhead appears at 
the terminal end. With the line or arrow selected, right-click to display the context menu, which provides 
access to several options. 

Inserting a Text Arrow 
A text arrow combines a textbox with an arrow. It is useful for labeling points on a graph. Add a text arrow 
to a graph by selecting the arrow button that has a T above the arrow. Insert the text arrow and type text in 
the box.  

  

You can also select Add Textbox from the Edit → Annotation menu. This arrow has a preset design with 
an orange textbox attached. The design can be changed.  

      

This action also activates Edit Plot mode. To exit the mode and return to the main features press icon 
located in the Main Toolbar.  

Pinning the Arrowhead End 
Attach the arrowhead end to the point of interest on the Image while letting the text box automatically 
reposition itself as you zoom or pan the graph. 

Select the Pin button in the Annotation Toolbar. 
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Changing the fonts 

Use the following icons to change the font and color of the font: . Double-click inside 
the object (textbox or text arrow), click on the font icons, and select the font and/or the color.  

 

Coloring Texts and Objects 
NOTE: Color Picker blocks interaction with other windows until the user closes it.  

Coloring of the annotation uses Color Picker apps that are activated with the right-click menu or using 

the corresponding icons  from Annotation Toolbar. 

Two options can be implemented and selected from the top right buttons (shown with arrows): 

• The Standard Colors app (default). 

• The Custom Colors app. This color picker provides a tab for selecting custom colors from a 
gradient as well as intensity. Move the vertical slider to display the desired region of color space. 
Then click the color gradient to select a color. This app also offers a dropdown menu to select or 
input the desired color. 
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Group Option Description 

Standard Colors Preset colors  Allows the user to select the color by clicking on it. 
Custom Colors RGB [0, 1] Enables the user to input RGB triplet interactively as the red, green, and 

blue components of the selected color. The intensities must be in the 
range [0 - 1]. 

 RGB [0, 255] Enables the user to input RGB triplet interactively as the red, green, and 
blue components of the selected color. The intensities must be in the 
range [0 - 255]. 

 Hex Enables the user to input a Hex number (interactively and manually) of 
a color. 

 HSV Enables the user to input HSV triplet interactively as the Hue (H), 
Saturation (S), and Value (V) components of the selected color. Hue is 
selected with the scalebar on the left (range 0-360 degrees), S and V are 
from 0 to 100.  

Removing and Editing Annotations 

You can delete or modify any annotation by clicking an Edit Plot button   icon located in the Main 
Toolbar. You will have to click this button again to exit the interactive layout. 

  



v. 2.78   

39 
 

5.7. Interactive Colorbar 
Adds additional interactive features to the existing colorbar to improve visualization and customization of 
the monochromatic image. Activate the Interactive Colorbar menu by making a right click.  

 
Select from the following options: 

Button Name Description Default Comment 

Delete Deletes the toolbar. n/a  
Location Displays the colorbar in a specific location such as 

'north outside. 
East outside  

Standard colormap Choose from the preset colormaps: 
cool, gray, hot, hsv, jet, turbo and parula. 

parula  

Interactive colormap 
shift 

Interactively changes the distribution of color 
values within automatically assigned limits. 

n/a Activates interactive 
layout. 

Open colormap editor Adjusts scale and customized LUTs, not available 
for IDCubePro® users. 

n/a  

Open Property 
Inspector 

Analyze properties of graphical objects, not 
available for IDCubePro® users. 

n/a  

Show Code Not available for IDCubePro® users. n/a  

Colorbar Location:  
To change the position of the colorbar, Right click on the colorbar and select Location. An example below 
shows the North Outside location.  

 
 

 

 Channel: 1021, Bandwidth: , Image quality: 41.90

0 1000 2000 3000 4000 5000 6000
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Standard Colormaps  
To change the colormap, Right click on the colorbar and select Standard Colormaps. A list of standard 
colormaps is given in the table below. NOTE: a large number of colormaps are available from the toolbar 
menu.   

Colormap Name Description 

cool 
 

gray  
hot 

 
hsv 

 
jet 

 
tubo 

 
parula (default) 

 
 

 

Interactive Colormap Shift:  
To shift the mapping of data values into the current colormap, Right click on the colorbar and 
select Interactive Colormap Shift. Then, select a color in the colorbar. The cursor will change its shape 
to a double-headed arrow with a vertical line inside. The entire colorbar will be flanked with four blue 
squares indicating the activation of the Edit Plot mode.  

 

Press the left button on the mouse and drag the cursor. As you drag, the mapping of data values into the 
colormap shifts. When complete, leave the interactive mode by unchecking Interactive Colormap Shift 
(Right click on the colorbar and select Interactive Colormap Shift again), or pressing the Edit Plot button 

 from the Main Toolbar. The Edit Plot button should turn grey. 

Tip: In some cases, it is difficult to activate the cursor when the colorbar is in a vertical (i.e., east or west 
orientation, see above). If that is the case, change to a different position (i.e., north colorbar position), and 
then adjust the colors. You can then return to your desired colorbar position. The colormap values will not 
be affected.   
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6.  Panels 
6.1. Image Display Panel 

NOTE: PAVIA dataset is used as an example. 

Basic Information 
The panel presents 2D or in certain cases 3D representations of the dataset. Changes in the image can be 
made by a variety of commands and functions from most of the panels and Tabs. 

Panels affecting Image Display Description Effect 

Toolbar panel Applies colormaps and annotations. Global to the entire datacube 
Data Reduction panel Applies changes the size and binning. Global to the entire datacube 
Datacube Mathematics panel Applies mathematics to the image. Global to the entire datacube 
Interactive Band/Channel 
Selection panel 

Select different bands and their 
combinations. 

Only to the current frame 

Image Adjustment panel Optimize the visualization of the 
image. 

Only the current frame (can be made 
global) 

Frame-by-Frame panel Animates the frames. Global to the entire datacube 
 

Tabs affecting Image Display Description  

View Adds scale. Only to the current frame 
Edit Changes the size of the dataset, 

binning. 
Global to the entire datacube 

Plots Modifies the plots of the current frame. Only to the current frame 
Filtering and enhancements Applies filters, enhancements, quality 

controls, and other functions to the 
entire datasets. 

Mostly global to the entire datacube 

Data correction Applies corrections to the dataset. Mostly global to the entire datacube 

Image Zoom and Pan 
The presented image can be zoomed in and panned. The Image Display also serves as a gateway to spectral 
analysis. 

Zoom and Pan can be used in three different ways: 

• Mouse Wheel 

• Mouse Drag 

• Strip Toolbar 

1.10. Using Keyboard and Mouse shortcuts (see section Computer 
Information Panel     

Features: 



v. 2.78   

42 
 

1. The COMPUTER INFORMATION panel provides real-time information about the user’s PC CPU and 
memory usage.  

2. CPU data is displayed as a percentage (%) of the PC’s capacity.  

3. Memory is displayed in megabytes (MB).  

 

 
 
 

The “Monitor” button starts/resumes the information collecting process.  

 

The “Stop” button pauses the information-collecting process. Functionality can be resumed by pressing the 
“Monitor” button.  
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‘Smart’ Zoom (via Mouse Wheel) 
Smart Zoom enables the user to click on any pixel of the image and start zooming the around the pixel by 
using the wheel of the mouse. The selected pixel remains in the center of the image. 

Pan (via Mouse Drag) 
In the zoom mode, you can pan the image by the right-click, holding the button down (the cursor turns into 
a hand), and moving the image. You can also combine the right-click while pushing down with the 
keyboard arrow keys to perform panning. 

Using Strip Toolbar 
This toolbar has Pan, Zoom in, Zoom Out, and Restore View buttons.  

 

  



v. 2.78   

44 
 

Right Click Menu in the Image Display Panel 

Features: Enables the user to activate specific functions in the IMAGE DISPLAY panel through the right-
click menu. 

Steps: 

1. Load a file and Right click on the image in the IMAGE DISPLAY panel. 

 
2. Select an option from the following menu: 

Option Description 

Copy Image Copies the current image without any additional information. 
Copy Image with Annotations 
 

Copies the current image with the additional information (i.e., 
RGB [w1=586, w2=730, w3=742], Bandwidths (bw1=, bw2=, bw3=), 
Contrast=0%, Quality:13.83). 

Save Image As… 
 

Saves the current image in png, jpeg, or tiff format with no additional 
information attached. 

Save Image with Annotations 
As… 

Saves the current image in png, jpeg, or tiff format with Annotations. 

Save As a Label file… 
 

Saves the current image in png, and mat formats for machine learning 
applications. 

Save ROI Average Spectrum In 
ECOSTRESS Format. 

Provides interactivity to select the region of interest and saves the average 
spectrum in ECOSTRESS format to use elsewhere. For example, Spectral 
Matching Toolbox. 

Alternatives:  

Saving images in different formats is also available from the Strip Toolbar; however, the format of saving 
and the size of images might be different from the Right click menu. Saving an average spectrum from the 
selected area in the ECOSTRESS format is also available from SPECTRAL ANALYSIS panel.  

References 

Dany Cabrera (2022). Image Mouse Zoom and Pan (https://github.com/danyalejandro/imgzoompan), 
GitHub. Retrieved May 2, 2022.  

Ned Gulley (2022). Zoom Keys (https://github.com/gulley/Ax-Drag), GitHub. Retrieved May 2, 2022. 
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6.2. Data Reduction Panel 
The panel enables changes to the size of the dataset by either cropping (spatially and spectrally) or binning 
(spatially and spectrally). These functions are applied globally for the entire datacube.  

NOTE: PAVIA dataset is used as an example.  

Spatial Crop Interactive 

Features: Enables spatial cropping of the entire dataset. 

Steps: 

1. In the DATA REDUCTION panel click Select Crop (also can be triggered by using an icon  ) 
or using Edit → Crop → Spatial Crop.  

Spatial crop activates an interactive rectangular (active frame) that enables the user to select the 
region of interest and crop the rest of the image. (Press the Spatial Crop button again to deactivate 
the crop function). 

2. Move the boundaries of the active frame with the mouse. The coordinates of the frame in 
a format [left bottom width height] can be seen below the image. The units are pixels. When 
the active frame size is adjusted, IDCube automatically updates the coordinates to the new 
values.  
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3. Click Apply Crop. The change will be applied globally and a new datacube will be stored in the 

internal memory, without erasing the original data. A new pop-up window with information about 
the spatial dimension of the new dataset will appear in the left corner showing the dimension of 
the new frame, type of data, color, maximum, and minimum. In the case of the RGB, the maximum 
and minimum will not be shown. Click Reset Image to return to the original datacube (NOTE: 
all other changes will also be eliminated). 

4. (Optional) The new dataset can be saved using a standard Save Data As…→ Save as IDCube 
format or Data Export function and opened as a new datacube.  

Spatial Crop by Coordinates 

Features: You will be able to specify the X/Y Position and X/Y Dimension to crop the datacube. 

Steps: 

1. Open a file. 

2. In the DATA REDUCTION panel enters the values under Spatial Crop by Coordinates. This 
method enables the user to apply the same crop coordinates across other images. For that, select 
the anchor point (X coordinate, Y coordinate), and the dimension in both X and Y directions from 
the anchor.  

3. Activate by clicking Confirm area button then click Apply Crop. The spatially cropped image is 
saved in the memory of IDCube, but the original image is not affected. A window Image 
Information will pop up with the updated information about the new dataset.  

4. Click Reset to return to the original image.  
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Spectral Crop 

Features: Enables spectral cropping of the entire dataset. 

Steps: 

1. Load a file. 

2. In the DATA REDUCTION panel enters the values in the Lower and Upper Limits. This will cut 
the z-dimension of the datacube from both sides. Click Clear to empty the fields. 

 
3. Click Apply. The new datacube will be spectrally cropped. The original data will not be affected. 

4. Click Reset to return to the original image.  

Alternatively, this can be done from the Edit → Crop → Spectral Crop function available from the Menu 
Bar. 

A pop-up dialog will ask for the lower and upper limit of channels (i.e., wavelengths) with the default values 
showing the current lowest and highest channels. Enter the values and click Apply Cropping. The original 
data will not be affected. 
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Spatial Binning 

Features: Performs spatial binning of the entire dataset to decrease the number of pixels. 

Pixel binning is the process of combining neighboring pixels into a larger pixel. This larger pixel represents 
the area of all the individual pixels. For example, in 2 x 2 binning, the signal from a square of 4 adjacent 
pixels is combined into 1, and in 3 x 3 binning, the signal from a square of 9 adjacent pixels is combined 
into 1. Binning decreases the size of the file and provides averaging.  

 
Steps:  

1. Open a file. In the DATA REDUCTION panel enters a single value for the Spatial Binning.  For 
example, the value 3 will indicate 3 x 3 binning. Press Apply and Spatial Binning will be applied 
to the entire datacube. Click Clear to empty the field.  

         
2. Click Reset to return to the original datacube. In that case, all changes to the datacube will be 

rejected.  
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3. (Optional) The new dataset can be saved using a standard Save Data As… → Save as IDCube 
format.  

Alternatively, Spatial Binning can be performed from the Edit → Binning → Spatial Binning function 
available from the tab. Enter the number and click Apply Binning. 

 

Spectral Binning 

Features: Performs spectral binning of the z-direction of the datacube to decrease the number of 
bands/channels. 

Spectral binning is the process of combining neighboring individual bands into a single band. For example, 
in 2 binning, the signal from 2 adjacent bands is combined into 1, and in 3 binning, the signal from 3 
adjacent bands is combined into 1. Spectral Binning decreases the size of the file and provides averaging 
across the bands.  

Binning options Combined bands 

None           

2           

3           

4           

 

This function is not available from the DATA REDUCTION panel but is available from the Edit Tab → 
Binning → Spectral Binning. Enter the number and click Apply Binning. 
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6.3. Data Export Panel  
NOTE: PAVIA dataset is used as an example. 

Features: Enables the user to export a part of or all of the dataset into a variety of formats including tiff, 
raw/HDR, commonly used by a variety of data acquisition systems, such as ENVI, Inc, and Excel.  

Steps: 

Load the image file and select the Data Export tab. Available options are: 

• Convert to a tif/tiff stack 

• Convert to a raw/HDR file  

• Convert the entire datacube into Excel 

• Convert the selected region of interest into Excel  

• Convert the current image into Excel  

o Convert the mean spectrum into Excel 

o Convert all spectra into Excel  

• Convert the current image into Excel  
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Convert into a tiff Format  
This option saves the images into a stack of frame-by-frame tiff files. 

Select a TIF/TIFF radio button and click Convert. You will be asked to select a folder. The current 
directory will be your default folder. The stack of tiff files will be automatically saved in the specified 
directory.  

 

Convert into a raw/hdr Format  
This option saves the entire dataset into one of the most common industry-standard hyperspectral imaging 
formats used by ENVI Inc., and other companies.  

Select a raw/hdr radio button and click Convert. You will be asked to select a folder. The current directory 
will be your default folder. The conversion will generate two files (raw and hdr) in the specified directory. 

 

Convert into an Excel Format 
When this option is selected three other options will be offered: i) convert the entire datacube into Excel, 
ii) convert spectra from the selected regions into Excel, and iii) convert the current image into Excel.  

 

Convert the Entire Datacube into the Excel format  
Click Save As… and select the name of the file. Click Save. A pop-up message will warn that this operation 
might take a long time.  
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A pop-up message box will inform when the conversion is complete. 

 
The number of tabs is equivalent to the number of bands/channels. For example, Pavia has 103 channels.  

 

Convert the Spectra into Excel format 
This option is interactive. You can either select a single spectrum from the image by clicking somewhere 
on the image or select a region of interest by drawing a rectangle. Click Save As… and select the name of 
the file. Click Save.  

Convert Mean Spectrum from the Area 
Select Mean spectrum from the area and click Select Area. Point to a specific location or draw a rectangle 
over the image and click Save As… Select a folder and enter the name of the file. Click Save. A pop-up 
message box will inform you when the conversion is complete. 



v. 2.78   

53 
 

 
Open the saved Excel file. NOTE that the wavelength values are preserved in the first column. 

 

Convert All Spectra from the Area 
Select All Spectra from the Area and click Select Area. Draw a rectangle over the image and click Save 
As… Select a folder and enter the name of the file. Click Save. When the conversion is complete a popup 
message box will appear. 

Open the saved Excel file. The left column represents bands/channels. NOTE: that the wavelength values 
are preserved.  
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Convert the Currently Displayed Image into Excel Format 
Click Save As… select the folder and enter the name of the file. Click Save. When the conversion is 
complete a popup message box will appear. 

 
Open an Excel file. The rows and columns represent the spatial dimension of the saved image.  

 
Alternatives: Some of the functions can be also activated through the File → Export IDCube to other 
formats.  
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6.4. Datacube Mathematics Panel 
NOTE: PAVIA dataset is used as the example 

Features: 

• Enables image algebra to be performed on the entire dataset. 

• Enables broadband image analysis. 

• Performs mathematics on the image offering more than 50 math functions. 

• Saves the new datacube. 

  Steps (could be used in a different order): 

1. Load the data using File → Open. 

 

Single Channel 
Check the Single Channel radio button. This will activate a Single Channel in the CHANNEL 
SELECTION panel. Alternatively, you can click the Single Channel radio button. 

The user can select any single wavelength as well as the bandwidth. The image will be immediately updated 
with the new image.  

The slider automatically detects the highest and lowest band. If no wavelengths of other units are assigned, 
the slider will follow the number of the detected bands starting from #1. You can also type the band 
number/channel, etc. number.  
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Broadband 
Check the Broadband radio button. That will automatically select the Two-Channel option in the 
CHANNEL SELECTION panel. The broadband will correspond to the wavelengths between wavelength 
1 and wavelength 2, (i.e., from 442 to 698 nm) as shown below. NOTE: that bandwidths will be deactivated 
when Broadband is selected. 

 

Image Algebra 
Check the Image Algebra radio button. That will activate a dropdown menu with preselected commonly 
used algebra and logical functions. This selection will automatically activate the Two-Channel option in 
the CHANNEL SELECTION panel.  
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Table 1. Functions implemented in Image Algebra 

 Description Number of bands Mathematical Expression or 
function  

 None (default)  Single Band w1  
 Inverse image  Single Band 1/w1 
 Image complement  Single Band imcomplement(w1) 
 First derivative  Single Band gradient(w1) 
 Second derivative  Single Band gradient(gradient(w1)) 
 Summation  Two Bands w1 + w2 
 Simple Ratio  Two Bands w1./w2   
 Normalized Ratio   Two Bands (w1-w2)/(w1+w2) 
 Weber Ratio   Two Bands (w1-w2)/w2 
 Log10[Ratio]   Two Bands Log10(w1./w2) 
 Multiplication   Two Bands w1 x w2 
 Log10[Multiplication]   Two Bands Log10(w1 + w2) 
 Logical AND   Two Bands w1 AND w2 
 Logical OR   Two Bands w1 OR w2 
 Logical XOR   Two Bands w1 XOR w2 
 Absorbance from Transmission Single Band A=2-log10(T) 
 Transmission from Absorbance Single Band %T=10^(2-A) 

 

IMPORTANT: The changes induced by the functions implemented by Image Algebra are global 
and applied to the entire datacube. These changes are passed to other functions, filters, toolboxes, 
etc. but not passed to other Image Algebra functions. Since the changes are global use the Reset 
button when you need to remove the effect of the function.  

If you selected one function from the Image Algebra dropdown menu and then another, the previous 
function will be canceled, the dataset will be reset to the original datacube and a second function will be 
applied.  

Pressing the Get Image button will have no additional effect.  

If a Two Bands function is applied, the new datacube will use the first band (w1) as a variable and the 
second band (w2) as a constant.  

 
A message box Converting the datacube will inform when the conversion is completed. To verify that the 
conversion was successful, check Real-Time Spectrum from the SPECTRAL ANALYSIS panel.      
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The function is activated immediately after its selection from the Image Algebra dropdown menu. Clicking 
Get Image will repeat this function. 

You can save the new datacube via File → Save Data As… → Save in IDCube format (Ctrl+S) or Right 
click on the image and select Save New Datacube in IDCube Format… and select a folder where a new 
file will be stored. Alternatively, Right click on the IMAGE DISPLAY panel and select Save New 
Datacube in IDCube Format… and select a folder where a new file will be stored.  

Custom Functions 
Select the Custom Functions radio button. This will automatically activate an interactive field where the 
user can type an equation. After entering an equation, click the green Get Image button. The produced 
image will be seen on the IMAGE DISPLAY panel. You can change the bands to visualize individual slices. 

IMPORTANT: The changes induced by the functions implemented in Custom Functions are not 
global and do not apply to the entire datacube. These changes are not passed to filters, toolboxes, etc. 
The changes are only temporally and therefore other commands will remove the effect of the custom 
function. To store the entire datacube affected by the custom function, Right click on the image and 
select Save New Datacube in IDCube Format… and select a folder where a new file will be stored. 

 

 
Format and Notation  

Type an equation using the following format: 

Examples:     w1 + w2 

sin(w1+w2) 

sin(w1./w2) 

sin(w1.*w2)  (use dots for divisions and multiplications) 

Up to three selected channels are supported. Use w1, w2, or w3 and their combinations. Combine any of 
the functions with other functions: 
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Examples:        log(sin(sqrt(w1.*w2))) 

fftshift(erf(cos(w1))) 

The list of equations and functions supported by IDCube is given in Appendix 1.    
6.5. Interactive Band/Channel Selection Panel 

NOTE: Plastic and Coin dataset (cropped) is used as an example.  

The panel consists of several functional units: Single channel visualization, Two - channel visualization, 
Three - channel visualization, Bandwidths, and Constant Saturation. 

 

Single Channel Visualization   

Features: 

Use this option to visualize the image at any single band/channel. The resulting image will be 
monochromatic.   

Steps: 

1. Open a file. The default view is monochromatic using a randomly selected single channel. Both 
DATACUBE MATHEMATICS and CHANNEL SELECTION panels will show Single Channel 
radio button clicked. 

2. Change the values of Bands/Channels 1 by either entering values in the boxes or using sliders.  
The main image will be automatically updated. The input values along with other information will 
be added to the caption under the main image.    
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3. The values for each pixel can be visualized by clicking a Data Tips icon on the Strip Toolbar and 
pointing to the pixel of interest. Data Tip shows the coordinate, the intensity of the pixel (index), 
and the assigned color using the RGB notation (normalized to 0-1).  

 
(Optional). You can increase the number of bands assigned to each channel by entering values in the 
BANDWIDTHS panel.  

(Optional). You can fine-tune the image by adjusting histograms in the HISTOGRAM panel.  

Pressing the Reset button will return the image to the original unprocessed state in the monochromatic 
mode.  

Notes: 

Large datasets might cause a delay in updating the slider value and the image. Click the green Get Image 
button to ensure the effect. 

The sliders work well for a relatively large number of bands that are uniformly distributed. For a small 
number of bands (10 or less, i.e., in multispectral imaging) adding the values manually might be necessary. 

Two-Channel Visualization 
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: Use this option to visualize the image of any combinations of two bands/channels and the 
corresponding mathematics using preset Image Algebra functions. The resulting image will be 
monochromatic.   
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Steps:  

1. Open a file. The default view is monochromatic using a randomly selected single channel. Select 
Two-Channel from the CHANNEL SELECTION panels. DATACUBE MATHEMATICS panel 
should automatically select the Image Algebra radio button. Alternatively, you can select the 
Image Algebra radio button first. 

2. Apply any mathematics available from the Image Algebra dropdown menu in the Datacube 
Mathematics. 

 

Preset functions Number of channels Description 

None 1 No math is applied 
Inverse image 1 1/w1 
Image complement 1 imcomplement (w1) 
Log10 1 Log10(w1) 
First derivative 1 diff (w1) 
Second derivatives 1 diff (diff (w1)) 
Summation 2 w1 + w2 
Subtraction 2 w1 - w2 
Simple Ratio 2 w1 / w2 
Normalized Ratio 2 (w1 - w2)/(w1 + w2) 
Weber ratio 2 (w1 - w2)/w2 
Log10(Ratio) 2 Log10 (w1 / w2) 
Multiplication 2 w1 × w2 
Log10(Multiplication) 2 Log10 (w1 × w2) 
Logical AND 2 w1 AND w2 
Logical OR 2 w1 OR w2 
Logical XOR 2 w1 XOR w2 
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3. Change the values of Bands/Channels 1 and Bands/Channels 2 by either entering values in the 
boxes or using sliders. The main image will be automatically updated. The input values along with 
other information will be added to the caption under the main image. 

 

 

 
4. The values for each pixel can be visualized by clicking a Data Tips icon on the Strip Toolbar and 

pointing to the pixel of interest. Data Tip shows the coordinate, the intensity of the pixel (index), 
and the assigned color using the RGB notation (normalized to 0 -1). 

 
Pressing the Reset button will return the image to the original unprocessed state in a monochromatic mode.  

You can increase the number of bands assigned to each channel by entering values in the BANDWIDTH 
panel. You can fine-tune the image by adjusting histograms in the HISTOGRAM panel or changing the 
range of the intensities by entering numbers in the Intensity Scale.  
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Large datasets might cause a delay in updating the slider value and the image. Click the green Get Image 
button to ensure the effect. The sliders work well for a relatively large number of bands that are uniformly 
distributed. For a small number of bands (10 or less, i.e., in multispectral imaging) adding the values 
manually may be necessary. 

Three-Channel Visualization (Custom Functions) 
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: Use this option to visualize the image of any combinations of one, two, or three bands/channels 
using many preset Custom Functions. The functions should be typed into the interactive field. The resulting 
image will be monochromatic.   

Steps: 

1. Open a file. The default view is monochromatic using a randomly selected single channel. Select 
Three-Channel from the CHANNEL SELECTION panel. DATACUBE MATHEMATICS panel 
should automatically select the Custom Functions radio button and activate an interactive field for 
entering an equation. 

2. Type a valid equation using an appropriate notation from the list of functions or their combinations 
from the list of available functions. You can use one, two, or three bands denoted as w1 
(Band/Channel 1), w2 (Band/Channel 2), and w3 (Band/Channel 3). 
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1. Change the values in Bands/Channels 1 - 3 by either entering a value in the box or using sliders. The 

main image will be automatically updated. The input values along with other information will be added 
to the caption under the main image.    

2. The values for each pixel on the Image can be visualized by clicking a Data Tips icon on the Strip 
Toolbar and pointing to the pixel of interest. Data Tips show the coordinate, the intensity of the pixel 
(index), and the assigned color using the RGB notation (normalized to 0 - 1).  

3. (Optional). You can increase the number of bands assigned to each channel by entering values in the 
BANDWIDTHS panel.  

4. (Optional). You can fine-tune the image by adjusting a histogram in the HISTOGRAM panel or 
changing the range of the intensities by entering numbers in the INTENSITY SCALE panel.  

Saving: Custom Function only changes the current image and does not generate a new datacube like 
some other functions. IDCube Pro enables the user to save the entire datacube after the results of the 
custom function. If more than one variable (w1, w2, w3) is selected, only w1 will be used as a spectral 
variable. Other variables such as w2 and w3 will be used as constants. The image below shows the 
effect of the fft function (Fourier transform) on the image.  

5. To save the datacube, Right click on the Image Display and select Save New Dataset in IDCube 
format. You can then open the new datacube through the File → Open Dataset in IDCube format 
(Ctrl+O).  

 
Pressing the Reset button will return the image to the original unprocessed state in the monochromatic 
mode. The RGB channel values will be remembered. 



v. 2.78   

65 
 

Notes: 

Large datasets might cause a delay in updating the slider value and the image. Click the green Get Image 
button to ensure the effect.  

The sliders work well for a relatively large number of bands that are uniformly distributed. For a small 
number of bands (10 or less, i.e., in multispectral imaging) adding the values manually might be necessary.  

You can increase the number of bands assigned to each channel by entering values in the BANDWIDTHS 
panel. You can adjust the Contrast Saturation of the image by entering the number from 0 (default) to 49.  
You can fine-tune the image by adjusting histograms in the RGB HISTOGRAM panel.  

Additional Information:  

For the list of Functions and Expressions that can be used in IDCubePro® see section Appendix 1.  

Visualization with Pseudo RGB 
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: 

Use this option to visualize the image at any three different bands/channels as a pseudo-RGB image. In this 
mode, you can assign any band.   

This feature is mostly for visualization and can work with other visualization functions (histogram, contrast 
saturation, cropping, etc.).  

 
Steps: 

1. Open a file. The default view is monochromatic using a randomly selected single channel. 

2. In the CHANNEL SELECTION panel selects RGB mode. IDCube automatically and randomly 
assigns values to all three channels.  

 

Each Band/Channel is assigned to a specific true color.  
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Band/Channel Color 

#1 red 
#2 green 
#3 blue 

3. Change the values of Bands/Channels by either entering values in the boxes or using sliders.  The 
main image will be automatically updated. The input values along with other information will be 
added to the caption under the main image.  

 
The RGB values for each pixel can be visualized by clicking a Data Tips icon on the Strip Toolbar and 
pointing to the pixel of interest. The scale of the colors using a standardized 0 to 255 scale normalized 
between 0 and 1. 

 
You can increase the number of bands assigned to each channel by entering values in the BANDWIDTHS 
panel.  

You can adjust the Contrast Saturation of the image by entering the number from 0 (default) to 49.  You 
can fine-tune the image by adjusting histograms in the RGB HISTOGRAM panel.  

Pressing the Reset button will return the image to the original unprocessed state in the monochromatic 
mode but will remember the values for the RGB channels.  
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Additional Information: 

Large datasets might cause a delay in updating the slider value and the image. Click the green Get Image 
button to ensure the effect.  

The sliders work well for a relatively large number of bands that are uniformly distributed. For a small 
number of bands (10 or less, i.e., in multispectral imaging) adding the values manually might be necessary. 

Bandwidths  
NOTE: Plastic and Coin dataset is used as an example. Example is given for the RGB mode. 

Features:  

Use this option to broaden the band as shown below and treat the resulting group as a single band. For 
example, in the RGB mode, you can include additional bands on every color channel.  

This function can be used with any Channel Selection: Single Channel, Two-Channel, Three-Channel, 
or RGB.   

This feature is for visualization only and can work with visualization functions (histogram, colormaps, etc). 
The entered bandwidths do not pass to other functions that treat input as single bands. 

 

Steps: 

1. Load the file. 

2. Select the bands of interest in Band/Channels. Those are the center bands.  

3. Go to the BANDWIDTH panel and add values to Ch1 through Ch 3. The bandwidth indicates how 
many bands/channels will be combined to generate the image.  

4. Click Apply and observe the image. The information about the bandwidths can be seen in the 
caption under the image.  
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Additional Information: 

The current version of the software sums the signal from several bands grouped into one band.  

Contrast Saturation  
NOTE: PAVIA dataset is used as an example. 

Features: 

Enables the user to adjust the image visualization by changing the contrast saturation. Contrast saturation 
is preserved for any further changes activated from Main Interface but is not transferred to Toolboxes. 
Only available for the RGB mode. The original data are not affected. 

Steps: 

1. Load the image file and select RGB from the CHANNEL SELECTION panel: 

 
2. Put a value in Contrast Saturation % between 0 and 49.9 (default 0). A higher level of contrast 

saturation will make the image with higher contrast and often darker. To remove the contrast 
saturation, put a zero in the Contrast Saturation field.  

 

Contrast Saturation  Contrast Saturation  Contrast Saturation Contrast Saturation 
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= 0 (Original) = 10 = 20 = 30 

    

Additional Information: 

The algorithm maps the values in true-color image RGB to new values by saturating the bottom N% and 
the top N% of all pixel values, where N is the value inputted into the textbox. The same mapping is applied 
to each channel.  
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6.6. Histogram Image Adjustment Panel 
NOTE: PAVIA dataset is used as an example. 

Features: 

Enables the user to optimize the view of the image using an interactive HISTOGRAM panel. Works in 
both, monochromatic mode and an RGB mode.  

Monochromatic mode  
1. Select the Monochromatic tab in the HISTOGRAM panel. To adjust the image, move either a 

magenta (minimum) or cyan (maximum) boundary line. The changes can be seen in the Min and 
Max fields located under the histogram.  

a. The Bins number enables the user to change the number of the histogram bins. The default 
level is 500, this quantity depends on the spatial size of the image, and smaller files might need 
a lower number of bins. 

 
The changes in the images will be immediately visualized: 

a. In the HISTOGRAM MODIFIED IMAGE panel located below the HISTOGRAM PANEL 
(default). 

b. In the IMAGE DISPLAY panel if the View on Image Display checkbox is checked.  

 

You can also expand the image by clicking on it. 
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NOTE: After adjustment the histogram you can save the entire dataset as a new file. Select File → Save 
Histogram-Modified Dataset and select a destination folder. By default, the current folder will be opened. 
You can create a different folder. Press Select Folder. For details see Save Histogram-Modified Dataset 
section). 

RGB mode  
Select the RGB histogram tab in the HISTOGRAM panel or select RGB in the CHANNEL SELECTION 
panel. To adjust the image, move either a white (minimum) or orange (maximum) boundary line in each of 
the channels (Red, Green, or Blue). The scale of the channels is between 0 and 1.   

 
1. The changes in the images will be immediately visualized:  

a. In the HISTOGRAM MODIFIED IMAGE panel located below the HISTOGRAM PANEL 
(default). 

b. In the IMAGE DISPLAY panel if the View on Image Display checkbox is checked.  

2. You can also expand the image by clicking on the image. 
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6.7. Image Enhancement Panel 
The main feature of the panel is to improve the visualization of the 2D representation of the datacube. This 
is performed using an image histogram.  

An image histogram is a gray-scale value distribution showing the frequency of occurrence of each gray-
level value. Modification of image histograms is commonly used in image enhancement procedures.  

IDCube calculates the histogram for both the grayscale image and the RGB-type image. The number of 
bins in the histogram can be changed (default = 500) and is determined by the image type and size. Larger 
images might require a larger number of bins. IDCubePro® enables the user to control the number of bins. 

IDCube also enables the user to modify the image by controlling the boundaries of the histogram. In the 
unprocessed image, all pixels have an intensity and are presented in the histogram. Moving boundaries in 
the HISTOGRAM panel allow you to remove some of the pixels with abnormally high or low intensities. 
These pixels are eliminated from the image. The boundaries can be controlled interactively by grabbing 
and moving the boundaries or by entering the values in the appropriate fields. 

HISTOGRAM panel for monochromatic images:  

  

HISTOGRAM panel for RGB images: 
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Monochromatic Histogram    
NOTE: Plastic and Coin dataset is used as an example. 

Features: 

Enables adjustment of the monochromatic images via interactive histogram manipulation. The changes in 
the image are first observed in the HISTOGRAM MODIFIED IMAGE panel. 

In the case of monochromatic images, you can set the range of intensities for all frames in the dataset. 

 Steps: 

1. Open a file. The histogram will be generated automatically. 

2. Select the 1st tab in the HISTOGRAM panel. To adjust the image, move either red (minimum) or 
green (maximum) boundaries. The changes can be seen in the Min and Max fields located under 
the histogram. The Bins Number enables the user to change the number of the histogram bins, 
default 500. This quantity depends on the spatial size of the image, and smaller files might need a 
lower number of bins.  

 
The changes in the images can be visualized in two windows:  

• In the HISTOGRAM MODIFIED IMAGE panel located below the HISTOGRAM PANEL 
(default). 

• In the main IMAGE DISPLAY panel, if the View on Image Display checkbox is checked.  

The changes induced by the monochromatic histogram can be applied globally to the entire dataset.  

3. For that click Transfer Min-Max to Intensity scale. The INTENSITY SCALE panel located on 
the bottom left will display the new values.  

4. Click Apply. You will see that the colorbar on the IMAGE DISPLAY panel will reflect the new 
boundaries. Click Clear to remove values and clear the fields.  
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RGB Histograms 
NOTE: PAVIA dataset is used as an example. 

Features: Enables adjustment of RGB images via manipulation of the interactive histogram. 

The changes in the image are first observed in the HISTOGRAM MODIFIED IMAGE panel. The changes 
are only applied to the shown image. Changes in the wavelengths will bring the histogram's min and max 
values back to the default values. 

Steps: 

Select the RGB histograms tab in the HISTOGRAM panel. To adjust the image, move white (minimum) 
or orange (maximum) boundaries on any of the three-histogram panels corresponding to three color 
channels (Red, Green, and Blue). The default scale for each color histogram is from 0 to 1. 

Move the boundaries to change the values. In contrast to the monochromatic images, the Bins number is 
fixed at 500.  

 
The changes in the images can be visualized in two panels:  

• In the HISTOGRAM MODIFIED IMAGE panel located below the HISTOGRAM panel (default). 

• In the main IMAGE DISPLAY panel by clicking the textbox View on Image Display to change 
the visualization panel. 

Click Reset to change the histograms and entire image back to the default level.  
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6.8. Spectral Analysis Panel 
NOTE: PAVIA dataset is used as an example. 

Features: 

1. Interactively presents spectra at individual pixels. 

2. Shows spectra from the selected region of interest (with or without standard deviation). 

3. Calculates interactions between the selected spectra that are related to a specific region of interest. 

4. Performs mathematics over the spectra (log, derivatives, etc). 

5. Saves selected spectra as images, in Excel, or ECOSTRSESS format. 

Steps: (could be used in random order) 

The spectral analysis toolbox is located at the bottom of the Main Interface.  

 
 

Real-Time Spectrum: In the SPECTRAL ANALYSIS panel click Real-Time Spectrum and place the 
cursor on the image. The spectrum will be generated with its maximum marked with a red circle. The 
position of the cursor, maximum intensity value, and the total number of channels will be shown above the 
graph.  

Multi-Spectra Mode enables the selection of several regions of interest to visualize their spectra. The 
default presentation is the standard deviation spectrum. The function enables several spectra to be 
visualized. 

To visualize spectra in a different mode, Right Click and select one of the options: 

• Standard deviation spectrum (default) 

• Mean spectrum 
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Spectral Mathematics: This mode enables both single-spectrum math as well as a spectral comparison 
between the selected region of interest and the entire dataset. Click the Spectra Mathematics button. A 
new panel with the available options will appear. Select the method from the drop-down menu. Available 
options are listed in the table: 

 Group Mathematical function  

 Information Length of the spectrum (default) 

  Normalization of one or two spectra 
 Spectral algebra Subtraction of two spectra 
  Simple Ratio between two spectra 
  Log10 
  Derivatives of spectra 
  First Derivative  

  Second Derivative 

 Fourier transform of spectra Low pass Fourier transform filtering 

  High pass Fourier transform filtering 

 Spectral Correlation between two regions of interest Spectral Correlation value 
  Spectral Divergence value  

  Spectral Angle Value 
 Spectral Correlation between the selected region of 

interest and the rest of the image (correlation maps) 
Spectral Correlation Map  

  Spectral Divergence Map  

  Spectral Angle Map 
 Spectra smoothing Savitzky – Golay smoothing 

 Background removal Continuum Hull Removal 
  Polynomial Baseline Removal 
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Press the Select 1st spectrum button and draw a region of interest.  

Whenever applicable, press the Select 2nd spectrum button and draw another region of interest. 

Click Generate to visualize the results. NOTE: if Correlation Maps are selected, a new interactive pop-up 
window will appear. 

Saving options. The software enables several methods for saving data. Available options include: 

1. Right-click the mouse on the area outside of the spectra. The options enable the user to save all 
spectra as images, in Excel and ECOSTRESS format (see below).  

a. Click Copy Spectra Image to generate an image that can be pasted elsewhere. (NOTE: 
this option does not include legends). 

b. Click Save Spectra Image as… to save an image as a png, jpeg, or tiff format. (NOTE: 
this option does not include legends). 

c. Click Save Std spectra in Excel… to save standard deviation spectra derived from a region 
of interest. 

d. Click Save Mean Spectra in Excel… to save mean spectra from the spectra derived from 
a region of interest.  

2. Hover over the spectral window to activate a small toolbar and point to the Save icon. When 
pointed, the icon further splits into the following icons (options): 

a. Save As… 
b. Copy as Image 
c. Copy as Vector Graphic 

3. Saving spectra in Excel format using a brush. Click the Brush icon in the Main Toolbar  or 
hover over the spectral window to activate a small toolbar and point to the Brush icon. When 
clicked, the Brush icon will turn blue.  

 

Brush the entire or part of the spectra on the graph and Right click. Select Copy Data to Clipboard or 
activate a pop-up by clicking Export brushed… and the Identify Brushed Data table comes up. The 
lowest row in the Table corresponds to the first spectrum, the second from the bottom to the second 
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spectrum and so on. Select the row and the spectrum and the legends will became thicker indicating the 
spectrum you selected. Click OK and paste the numbers into Excel or other text file. If you need to select 
another spectrum, you will have to repeat the process: right-click on the spectra, select Copy Data to 
Clipboard and select another row. At the end, click the Brush button from the small toolbar to deactivate 
it.  

      
 

 
 

5. Flip spectral axes 

The direction of the axes in the spectral windows can be reversed. The default direction is from low to high 

values. Pressing ‘flip’ buttons  reverse the directions of axes. Blue color of the flip icon 
indicate ‘reverse’ direction as shown in the spectral images below. The spectral view can be returned to the 
original by pressing the buttons again.  

 

 
Y axes is reversed           X and Y axes are reversed 

   

 

NOTE: Many functions on the software will stop responding if one of the icons from the Strip Toolbar is 
activated (blue-colored) except the flip functions. Before you go to the next task, please make sure activated 
(blue) icons are turned off. 
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Saving in the ECOSTRESS format. The ECOSTRESS spectral library is a compilation of over 3,400 
spectra of natural and manmade materials. These libraries were developed as part of 
the ASTER and ECOSTRESS projects. IDCubePro® supports the format of the library and allows spectra 
to be saved in the standard ECOSTRESS format that can be used in the Spectral Matching Toolbox. A new 
pop-up ECOSTRESS Format Parameters will offer an ECOSTRESS META INFO form to be filled. 
Submitting any information is optional. This information will be used as a header. Feel free to add the 
information or leave the fields blank.  

 

Click Save File and select the folder to store the spectrum.  

IMPORTANT: the name of the file must be followed a specific format: yourname_spectrum.txt 
(i.e., pavia_spectrum.txt) where spectrum.txt is mandatory and cannot be changed.  

 

Notes: Some of the advanced spectral functions are also available from other toolboxes. 

References: 

ECOSTRESS library downloads: https://speclib.jpl.nasa.gov/;  

ECOSTRESS Library MATLAB format:  

 https://www.mathworks.com/help/images/ref/readecostresssig.html   

Length of Spectrum 
NOTE: PAVIA dataset is used as an example.  

Features:  

https://asterweb.jpl.nasa.gov/
https://ecostress.jpl.nasa.gov/
https://speclib.jpl.nasa.gov/
https://www.mathworks.com/help/images/ref/readecostresssig.html
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Provides information about the length of the z-dimension. For most of the datacubes, this information is 
independent of the regions of interest (ROI), but ROI is still required to operate the function.   

Steps: 

1. Click Spectra Mathematics. 

2. Select the ROI on the image using a mouse.  

3. Select Length of Spectrum from the dropdown menu.  

4. Click Select 1st Spectrum. 

5. Click Generate. The information will be given in the spectral plot window.  

 

Normalization of Spectra to [0 1] 
NOTE: PAVIA dataset is used as an example.  

Features: Normalizes up to two spectra from two corresponding regions of interest.   

Steps: 

1. Click Spectra Mathematics. 

2. Select Normalization from the dropdown menu.  

3. Click Select 1st Spectrum and draw a region of interest. The spectrum should appear in the 
SPECTRAL ANALYSIS panel. 

4. Click Select 2nd Spectrum and draw a region of interest. The second spectrum should appear in 
the SPECTRAL ANALYSIS panel. 

   
5. Click Generate. Both spectra will be normalized to [0, 1].  
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Simple Ratio of Two Spectra 
NOTE: PAVIA dataset is used as an example.  

Features: Divides two spectra from two corresponding regions of interest.   

Steps: 

1. Click Spectra Mathematics. 

2. Select Simple Ratio from the dropdown menu.  

3. Click Select 1st Spectrum and draw a region of interest. The spectrum should appear in the 
SPECTRAL ANALYSIS panel. 

4. Click Select 2nd Spectrum and draw a region of interest. The second spectrum should appear in 
the SPECTRAL ANALYSIS panel. 

 
5. Click Generate. The resulting spectrum will be a result = S1/S2.  

 

Log10 of Spectra 
NOTE: PAVIA dataset is used as an example.  

Features: Calculates the Log10 of a spectrum.   

Steps: 

1. Click Spectra Mathematics. 
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2. Select Log10 from the dropdown menu.  

3. Click Select 1st Spectrum and draw a region of interest. The spectrum should appear in the 
SPECTRAL ANALYSIS panel. 

 
4. Click Generate. The resulting spectrum will be a result = log10(S1).  

 

First Derivative 
NOTE: PAVIA dataset is used as an example.  

Features: Generates the first derivative of the spectra. 

The first derivative of the spectrum from the region of interest is performed in two steps. First, the function 
averages the spectra from the region of interest. Second, the algorithm performs derivation of the spectrum, 
converting the mean spectrum into its corresponding first derivative spectrum. 

Steps:  

1. Load the file. Select Spectra Mathematics and select First Derivative. 

2. Press Select 1st spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel. 

 

3. Press Generate and observe a new spectrum. 
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NOTE: You can save the spectra using the brushing mode available from the Strip Toolbar.  

Alternative: 

You can also execute the first derivative of the entire dataset selecting the First Derivative from Image 
Algebra available from the DATACUBE MATHEMATICS panel.  

 

Additional Information: 

A first-order derivative is the rate of change of intensity with respect to the band/channel number. A first-
order derivative starts and finishes at zero. It also passes through zero at the same wavelength as the max 
of the band. Either side of this point is positive and negative bands with maximum and minimum at the 
same wavelengths as the inflection points in the band. This bipolar function is characteristic of all odd-
order derivatives. 

Second Derivative    
NOTE: PAVIA dataset is used as an example 

Features: 

• Generate the second derivative of the spectra. 

• Second derivative spectroscopy is a technique that enhances the separation of overlapping peaks. 
The second derivative measures the instantaneous rate of change of the first derivative. The sign of 
the second derivative tells us whether the slope of the tangent line is increasing or decreasing. 

Steps:  

1. Load the file. Select Spectra Mathematics and select Second Derivative from the dropdown 
menu.  
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2. Click Select 1st spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel. 

 

3. Press Generate and observe a new spectrum. 

  

Tip: You can save the spectra using the brushing mode available from the Strip Toolbar. 

NOTE: You can also execute the second derivative of the entire dataset by selecting Second Derivative 
from Image Algebra available from the DATACUBE MATHEMATICS panel.  

 

Low Pass Fourier Transform Spectral Analysis 
NOTE: PAVIA dataset is used as an example. Can be used in conjunction with Filtering and 
Enhancement Tab → Low Pass FFT Filter. 

Features: Performs FFT of the spectrum and removes high-frequency data. 

The Low Pass FFT of the spectrum from the region of interest is performed in several steps automatically 
after several inputs from the user. First, the function averages the spectra from the region of interest. Second, 
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the algorithm performs a Fourier transform of the spectrum, converting the mean spectrum into its 
corresponding frequency domain spectrum. Third, the algorithm executes a low pass filter with a specified 
user cut-off frequency. In the final step, the inverted Fourier transform algorithm is performed to generate 
a new dataset with only low frequencies remaining. 

Steps:  

1. Optimize and visualize the performance of FFT on an individual spectrum from the selected region 
of interest using Fourier Transform. 

a. Load the file. 

b. Select Spectra Mathematics. 

c. Select Low Pass Fourier Transform.  

2. Click Select 1st Spectrum and draw a region of interest. A spectrum corresponding to the region 
will appear in the SPECTRAL ANALYSIS window. 

 

3. Press Generate and enter a Cutoff value number in the pop-up dialog. The number reflects the % 
of Nyquist frequency in the range between 0 and 1. 

 

4. Press Visualize Spectra. 

Observe a new window that shows the following spectra: the original spectrum, FFT transformed spectrum, 
and a reconstructed spectrum as shown in the figure below. From top to bottom: i) original spectrum, ii) 
frequency domain spectrum, with red dots showing the frequencies that are preserved for subsequent 
inverse Fourier transform, iii) the spectrum after the inverse Fourier transform.  

 
Cutoff =1.0 

(Preserves 100% frequencies) 
Cutoff =0.5 

(Keeps 50% low frequencies) 
Cutoff=0.25 

(Keeps 25% low frequencies) 
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NOTE: the intensity scale of the reconstructed spectra automatically changes and ranges from 0 to 1.  

The results of these transformations can be also seen in the SPECTRAL ANALYSIS panel. Multiple 
reconstructed spectra from several cutoffs can be visualized.  

 
 

(Optional) After the cutoff value of the FFT filter is optimized, press Apply to Image to visualize the 
resulting filtered image. 

 

References: 

The algorithm is built using part of the fftl library developed by Shmuel Ben-Ezra in 2009:  

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-
results?s_tid=srchtitle  

High Pass Fourier Transform Spectral Analysis 
NOTE: PAVIA dataset is used as an example. Can be used in conjunction with Filtering and 
Enhancement Tab →   High Pass FFT Filter 

Features: Performs FFT of the spectrum and removes low-frequency data. 

The High Pass FFT of the spectrum from the region of interest is performed in several steps, automatically 
with several inputs from the user. First, the function averages the spectra from the region of interest. Second, 
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v. 2.78   

87 
 

the algorithm performs a Fourier transform of the spectrum, converting the mean spectrum into its 
corresponding frequency domain spectrum. Third, the algorithm executes a high pass filter with a specified 
user cut-off frequency. In the final step, the inverted Fourier transform algorithm is performed to generate 
a new dataset with only high frequencies remaining. 

Steps: 

1. Optimize and visualize the performance of FFT on an individual spectrum from the selected region 
of interest using Fourier Transform. 

a. Load the file. 

b. Select Spectra Mathematics. 

c. Select High Pass Fourier.  

d. Click Select 1st Spectrum and draw a region of interest. A spectrum corresponding to the 
region will appear in the SPECTRAL ANALYSIS panel. 

 

2. Press Generate and enter a Cutoff value number in the pop-up dialog. The number reflects the % 
of Nyquist frequency in the range between 0 and 1. 

 

3. Press Visualize Spectra. 

4. Observe a new window that shows the original spectrum, FFT transformed spectrum, and a 
reconstructed spectrum as shown in the figure below. From top to bottom: i) original spectrum, ii) 
frequency domain spectrum, with red dots showing the frequencies that are preserved for 
subsequent inverse Fourier transform, iii) the spectrum after the inverse Fourier transform. 

NOTE: the intensity scale of the reconstructed spectra ranges from 0 to 1. 

 
Cutoff =0.0 

(preserves 100% frequencies) 
Cutoff =0.5 

(keeps 50% high frequencies) 
Cutoff=0.25 

(keeps 75% high frequencies) 
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The results of these transformations can be also seen in the SPECTRAL ANALYSIS panel. Multiple 
reconstructed spectra from several cutoffs can be visualized.  

 

(Optional) After the cutoff value of the FFT filter is optimized, press Apply to Image to visualize the 
resulting filtered image. 

 

References:  

The algorithm is built using part of the fftl library developed by Shmuel Ben-Ezra in 2009:  

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-
results?s_tid=srchtitle 
 

Spectral Correlation   
NOTE: PAVIA dataset is used as an example.  

Features: Generates comparison between any two regions of interest interactively selected on the image 
using spectral correlation algorithm.  

Steps: 

1. Load the file. Select Spectra Mathematics and select Spectral Correlation from the dropdown 
menu.  
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2. Click Select 1st Spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel.  

3. Click Select 2nd Spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel. 

 

4. Press Generate to measure the spectral correlation between two objects. Correlation coefficient 
scores can range from –1 to +1. A score of –1 indicates a perfect negative correlation, while a score 
of +1 indicates a perfect positive correlation. Higher scores correspond to stronger spectral 
correlation. A score of 0 indicates no correlation between the two selected areas.  

 

In the shown case where two areas (purple boxes) were selected, the spectral correlation score is 0.964. For 
comparison, the correlation score between the roof and the grass is 0.672. 

Press Clear ROI/Spectra to start another correlation analysis or any other spectral tasks. 

The function is based on a spectral cross-correlation algorithm that computes the p-scores for Pearson's 
correlation using a Student's t distribution for a transformation of the correlation.  

References 

Gibbons, J.D. Nonparametric Statistical Inference. 2nd ed. M. Dekker, 1985. 

Hollander, M., and D.A. Wolfe. Nonparametric Statistical Methods. Wiley, 1973. 

Spectral Divergence   
NOTE: PAVIA dataset is used as an example.  

Features: Generates comparison between any two regions of interest interactively selected on the image 
using spectral information divergence (SID) algorithm.  

Steps: 
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1. Load the file. Select Spectra Mathematics and select Spectral Divergence.  

2. Click Select 1st spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel.  

3. Click Select 2nd spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel. 

 

4. Press Generate to measure the spectral information divergence score between two objects. A lower 
score corresponds to a stronger similarity between the areas. A value of 0 indicates no divergence 
between the two areas.  

 

In the shown case where two areas (purple boxes) were selected, the SID score is 3.9382. For comparison, 
the SID score between the roof and the canopy is 38.43. 

Press Clear ROI/Spectra to start another analysis or to perform any other spectral tasks. 

Additional Information: 

The method measures the spectral similarity between the two mean spectra from the selected ROIs by using 
the spectral information divergence (SID) algorithm. This method might also be used to compare the 
spectral signature of an unknown material against the reference area. The smaller the divergence, the more 
likely the pixels are similar. 

The method computes spectral similarity scores based on the divergence between the probability 
distributions of the two spectra.  

References: 

Chein-I Chang, “An Information-Theoretic Approach to Spectral Variability, Similarity, and 
Discrimination for Hyperspectral Image Analysis.” IEEE Transactions on Information Theory 46, no. 5 
(August 2000): 1927–32. https://doi.org/10.1109/18.857802. 

https://doi.org/10.1109/18.857802
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Du, H., C.-I. Chang, H. Ren, F. M. D’Amico, and J. O. Jensen, J. "New Hyperspectral Discrimination 
Measure for Spectral Characterization." Optical Engineering 43, No. 8 (2004): 1777-1786. 

Spectral Angle 

NOTE: PAVIA dataset is used as an example.  

Features: Generates comparison between any two regions of interest interactively selected on the image 
using a spectral angle algorithm.  

Steps: 

1. Load the file. Select Spectra Mathematics and select Spectral Angle from the dropdown 
menu. 

2. Click Select 1st spectrum. Draw a region of interest. A spectrum corresponding to the average 
spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel.  

3. Click Select 2nd spectrum. Draw another region of interest. A spectrum corresponding to the 
average spectrum of the selected region will appear in the SPECTRAL ANALYSIS panel. 

 
4. Press Generate to measure the spectral angle between two objects.  

A lower score corresponds to stronger spectral similarity. A score of 0 indicates perfect similarity. Usually, 
a score > 0.1 radians indicate no similarity. 

 

5. In the shown case where two objects were selected, the spectral angle is 0.05. For comparison, 
the spectral angle between the roof and the canopy is much higher 0.405 (not shown) indicating 
a low spectral correlation between the two subjects. 

6. Press Clear ROI/Spectra to start another spectral angle analysis or any other spectral tasks. 
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Additional Information: 

The spectral angle algorithm determines the spectral similarity between two spectra by calculating the angle 
between the spectra. Smaller angles represent closer matches between the two selected areas. 

References: 

Kruse, F.A., A.B. Lefkoff, J.W. Boardman, K.B. Heidebrecht, A.T. Shapiro, P.J. Barloon, and A.F.H. 
Goetz. “The Spectral Image Processing System (SIPS)—Interactive Visualization and Analysis of Imaging 
Spectrometer Data.” Remote Sensing of Environment 44, no. 2–3 (May 1993): 145–63. 
https://doi.org/10.1016/0034-4257(93)90013-N. 

Spectral Cross-Correlation Map 
NOTE: PAVIA dataset is used as an example. 

Features: 

• Enables to draw a seed and cross-correlate with the rest of the image.  

• Identifies the area of the highest/lowest cross-correlation. 

• Quantifies the area correlated with the seed.  

Steps:  

1. Press the button Spectral Mathematics on the Main Interface under SPECTRAL ANALYSIS. 

2. Select Spectral Correlation Map from a dropdown menu. 

3. Select 1st spectrum. 

4. Draw a region of interest that can be used as a reference point (seed) and visualize the mean 
spectrum. 

 
5. Click Generate to open another window Spectral Correlation Map.  

6. Visualize and quantify a Spectral Cross-Correlation Map. 
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Higher cross-correlation corresponds to a closer match between the seed and each pixel in the image. Use 
a slider on the histogram to visualize the images with the highest or lowest correlation. The area of the 
matched cross-correlation (high cross-correlation) is shown in the title.  

 
The Reset button can be used to revert the image to the original.  

Additional Information: 

The toolbox is based on a spectral cross-correlation algorithm that computes the p-values for Pearson's 
correlation using a Student's t distribution for a transformation of the correlation.  

Values of the correlation coefficient can range from –1 to +1. A value of –1 indicates a perfect negative 
correlation, while a value of +1 indicates a perfect positive correlation. A value of 0 indicates no correlation 
between the seed and the pixel. 

References: 

Gibbons, J.D. Nonparametric Statistical Inference. 2nd ed. M. Dekker, 1985. 

Hollander, M., and D.A. Wolfe. Nonparametric Statistical Methods. Wiley, 1973. 

Spectral Information Divergence Map 
NOTE: PAVIA dataset is used as an example. 

Features: 

• Interactively selects a seed. 

• Show a divergence between the seed and the rest of the image.  

• Identifies the area of the highest/lowest divergence. 

• Quantifies the area correlated with the seed.  

Steps: 

2. Press the button Spectral Mathematics under Spectral Analysis on the Main Interface. 

3. Select Spectral Divergence Map from a dropdown menu. 
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4. Select 1st spectrum. 

5. Draw a region of interest and visualize the mean spectrum. 

 

6. Click Generate to open another window Spectral Divergence Map. The mapping calculations 
will start. 

7. Visualize and quantify a spectral information divergence map. 

 

Lower divergence corresponds to a closer match between the seed and each pixel in the image. Use a slider 
on the histogram to visualize the images with the highest or lowest correlation. The total area of the matched 
divergence (low values) is shown in the title.   

Using the Reset button below the image, revert the image to the original. 

NOTE: For this calculation, only values between the cyan line and the left edge of the histogram are 
counted.  

Additional Information: 

Spectral Information Divergence (SID) measures the spectral similarity between the specified test 
spectra (pixels in the image) and reference spectra (mean spectrum) from the selected ROI by using the SID 
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method. This method is used to compare the spectral signature of an unknown material against the seed 
reference spectra or to compute spectral variability between two spectral signatures. 

SID: measures the spectral similarity between the spectra of each pixel in the hyperspectral data and the 
specified reference by using the spectral information divergence (SID) technique. The method computes 
spectral similarity based on the divergence between the probability distributions of the two spectra.  

References: 

SID: Chein-I Chang. “An Information-Theoretic Approach to Spectral Variability, Similarity, and 
Discrimination for Hyperspectral Image Analysis.” IEEE Transactions on Information Theory 46, no. 5 
(August 2000): 1927–32. https://doi.org/10.1109/18.857802. 

Spectral Angle Map 
NOTE: PAVIA dataset is used as an example. 

Features: 

Measures the spectral similarity between the spectra of each pixel in the hyperspectral data and the specified 
reference spectra (seed) by using the spectral angle mapper (SAM) classification algorithm.  A lower score 
corresponds to stronger spectral similarity. A score of 0 indicates perfect similarity. Usually, a score > 0.1 
indicate no similarity between the pixels. A static similarity threshold will have to be applied to recognize 
similar and dissimilar areas. 

• The user can interactively select a seed area. 

• Shows a spectral angle map between the seed and the rest of the image. 

• Identifies the area of the highest/lowest angle. 

• Quantifies the area correlated with the seed. 

Steps: 

 

Draw an area in the Image Display that you would like to use as a reference. This area is called a seed 
area. 

https://doi.org/10.1109/18.857802
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1. Press the button Spectra Mathematics on the Main Interface under the SPECTRAL ANALYSIS 
panel. 

2. Select Spectral Angle Map from a dropdown menu. 

3. Select the 1st  Spectrum button. 

4. Draw a region of interest and visualize the mean spectrum. 

5. Click Generate to activate the calculation of the map. A new pop-up window Spectral Angle Map 
appears after the calculation is performed. 

6. Visualize and quantify a Spectral Angle Map. 

 

1. The mapper has three panels:  

a. Spectrum of the Seed area shows the average spectrum across the selected seed area. 

b. Histogram of the image where each value is a spectral angle score. 

c. A monochromatic image of the map where each pixel value is a spectral angle score.  

2. The lower angle value corresponds to a closer match between the spectrum from the seed and the 
pixel in the image.  

3. Use a slider on the histogram to set a threshold to visualize the images with the highest or the lowest 
similarity. For example, to see the regions on the image with the highest similarity to the seed, 
move the green boundary on the histogram to the left. The modified image of the map will show 
the highest similarity. 
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4. The total area of similar objects with the defined threshold (low values) is shown in the title above 
the map.   

5. Press the Reset button to cancel changes and return the spectral angle map image to the original. 

NOTE: For these calculations, only values between the green line and the left edge of the histogram are 
counted. 

References: 

Kruse, F.A., A.B. Lefkoff, J.W. Boardman, K.B. Heidebrecht, A.T. Shapiro, P.J. Barloon, and A.F.H. 
Goetz. “The Spectral Image Processing System (SIPS)—Interactive Visualization and Analysis of Imaging 
Spectrometer Data.” Remote Sensing of Environment 44, no. 2–3 (May 1993): 145–63. 
https://doi.org/10.1016/0034-4257(93)90013-N. 

Savitzky-Golay (S-G) Smoothing  
NOTE: PAVIA dataset is used as an example. 

Features: S-G smooths noisy signal data using a least-squares digital polynomial filter. Optimizes and 
visualizes the performance of the S-G smoothing algorithm on an individual spectrum from the selected 
region of interest using Savitzky-Golay smoothing. 

Steps: 

1. Load the file. 

2. Select Spectra Mathematics → Savitzky-Golay smoothing. 

3. Press Select 1st Spectrum and draw a region of interest. A spectrum corresponding to the region 
will appear in the SPECTRAL ANALYSIS panel. 

 

4. Press Generate. A pop-up dialogue window will ask for additional parameters, Polynomial Order 
and Frame Size.  

https://doi.org/10.1016/0034-4257(93)90013-N
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Polynomial Order corresponds to the degree of the polynomial fitted to the points in the moving frame. 
The default value is 2. Polynomial Order value must be smaller than Frame Size if the frame size is a 
positive integer. The default value is 10. 

Frame Size modifies the frame size for the smoothing function. If the Frame Size value is greater than 1, 
the rolling window is the size of the input number (i.e., 10) and independent of the number of 
bands/channels. Higher values smooth the signal more with an increase in computation time. If the Frame 
Size is less than 1, the window size is a fraction of the number of points in the total number of channels. 
For example, if the Frame Size value is 0.05, the window size is equal to 5% of the number of points in 
the total number of channels. 

When the process is complete, the new spectrum will replace the original image. We suggest clearing the 
spectrum by pressing Clear ROI/Spectra before drawing a new area of interest.  

(Optional) The optimized parameters can be applied to the Savitzky-Golay filter. 

Additional Information: 

IDCube uses a modified version of the Savitzky-Golay algorithm. The original algorithm developed by 
Savitzky and Golay assumes the input vector corresponding to the band/channel dimension has uniformly 
spaced separation units, while the current algorithm also allows one that is not uniformly spaced.  

When the input bands/channels vector is evenly spaced, the least-squares fitting is performed once so that 
the signal is filtered with the same coefficients, and the speed of the algorithm increases considerably. 

The algorithm specifies the degree of the polynomial fitted to the points in the moving frame. The default 
order of the polynomial fitted to the points in the moving frame is equal to 2. The default frame size 
is 10 samples. Both parameters can be modified in the IDCube. 

 

Continuum Hull Removal from Spectrum 
NOTE: Plastic and Coin dataset is used as an example.  

Features: Enables rapid removal of continuum hull from the spectra across the entire dataset. See also 
Continuum hull removal from spectrum section. 

Continuum hull removal is a pre-processing technique used in hyperspectral image analysis to remove the 
spectral continuum from the data. The spectral continuum refers to the background signal in the image that 
is not associated with any specific spectral features or information. This background signal can obscure or 
distort the spectral information of interest, making it more difficult to analyze and interpret the data. 

Step 1. In the SPECTRAL ANALYSIS panel click Spectra Mathematics button and select Continuum 
Hull Removal from the right menu.  

Step 2. Select 1st spectrum button and draw a region of interest on the image.  
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Step 3. Click Generate and a popup dialogue IDCubePro : Continuum window with methods will popup. 
Select the method and press Apply.  

 

A new window with the original spectrum, convex hull and continuum removed corrected spectrum will 
appear.  
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Additional Information 

The continuum hull removal technique involves estimating the continuum spectrum and subtracting it from 
the original hyperspectral data. The goal is to remove the background signal while preserving the spectral 
information of interest. The specific method used for continuum hull removal may depend on the 
characteristics of the data and the analysis goals. After the continuum is estimated and subtracted, the 
resulting data is referred to as the "continuum-removed" spectrum. This spectrum represents the spectral 
features of the image without the background signal, making it easier to identify and analyze the specific 
spectral signatures associated with different materials or phenomena. 

The algorithm performs three steps: 1. Identifies a continuum hull using one of the methods (see a Table 
below). 2. Subtracts the original spectrum from the continuum hull. 3 Repeats the procedure 1-2 for each 
pixel.  

 

Method Description Comments 

'makima' Modified Akima cubic Hermite interpolation. The data is modeled 
using a cubic polynomial that is based on a set of Hermite basis 
functions, which are used to interpolate the data. The Modified Akima 
method improves upon the Akima method by adding a smoothing 
factor that reduces the impact of any noisy or erratic data points on 
the interpolation results. 

Particularly useful in situations 
where the data is noisy or contains 
outliers, as it is able to provide a 
smooth interpolation.  

Memory requirements are similar to 
those of 'spline'. 

'linear' Linear interpolation. The interpolated value at a query point is based 
on linear interpolation of the values at neighboring grid points in each 
respective dimension. This is the most common interpolation method. 

Requires more memory and 
computation time than nearest 
neighbor. 

'nearest' Nearest neighbor interpolation. The interpolated value at a query 
point is the value at the nearest sample grid point. 

Modest memory requirements. 

Fastest computation time. 

'next' Next neighbor interpolation. The interpolated value at a query point 
is the value at the next sample grid point. 

Same memory requirements and 
computation time as 'nearest'. 

'pchip' Shape-preserving piecewise cubic interpolation. The interpolated 
value at a query point is based on a shape-preserving piecewise cubic 
interpolation of the values at neighboring grid points. 

Requires more memory and 
computation time than 'linear'. 

'cubic' Cubic convolution used in MATLAB. Points must be uniformly spaced 

This method falls back 
to 'spline' interpolation for 
irregularly spaced data. 

Similar memory requirements and 
computation time as 'pchip'. 

'v5cubic' Same as 'cubic'. 

'spline' A spline is a piecewise polynomial function that is defined by a set of 
control points, which are the known data points in the case of spline 
interpolation. The spline curve is constructed by fitting a series of 
polynomial segments to the control points, with the requirement that 
the curve is smooth and continuous at each control point. 

Uses the cubic spline as it provides a 
good balance between smoothness 
and accuracy Requires more memory 
and computation time than 'pchip'. 

 

Acknowledgement 
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The code in part was developed by Marian-Daniel Iordache, Copyright (April 14, 2016):   

Polynomial Baseline Removal in the Spectrum 
NOTE: Plastic and Coin dataset is used as an example. Also see Polynomial Baseline Removal from the 
Data Correction tab. 

Features: Enables removal of the baseline from the spectrum from the selected region of interest.  

Polynomial baseline removal is a pre-processing technique used in hyperspectral image analysis to remove 
the baseline from the data. The idea behind Polynomial Baseline Removal is to fit a polynomial function to 
the baseline of the signal and then subtract it from the original signal to obtain the corrected signal. 

Step 1. In the SPECTRAL ANALYSIS panel click Spectra Mathematics button and select Polynomial 
Baseline Removal from the right menu.  

Step 2. Select 1st spectrum button and draw a region of interest on the image.  

Step 3. Click Generate. 

 
Select the degree of polynomial (from 1 to 9) and click Apply to perform fitting, subtraction and shifting. 

     
A new window with the original spectrum, baseline and corrected spectrum will appear.  



v. 2.78   

102 
 

 
 

Additional Information 

The algorithm performs three steps: 1. Fits a polynomial function to the baseline with the selected degree 
of the polynomial function depends on the complexity of the baseline simple linear function (degree=1) or 
a higher-degree polynomial function (degree > 1). 2. Subtracts the polynomial function from the original 
signal. 3. Shifts the spectrum to have minimum values at zerois. 

The choice of the degree of the polynomial function is usually made by trial and error. The presented 
method will help you to visualize and optimize baseline removal on a specific region of interest. Once 
satisfied, you can perform removal of the baseline using Polynomial Baseline Removal from the Data 
Correction tab. 

The polynomial function fits to the spectrum using a least-squares regression algorithm. The polynomial 
order is typically chosen based on the noise level and complexity of the data, with higher-order polynomials 
providing more accurate fits but also increasing the risk of overfitting. After the baseline is estimated and 
subtracted, the resulting spectrum data are shifted to have minimum value at zerois. The final spectrum is 
referred to as the "baseline-removed" spectrum. The entire algorithm is performed over all pixels in the 
image. This spectrum represents the spectral features of the image without the background signal, making 
it easier to identify and analyze the specific spectral signatures associated with different materials or 
phenomena. 
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7.10. Frame-By-Frame Panel 
NOTE: PAVIA dataset is used as an example. 

Features: 

Presents images in a movie-type fashion. Can be combined with any other functions including mathematics.  

The movie can be saved as a movie file (avi) (via File - Save As…→Video). 
Steps: 

1. Select Frame-by-Frame Display and press the green Play button. Press the red Stop button to 
stop the movie.  

 

2. The movie can be visualized in two windows. Click View on Image Display to change the 
visualization panel. 

3. The movie can be combined with many functions available in IDCube. In the example shown in 
the figure below, Frame-to-Frame Display is combined with Mathematics where the image is 
calculated via the Normalized Ratio between two channels. In that case, Image Display will show 
the resulting images with the first channel scanning while the second channel remains stable. 

 

The movie can be saved through Save As... from the File menu and selecting Video (.avi). The movie will 
be saved in the avi format in the folder. 
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7.11. Directory Information Panel 
NOTE: The panel is interactive and allows the user to copy/paste/edit the information. 

Features: Generates a list of opened files with the pathways. 

Opening a single file: When the single file is open, the information about the file can be seen in the 
DIRECTORY INFORMATION panel in the lower right corner of the software.  

 
 Opening a single file with references generates a list of the main file and references 

 
Opening multiple files generate the list of files opened. 

 
NOTE: In the current configuration IDCube does not support Concatenated files. Instead, only the last 
opened file is shown 

 

  



v. 2.78   

106 
 

7.12. Computer Information Panel     
Features: 

4. The COMPUTER INFORMATION panel provides real-time information about the user’s PC CPU and 
memory usage.  

5. CPU data is displayed as a percentage (%) of the PC’s capacity.  

6. Memory is displayed in megabytes (MB).  

 

 
 
 

The “Monitor” button starts/resumes the information collecting process.  

 

The “Stop” button pauses the information-collecting process. Functionality can be resumed by pressing the 
“Monitor” button.  
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7. Tabs 
IDCubePro® offers many functions organized in tabs in the following categories 

 

 

 

Tabs Function Additional info 

File Tab Open Dataset in IDCube Format  

 Add References in IDCube Format Additional menu  
 Add Multiple Datasets in IDCube Format  

 Concatenate IDCube Dataset Additional menu 
 Import Other Formats and Convert to IDCube Additional menu 
 Open Legacy Format Datasets (MATLAB)  

 Open Color Image (BMP/JPED/TIFF)  

 Convert Images to Stack (JPEG/PNG/TIFF)  

 Recent IDCube Datasets Generated menu 
 Download Example Files in IDCube Format Additional menu 
 Export Setup…  
 Copy Interface View  
 Save Interface View As…  
 Save Data As… Additional menu 
 Save Histogram-Modified Dataset  
 Print Preview As… Pop-up window 
 Print Pop-up window 
 Exit  
 Generate Report Saved as a txt file 
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Tabs Function Additional info 

View Tab Colortheme of the software Additional menu 
 Close/Open Color LUT Toolbar  
 Close/Open Color Camera Toolbar  
 Generatorator  Pop-up GUI 
 List of Bands/Channels Pop-up window 
 Image Scale  

 Expanded View  

 View Header Information Pop-up window 
 View Image Information Pop-up window 
 View Heatmap Pop-up plot 
 Edit Plot  
 Turn Instructions Off  

Tabs Function Additional info 

Edit tab  Rotate and Flip Additional menu 
 Crop (spatial and spectral) Additional menu 
 Bin (spatial and spectral) Additional menu 
 Spectral Crop Dialogue window 
 Change Bands Pop-up window 
 Annotations Additional menu 
 Edit Plot Mode  

Tabs Function Additional info 

Plots Tab Contour 2D plot  

 Contour-filled 2D plot  

 Mesh 3D plot  

 Surface 3D plot  

 Contour 3D plot  

 Remove all plots  
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Tabs Function Additional info 

Image Statistics Image Quality Plot  Additional menu 

 Anomaly Pixels Pop-up window 

 Texture features Pop-up window 

 Hausdorff (Box-Counting) Fractal Dimension Pop-up value 

Tabs Function Additional info 

Filtering and Enhancement Tab Mean Spatial Filter Dialogue window 
 Mean Spectral Filter Directly applies to Image 
 3D Gaussian Filter Directly applies to Image 
 NGmeet Filter Directly applies to Image 
 Spatio-Spectral Total Variation (SSTV) Filter Dialogue window 
 FFT Filters Dialogue window 
 Savitzky-Golay Smoothing Dialogue window 
 Asymmetric Least Square Smoothing Dialogue window 
 Standard Deviation  Directly applies to Image 
 Decorrelation Stretch Directly applies to Image 
 Color Inversion Directly applies to Image 
 Normalization Additional menu 
 Contrast Enhancement Additional menu 
 Structure Similarity Index Pop-up value 
 Remove all filters and enhancements Equivalent to Reset 

Tabs Function Additional info 

Data Corrections Tab Background Data Correction Interactive menu 
 Flatfield Correction Interactive menu 
 Multiplicative Scatter Correction (MSC) Interactive menu 
 Standard Normal Variate (SNV) Interactive menu 
 Remove all filters and enhancements Equivalent to Reset 
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Tabs Function Additional info 

Toolboxes Principal Component Analysis (PCA) Pop-up toolbox 
 Maximum Noise Fraction (MNF) Pop-up toolbox 
 Image Classification  Pop-up toolbox 
 Spectral Signature Matching  Pop-up toolbox 
 Endmembers Extraction  Pop-up toolbox 
 Image Indices Pop-up toolbox 
 Contrast Maximization  Pop-up toolbox 
 Correlation Matrix (R-Squared) Pop-up toolbox 
 t-SNE Clustering Pop-up toolbox 
 Spectral Phasor Clustering  Pop-up toolbox 
 3D Viewer Pop-up toolbox 
 Feature Finder  Pop-up toolbox 
  Fusion MSI and HIS in IDCube format 

(Pansharpening) 
Pop-up toolbox 

   

Tabs Function Additional info 

Machine learning Create Label(s) Pop-up window 
 Create Mask(s) Pop-up window 
 Create Binary Image Pop-up window 
 k-Means Classifier Dialogue window 
 Machine Learn Classifier Pop-up toolbox 
 Deep Learning (future releases)  Pop-up toolbox 

Tabs Function Additional info 

Macros Editor Generate a sequence of commands for automatic run Generated menu 

Tabs Function Additional info 

Window Automatically populates with every open window Generated menu 
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Tabs Function Additional info 

Help About IDCubePro®  Online link 
 Tutorials Online videos 
 Report Bug Online form 
 Terms of Use Pop-up document 
 Error Log Generated document 
 About HSpeQ Online (idcubes.com) 
 Contact Us Online form 
 Visit IDCube website and check for updates Online 
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7.1. File Tab 
The File tab includes the following functions 

Open Dataset in IDCube Format 

Features:  

Open a file that has already been converted and saved in the IDCube format 

Steps: 

1. Go to File and select Open Dataset in IDCube format from the drop-down menu. You can also 
use Ctrl+O as s shortcut 

2. Find your file in the directory and select Open. 

3. The file will load and open on the IMAGE DISPLAY panel. 

Tabs Function Additional info 

File Tab Open Dataset in IDCube Format  

 Add References in IDCube Format Additional menu  
 Add Multiple Datasets in IDCube Format  

 Concatenate Image Additional menu 
 Import Other Formats and Convert to IDCube Additional menu 
 Open Legacy Format Datasets (MATLAB)  

 Open Color Image (BMP/JPED/TIFF)  

 Convert Images to Stack (JPEG/PNG/TIFF)  
 Recent IDCube Datasets Generated menu 
 Download Example Files in IDCube Format Additional menu 
 Export Setup  
 Copy Interface View  
 Save Interface View As… Additional menu 
 Save and Close Data Pop-up window 
 Save Data As... Additional menu 
 Print Preview Pop-up window 
 Print Pop-up window 
 Exit  
 Generate Report Saves as a text file 
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Add References 
NOTE: This function is only available for data in the IDCube format. For other formats, the user needs to 
first convert the data files and reference files into the IDCube format.   

Features:  

• Removes artifacts related to the illumination and noise from the detector.  

• Provides a pure spectrum of the sample  

Steps: 

1. Open a folder file in IDCube format. Switch to the RGB mode and adjust band/channels 
/wavelengths. Visualize the spectra of the object. The reflection spectra are severely affected by 
specular reflection from the light source and to some degree by the dark noise from the detector.   
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2. To correct the image, you will need to have control images recorded under similar conditions. The 
example folder has two correction files. The white_ref image shown below is recorded from a strip 
of white reflective material made of Spectralon®. The dark_ref image is recorded in the same 
setting as the closed lens of the imaging system. 

 

3. To apply the correction files select File →  Add reference in IDCube format and select one of the 
three options White, Dark, or White and Dark.  

• White – corrects for white reflection only. 

• Dark – corrects for the dark count only. 

• White and Dark - correct for white reflection and dark count. 

• Remove corrections – deletes all corrections. 

  

When the White and Dark option is selected, a message box Select the White Reference First will appear. 
After clicking OK, a pop-up dialog window Select White Reference File will appear. Choose the white_ref 
correction file and click Open. 
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After selecting a white ref file, a message box Now Select the Dark Reference will appear.   You will be 
prompted to select a Dark Reference file after clicking OK. Choose the dark_ref correction file and click 
Open. 

 

 
The completion of the task will be confirmed by a message box. 

 
The IMAGE DISPLAY and the DIRECTORY INFORMATION panel will be automatically updated. To 
visualize the spectra, click multispectral mode and select the region of interest. The corrected spectrum 
shown as a mean spectrum +/- standard deviation is drastically different from the non- corrected (see 
above). One of the features of the corrected spectrum is a relatively high standard deviation at both ends of 
the spectrum. This is caused by the limited sensitivity of the detector at wavelengths shorter than 950 nm 
and longer than 1650 nm. 
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NOTE: A new dataset corrected for the white and dark noise can be treated as a typical IDCube dataset.  

Additional Information: 

Illumination in hyperspectral imaging systems is often not uniform across the image, generating potential 
artifacts. This problem can be eliminated by calibrating the image with the white object. Currently, the 
widely used standard reflectance surface is made of Spectralon ® white diffuse reflectance target, although 
other materials especially in remote sensing can also be used. In addition, imaging detectors used in HSI 
systems generally have dark currents. Dark current is dependent on temperature and is proportional to 
integration time. To convert raw intensity into reflectance, reference and dark images are taken before or 
after acquiring sample images. The reference image is taken with a standard reflectance surface placed in 
the scene, and the dark current is measured by keeping the camera shutter closed. The raw data are then 
corrected using the following equation. 

𝐼𝐼 =
𝐼𝐼𝑟𝑟𝑟𝑟𝑟𝑟 − 𝐼𝐼𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑
𝐼𝐼𝑤𝑤ℎ𝑖𝑖𝑖𝑖𝑖𝑖 − 𝐼𝐼𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑

 

where I is the calculated reflectance value, Iraw is the raw data of a given pixel, and Idark and Iwhite are the 
dark current and the white reference intensity of the given pixel, respectively. 

References: 

Lu, Guolan, and Baowei Fei. "Medical hyperspectral imaging: a review." Journal of biomedical optics 19.1 
(2014): 010901. 

Add Multiple Datasets in IDCube Format 
NOTE: This function is only available for data recorded or converted to the IDCube format. For other 
formats, the user needs to first convert the data file and the reference files into the IDCube format. The files 
might have different spatial (X-Y) coordinates but must have the same spectral (Z) coordinate.  

Features:  
Enables the users to open several datasets and treat them as a single file. 

Steps: 

1. Select File →  Open Multiple IDCube Datasets and select one of the options. The available 
options are: 
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a. Horizontally – adds files horizontally (up to 7 files). Spatial coordinates might be 
different, but the spectral coordinates should be the same. 

b. Vertically – adds files vertically (up to 7 files). Spatial coordinates might be different, 
but the spectral coordinates should be the same. 

c. Z-axis – adds file along the spectral (Z) axis. 

2. Select Multiple IDCube Datasets (the files must be in the same folder). 

 

       

If six or more files are selected, then the files are arranged in the most compact form such as 3 x 3 for six 
files. 

 
When the Z-axis is selected, the files are open stacking in the Z direction as shown below. NOTE: that 
spectra of the new dataset in the SPECTRAL ANALYSIS panel reflect three files. 
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Concatenate Images  

NOTE: PAVIA dataset is used as an example. The maximum number of files to be concatenated is 5. 

Features: Allows to open maximum of four images and position them next to each other. The images do 
not have to be the same spatial dimension but must have the same spectral dimension. 

Steps: 

1. Load the data using File, Open… or using an icon and open a file in the IDCube format 

2. Go to File → Concatenate IDCube dataset to add a new image. Two options are available: 

a. Concatenate Horizontally 

b. Concatenate Vertically 

 

The procedure can be repeated with up to five files concatenated. 
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Import Other Formats 
IDCubePro® allows the conversion of different file formats to the IDCube format. This functionality can 
be accessed under the file menu and hovering the Import other formats and Convert to IDCube menu 
option. 

 

The following imports and conversions to the IDCube format are available:  
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General type of files Instruments/platform Comments 

AVI (.avi) Movies Imported and converted directly to IDCube 
format, no spectral information 

BIL/HDR (.bil/.hdr) Resonon Imported and converted directly to IDCube format 
BIP/HDR (.bip/.hdr) Resonon Imported and converted directly to IDCube format 
BSQ/HDR (.bsq/.hdr) Resonon Imported and converted directly to IDCube format 
DAT/HDR (.dat/hdr) Cytoviva, Arion Optics  Imported and converted directly to IDCube format 

DICOM (.dcm) Medical imaging Imported and converted directly to IDCube format 
No metadata 

FILE/HDR Aviris, Aviris NG Imported and converted directly to IDCube format 

FITS (.fits, .fit, .fts) Flexible Image Transport 
System, used by Andor, SensIR 

Imported and converted directly to IDCube 
format, no spectral information 

FSM (.fsm) Perkin Elmer (IR imager) Imported and converted directly to IDCube format 
JPEG (.jpeg, .jpg) single  various Requires conversion Images to Stack first 
PNG files (.png), single  various Requires conversion from Images to Stack first 

TIF/TIFF (.tif, .tiff), single  Landsat 8, Landsat 9 Requires conversion from Images to Stack first 

H5 (.h5) various  Imported directly to IDCube format 

JP2 (.jp2) Sentinel 2 Imported and converted directly to IDCube format 
JPEG (.jpeg, .jpg), stack Various Imported and converted directly to IDCube format 
L1R/HDR (.l1r, .hdr) Hyperion Imported and converted directly to IDCube format 
MAT (.mat, m) Bruker (Lumos) Requires additional input (image dimension) 
NIFTI (.nii) Medical imaging Imported to IDCube format 
PNG (.png), stack   various  Imported and converted directly to IDCube format 

raw data file Becker&Hickl (FLIM system) Imported and converted directly to IDCube 
format, no time information 

RAW/HDR Headwall Photonics, Middleton 
Spectral Vision Imported and converted directly to IDCube format 

SPC (.spc) Witek Requires additional input (image dimension) 

SPE (.spe) Princeton Photonics, also used 
by Andor and SensIR 

Imported and converted directly to IDCube 
format, no spectral information 

TIF/TIFF (.tif, .tiff), stack PlanetScope Imported and converted directly to IDCube format 

.tiff and .jpg files with the 
hdr Zhuhai-1 Satellite  Imported and converted directly to IDCube format 

 

Import AVI files (.avi) 

Features: 

• .avi stands for Audio Video Interleave, a widely used video file format created by Microsoft. 
IDCubePro® enables the user to convert these types of files to the IDCube format. 
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• The .avi files contains only a three-dimensional structure (m x n x l), where m and n are spatial 
coordinates and l is the spectral coordinate. 

Steps: 

1. Click File → Import other formats and Convert to IDCube → Import AVI. 

 

Import DICOM files (.dcm) 
DICOM stands for Digital Imaging and Communications in Medicine, which is a standard file format used 
in the medical imaging industry to store and transfer medical images and related information. DICOM files 
are typically created by medical imaging devices, such as MRI or CT scanners, and they contain not only 
the images themselves but also metadata such as patient information, the imaging modality used, and the 
acquisition parameters. DICOM files are designed to be platform-independent, which means that they can 
be viewed and analyzed on different types of computer systems using specialized software programs. 

Structure of the DICOM folder: 

 
To import the files, click File → Import other formats and Convert to IDCube → DICOM (.dcm) 
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The .dcm files will be combined and converted to the IDCube format.  

 
To save the converted file, click File → Save as…  

 
A message box will inform you when the conversion is complete. 

 



v. 2.78   

123 
 

The conversion also generates a NIFTI type file (.nii) and extracts the header information dcmHeaders.mat.  

 
To visualize a header file, click View → View Header Information… select a dcmHeaders.mat file.  

 
If you do not see this file, change the default .hdr type of files to .mat. 

 
The header file will be opened in a new window. 

 

Import FITS files (.fits) 
FITS (Flexible Image Transport System) files are a type of file format commonly used in astronomy to 
store and exchange data. These files can contain a wide range of information, including astronomical 
images, spectra, and data tables. One of the key features of FITS files is their ability to store metadata about 
the data they contain. This metadata can include information about the instrument used to acquire the data, 
the location of the observation, and the processing steps that have been applied to the data. 
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To import the file, click File → Import other formats and Convert to IDCube → FITS (.fits) 

Import Stack of .tif/tiff,  .png, and .jpeg files 
Features: IDCube directly imports a stack with .tif/tiff, .png, and .jpeg files. Cells_tiff_stack dataset is used 
as an example. To form a stack, see a previous section Convert individual JPEQ/PNG/TIF files to Stack. 

Steps:  

1. Click File → Import other formats and convert to IDCube → Import JPEQ/PNG/TIF 
Stack. 

 
2. Select a stack of tif/tiff files from the directory.  

 

Click Open. The stack file will be converted to the IDCube format and ready to use for any other operations.  

You can also save the tiff stack into the IDCube format using Save As… option from the File menu.  

Import Raw/HDR and Dat/HDR files    
NOTE: Kootenai river dataset is used as an example (available from  

https://www.sciencebase.gov/catalog/item/5bf48b00e4b045bfcae252d6).  

https://www.sciencebase.gov/catalog/item/5bf48b00e4b045bfcae252d6
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Features: 

• raw/hdr and dat/hdr files are commonly used by commercial data acquisition systems. 
IDCubePro® enables the user to import and convert these types of files to the IDCube format 

• Hyperspectral datasets often use raw/hdr or dat/hdr format. These formats have at least two files. 

• The .raw or .dat files contains all relevant data and have a three-dimensional structure (m x n x l), 
where m and n are spatial coordinates and l is the spectral coordinate. 

• The .hdr is a header file that contains metadata. The header file typically contains information about 
the type of sensor used to acquire the image, the date of the dataset collection, the number of 
discrete spectral bands, and the corresponding wavelengths or channels. 

• Typically, the header file uses the same name as the image file and is located in the same folder. 

Steps: 

2. Click File → Import other formats and Convert to IDCube → Import Raw/HDR or Dat/HDR. 

 

3. Select a folder that has both files. For example, folder Kootenai Rover has .dat and .raw files. 

 

4. Select both .dat and .hdr files and click Open. The files will be opened in IDCubePro® and 
automatically converted to the IDCube format. After completion, metadata from the header file will 
be automatically shown. The file name will be preserved and saved in the original folder as shown 
below. 
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Import H5 files (.h5, .hdf5) 
H5 or HDF5 (Hierarchical Data Format 5) is a file format designed to store and manage large and complex 
datasets. It is a data model, library, and file format for storing and managing data. HDF5 is organized as a 
hierarchical structure of groups and datasets. The data can be stored in a variety of data types such as 
integers, floats, strings, and arrays. The groups act as containers for datasets and other groups, and datasets 
can store data of any size and dimensionality. One of the key features of HDF5 is its ability to handle 
metadata, which is data that describes the attributes and characteristics of the dataset. This metadata can 
include information such as the creation date, author, and version of the dataset, as well as information 
about the data itself such as units and scaling factors. HDF5 is widely used in scientific research, 
engineering, and data analysis applications due to its ability to handle large and complex datasets, its 
flexibility, and its portability across different operating systems and platforms. 

NOTE: The IDCube algorithm has been tested on several examples to open HDF5. IDCube might not be 
able to perform that for every HDF5 dataset because of the wide range of HDF5 formats. 

Step 1. To import the files, click File → Import other formats and Convert to IDCube → H5 (.h5) 
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A message box will inform you when the conversion is complete. 

 
The converted file can be found in the folder 

 

Import NIFTI files (.nii) 
NIFTI (Neuroimaging Informatics Technology Initiative) files are a type of file format used in 
neuroimaging to store and share medical imaging data. They are a standard format for storing and 
distributing neuroimaging data and are widely used in the research community.  

NIFTI files contain both image data and metadata, including information about the image dimensions, voxel 
size, and orientation, as well as the data type and any image transformations that have been applied. This 
metadata is important for ensuring that the data can be properly interpreted and analyzed by different 
software tools. In the IDCubePro® NIFTI files can also be generated from DICOM (see Import DICOM 
(.dcm) files section). 

To import the file, click File → Import other formats and Convert to IDCube → NIFTI (.nii) 

 



v. 2.78   

128 
 

 
To save the converted file, click File → Save as… 

 
A message box will inform you when the conversion is complete. 
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To save the converted file, click File → Save as… 

 
A message box will inform you when the conversion is complete. 

 

 
The conversion also generates a header file. To open a header file click View → Save as… 

 

The header file will be opened in a new window. 
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Import from different instruments 
To save the converted file, click File → Save as… 

IDCubePro® supports many formats and platforms.  

For accessing data from satellites and other remote sensing platforms, see our video tutorials at 
https://www.idcubes.com/tutorials.   

Examples of using platforms from several types of platforms are given below. 
Aviris Classic 
To find and download the file go to https://aviris.jpl.nasa.gov/ and click on the panel Search the Data 
Archive. (Might require login in and not available for general public) 

 

Aviris NG 
AVIRIS NG stands for Aviris New Generation. AVIRIS-NG is an imaging spectrometer that measures 
reflected radiance at 5nm intervals in the Visible to Shortwave Infrared (VSWIR) spectral range from 
380-2510nm.  

https://www.idcubes.com/tutorials
https://aviris.jpl.nasa.gov/
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Step 1. Downloading data.  

NOTE: Aviris NG operates by a company/governmental agency that is not affiliated with IDCube. The 
access to the data and the quality of the data are not controlled by IDCubePro.  

To find and download the file go to https://avirisng.jpl.nasa.gov/data.html. Red areas indicate available 
data.  

 
 

 

 

Find the data of your interest and click Download Orthocorrected Radiance Data. The download will 
start. 

https://avirisng.jpl.nasa.gov/data.html
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After the download is complete, unzip the file to see a folder with all files  

 

Step 2. To convert Aviris-NG files to IDCube, select Import Other Formats and Convert to IDCube → 
Aviris → Aviris NG  

 
Navigate to the folder with the files and select an image datafile, usually the largest file, and a header file 
that has the same name as the datafile but with extension .hdr. Click Open to initiate the conversion.  

 
Completion of the conversion will be notified with a message box.  

 
After the conversion is completed, the new imaging file in the IDCube format (with a .mat extension) will 
be generated and saved with the same name as the .L1R file.  
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NOTE: AVIRIS-NG generates imaging data with values that are artificially low (highly negative). These 
data correspond to the edges of the image. If necessary, the best way to eliminate these data points is to 
crop the image.   

Due to the presence of several header files, the header file will not open automatically. It can be opened via 
View → View Header Information. Any file with a .hdr or .txt extension can be opened this way. 

 
Hyperion (tiff format) 
Hyperion generates files in two formats with .tiff and .l1r/hdr extensions. In the case of tiff files, all tiff files 
are located within one folder. The folder has also a metadata file. To convert the tiff files to IDCube format, 
select Import Other Formats and Convert to IDCube → Hyperion. 
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A pop-up message will ask to select a folder where the tiff files are located.  

 

 
Select the folder and click Select Folder where the tiff files are located. The conversion will start 
immediately. After the conversion is completed, the message will appear. The new imaging file in the 
IDCube format (with a .mat extension) will be generated and saved with the same name as the tiff files.  

 
Hyperion (L1R/hdr format)  
Hyperion generates files in two independent sets formats (tiff and L1R/hdr). This part of the manual 
describes how to download and process Hyperion files in the L1R/hdr format. The folder has also a metadata 
file.  

Step 1: Selecting the area and Landsat 9 
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Landsat 9 data can be obtained by visiting https://earthexplorer.usgs.gov/. You will have to log in to the 
website in order to download the data. 

 

Move to the location of interest and select the area by, for example, clicking on the map. 

 

a. In the Data Range (below) specify the Date, Cloud Cover, and other options.  

b. In the Data Sets tab (on the top), go to EO-1 and select sat dropdown menu which contains EO-1 
Hyperion.   

https://earthexplorer.usgs.gov/
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When the download is complete, unzip the file.  

Step 2. To import the file to IDCube format select File → Import Other Formats and Convert to IDCube 
→ Hyperion (L1R/hdr).  
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A pop-up message will ask to select two files with .L1R (datafile) and .hdr (metadata) extensions. 

 
Click OK and select two files. The Image data file is usually the largest file and the header file has a .hdr 
extension. 

 
Select the files and click Open. The conversion will start immediately. After the conversion is completed, 
the header file will be opened automatically. The new imaging file in the IDCube format (with a .mat 
extension) will be generated and saved with the same name as the L1R file.  
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Landsat 9  
Features: IDCubePro® allows for the conversion of different file formats to IDCube files. This manual 
will outline the steps to download and convert Landsat 9 data from the USGS website to IDCube format 
files.  

Step 1: Selecting the area and Landsat 9 

Landsat 9 data can be obtained by visiting https://earthexplorer.usgs.gov/. You will have to log in to the 
website in order to download the data. 

Move to the location of interest and select the area by, for example, clicking on the map  

 

c. In the Data Range (below) specify the Date, Cloud Cover, and other options.  

d. In the Data Sets tab (on the top), find a Landsat dropdown menu that contains “Landsat Collection 
2 Level 1” data. In this dropdown menu, the “Landsat 8-9” data can be selected.  

https://earthexplorer.usgs.gov/
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e. Any dataset beginning with “LC09…” can then be selected and downloaded. 

 

Step 2. Downloading the data 

a. The “Product Bundle” must be selected so that the entire dataset can be converted.  
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Once downloaded the dataset will appear as a zip file. This file can be unzipped using any software. We 
use 7-Zip software to extract the data. The resulting data file will be a folder.  

 

Step 3. Converting the data from the Landsat to IDCube format.  

The conversion function in IDCube can be accessed by navigating to the File menu → Import Other 
Formats and Convert to IDCube → Landsat → Landsat 9.  
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The desired Landsat 9 data folder can then be selected for conversion.  

 

The converted file will be saved in the original folder path and the file will automatically be opened in 
IDCube.  
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PlanetScope Satellites 
Planet launched their first Dove microsatellites in 2015 with multiple launches in subsequent years. As of 
2022, over 240 PlanetScope microsats were orbiting the planet, providing daily imagery of most Earth’s 
landmass at 3-meter resolution with 4 multispectral bands (i.e. blue, green, red and near-infrared [NIR]). 
SuperDoves launched since 2019 feature 3-m imagery with 8 multispectral bands, adding coastal blue and 
red edge data.  

 
Spectral responses for PlanetScope: (a) Dove Classic ‘PS2’, (b) Dove-R ‘PS2.SD’, and (c) SuperDove 

‘PSB.SD’ sensors. (see ref) 

Ref:  

A. E. Frazier and B. L. Hemingway. A Technical Review of Planet Smallsat Data: Practical Considerations 
for Processing and Using PlanetScope Imagery, Remote Sens. 2021, 13(19), 3930; 
https://doi.org/10.3390/rs13193930 

Sentinel-2  
Sentinel-2 is an Earth observation mission from the Copernicus Programme that systematically acquires 
optical imagery at a high spatial resolution over land and coastal waters. The mission is currently a 
constellation with two satellites, Sentinel-2A (launched in 2015) and Sentinel-2B (launched in 2017); a 
third satellite, Sentinel-2C, is currently undergoing testing in preparation for launch in 2024.  Level-2A data 
is the most ideal for research activities as it allows further analysis without applying additional atmospheric 
corrections. Sentinel-2 collects multi-spectral data with 13 bands in the visible (B02, B03, B04), near-
infrared (B05, B06, B08, B08A), and short-wave infrared parts (B09, B10, B11, B12) of the spectrum. 
Sentinel 2 provides images with three types of spatial resolution: 10 m, 20 m, and 60 m as shown in the 
Table: 

Table: Sentinel 2 Bands 



v. 2.78   

143 
 

Band name Resolution 
(m) 

Central wavelength 
(nm) 

Bandwidth (nm) Purpose 

B01 60 443 20 Aerosol detection 
B02 10 490 65 Blue 
B03 10 560 35 Green 
B04 10 665 30 Red 
B05 20 705 15 Vegetation classification 
B06 20 740 15 Vegetation classification 
B07 20 783 20 Vegetation classification 
B08 10 842 115 Near-infrared 
B08A 20 865 20 Vegetation classification 
B09 60 945 20 Water vapor 
B10 60 1375 30 Cirrus 
B11 20 1610 90 Snow / ice / cloud discrimination 
B12 20 2190 180 Snow / ice / cloud discrimination 
AOT 20   Aerosol Optical Thickness map 
SCL 20   Scene classification layer 
TCI 10 B02+B03+B04  True color image 
WVP 20   Scene-average Water Vapor map 

 

Step 1. Download data. 

The data can be downloaded from several resources such as Copernicus Open Access Hub 
(https://scihub.copernicus.eu/dhus/#/home) and Earth Explore (https://earthexplorer.usgs.gov/). 

A brief guidance from the Copernicus Open Access Hub is shown here.  

 
Press the Open Hub panel and put your login information (or register if you are a new user). After that 
switch the Navigation Mode to Area Mode.  

https://scihub.copernicus.eu/dhus/#/home
https://earthexplorer.usgs.gov/
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Then, 1) draw the region of interest (which will turn yellow).  2) Press the three lines on the Search Criteria 
and add criteria to narrow down the search. We suggest specifying Sentinel 2 as a mission platform. 3) 
Click Search to start the search process.  

 
The search has identified 1045 datasets. Select the appropriate dataset and download it.  

 
Unzip the file. Sentinel 2 dataset has the structure as shown on the left panel. Navigate to the IMG_DATA 
folder. In some cases, the IMG_DATA folder has subfolders, such as R10, R20, and R60. R20 and R60 are 
supported by the IDCubePro®. If any of the subfolders are selected (i.e., R20) you can see all bands that 
are available for processing. Refer to the meaning of each band in the Table of Sentinel 2 bands above.  
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Step 2. Converting data into the IDCube format.  

Select Import Other Formats and Convert to IDCube → Sentinel 2. 

 

You will be prompted to select the folder with the data that will be imported into the IDCube format.  
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After selecting the IMG_DATA folder, a waitbar will appear to show the conversion progress.  

 

The converted file will be saved in the original folder/file location.  

The converted file will automatically be opened and visualized in the IMAGE DISPLAY panel. In this 
example, the data in a folder containing Sentinel 2 images were converted to a single IDCube file, saved in 
the same directory, and opened in the IDCube format.  

 

Zhuhai-1 
The Zhuhai-1 hyperspectral satellite is a commercial remote satellite constellation that was launched first 
in 2018 and is currently operated by Zhuhai Orbita Aerospace Science and Technology Co., Ltd. On 2022, 
there were 10 hyperspectral satellites. These hyperspectral satellites can observe the Earth’s surface every 
2.5 days. The satellites images area are 50 x 50 km, with the spatial resolution 10 m. The sensor has 32 
bands with the spectral resolution of 6 nm (FWHM) shown in the table, generating images 5056 x 5056. 
Additional information is available from https://www.obtdata.com/en/zhuhai1.html. The data are stored as 
individual tiff and jpg files with the hdr file. 

Table: Zhuhai-1 Bands 

https://www.obtdata.com/en/zhuhai1.html
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Band Wavelength 
(nm) 

Resolution 
(m) Band Wavelength 

(nm) 
Resolution 
(m) Band Wavelength 

(nm) 
Resolution 
(m) 

1 440–446 10 12 639–641 10 22 779–781 10 
2 462–469 10 13 664–666 10 23 805–807 10 
3 486–494 10 14 669–671 10 24 819–821 10 
4 496–504 10 15 685–687 10 25 832–834 10 
5 505–514 10 16 699–701 10 26 849–851 10 
6 526–535 10 12 639–641 10 27 863–866 10 
7 545–555 10 17 708–710 10 28 878–881 10 
8 554–565 10 18 729–731 10 29 894–897 10 
9 574–585 10 19 745–747 10 30 908–912 10 
10 590–602 10 20 759–761 10 31 923–930 10 
11 619–621 10 21 775–777 10 32 937–944 10 

 

 
References: 

X. Feng, Z. Shao, X. Huang, L. He, X. Lv and Q. Zhuang, "Integrating Zhuhai-1 Hyperspectral Imagery 
With Sentinel-2 Multispectral Imagery to Improve High-Resolution Impervious Surface Area Mapping," 
in IEEE Journal of Selected Topics in Applied Earth Observations and Remote Sensing, vol. 15, pp. 2410-
2424, 2022, doi: 10.1109/JSTARS.2022.3157755.  
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Bruker (Lumos) 
Lumos microscope generates imaging files that can be saved in a .mat format. This conversion also 
generates an .hdr file that contains the information regarding the dimension of the image. An example of 
this .hdr file is shown below and includes samples that corresponds to the number of pixels in the X – axis, 
lines that corresponds to to the number of pixels in the Y – axis, and bands that correspond to the number 
of spectral bands (Z – axis). (NOTE: the actual number of bands is N = bands – 1). 

To start the conversion, select File → Import Other Formats... → Bruker (Lumos) and open both files. 

 

IVIS (.tiff) 
IVIS (Perkin Elmer) small animal imaging systems such as IVIS SPECTRUM allow a user to collect the 
data at different combination of excitation/emission channels. The resulting data are combined in a single 
folder with multiple subfolders with each folder having several files: 

 

IDCube extracts Luminescent.tif images and combine them in a stack. IDCube does not extract the 
metainformation that is located in the .txt file.  

Step 1. Select File → Import Other Formats... →IVIS (.tiff) 

 

Step 2. In the pop-up menu select the location of the folder.  
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Step 3. Select or create a folder to save the IDCube file with the extracted information.  

 

A messagebox will notify the user that the conversion to the IDCube format is completed and additionally 
a new stack of tiff files is generated and saved in the same directory. 

 

Perkin Elmer (.fsm) 
Perkin Elmer FTIR microscopes and imaging systems collect spectral imaging data in the .fsm format. 
IDCube extracts the image file and converts into a single file. IDCube also extract the limited amount 
meta information. 

Step 1. To start the conversion, select File → Import Other Formats... → Perkin Elmer (.fsm) and 
open an .spc file. 
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Step 2: Select an .fsm file from the dialogue window. 

 

A popup message box will indicate when the conversion is complete. The conversion also generates a 
limited header file as a text file with the same filename as the original one. You can view the header file 
using View →View Header information. 

 
 

Reference: Based in part on Stephen Westlake, Seer Green, PerkinElmer Life and Analytical Sciences 
Copyright (C) 2007. 

WItec (.spc) 
WItec microscopes generates imaging files that can be saved in an .spc format. The Information file (.txt) 
is also stored. To start the conversion, select File → Import Other Formats... → WItec →Witec (.spc) 
and open an .spc file. 



v. 2.78   

151 
 

 

 

In the popup dialog window, WItec Input, enter the Y dimension to satisfy the condition specified in the 
window. Here, IDCube automatically recognized the total number of pixels (=4800).  

 

To identify the Y dimension, open the saved text file with Notepad (only a portion of the text is shown 
below). Point per Line corresponds to the width (X dimension), Lines per Image corresponds to the height 
(Y dimension).  
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You can save the dataset as a new file in the IDCube format by clicking Save Data As…→ Save in IDCube 
format(.m) or CTRL+S. 

Zeiss (.czi) 
Zeiss microscopes generates imaging files saved in an .czi format. Perform the following steps 

Step 1. To start the conversion, select File → Import Other Formats... → Zeiss (.czi)  

 
Step 2. Select a .czi file from a dialogue window. 
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A popup message box will indicate when the conversion is complete. The conversion also generates a 
limited header file as a text file with the same filename as the original one. You can view the header file 
using View →View Header information. 

 

Open Color Image   

NOTE: Opens a color image in tiff, png, or jpeg format. 

Features:  

Enables the users to process any color image as a hyperspectral imaging dataset.   

Steps: 

1. Select File → Open Color Image and open the file.  

   
2. Process the file with any of the functions available in IDCube. 
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The number of channels is equal to 3. Red color corresponds to channel 1, green color corresponds to 
channel 2, and blue color corresponds to channel 3.  

Convert individual tif/tiff, png, and jpeg images into a stack  
NOTE: IDCube directly imports only stacks. Importing individual files requires converting individual 
images into a stack and then importing the formed stack.  

Features: 

IDCubePro® enables the user to convert multiple individual tiff, png, and jpeg files into a stack (the user 
can select the type of a stack file: tiff, png, or jpeg) and then import a stack file to IDCubePro®. 

The following example Cells_tiffs dataset is used as an example: The file presents a compilation of 10 tiff 
files.  

1. Click File → Import other formats and Convert to IDCube → Convert Multiple 
JPEG/PNG/TIF/ Files to Stack. 

 

2. From the opened directory navigate to the folder and select individual tiff files that you would 
like to convert to a stack. 
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3. Press Open. A new window will be opened asking where to save the stack file. The default 
name is ‘Stack’ and the default extension is .tif.  

 

You can rename the file and select a different type of file from the dropdown menu. 

 
Click Save. The completion of the file conversion will be confirmed. 
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Press OK. The stack file will be ready for import into IDCubePro® as shown in the next chapter Import 
JPEG/ PNG/ TIF/ Stack. 

Open Legacy Format   
NOTE: This function is only available for data stored in a folder with two separate matlab files: Image.m 
and wavelength.m.   

Features: opens MATLAB datafiles with or without header files. Image.m file has all the data, and 
wavelength.m files have header information.   

Steps: 

1. Click File → Open Legacy Format Datasets (Matlab), or click Ctrl+L. 

 
2. Select a folder with your data. The folder should have one file Image (format N x M x L) or 

two files with the names Image (format N x M x L) and wavelength (a linear vector that defines 
the wavelengths in L). Files with other names will be ignored. 

3.  Click Open to visualize the data. NOTE: if the wavelength file is absent the channels for 
datasets will be defined as 1,2,3 etc. 
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Download Example Files 
IDCubePro® enables the user to download files directly from the IDCube files depositary stored in a cloud 
location. The file will be downloaded as a ready-to-use file in the IDCubePro® format (.mat or .m 
extension). Additional datasets can be also opened from our website https://www.idcubes.com/examples.  

You can see in the left corner that the file will start downloading after you select the example dataset.  

 

If the file is too large it might be downloaded as a zip file. The files can also be downloaded from the file 
menu. Go to File → Download example files in IDCube format. 

 

https://www.idcubes.com/examples
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Selects the example file to download.  Currently available options are:  

• Rose Leaves (hyperspectral) 
• Plastic and Coin (hyperspectral)  
• AVIRIS data (hyperspectral) 
• St. Louis area (multispectral) 
• Farmland and rivers (multispectral) 
• FLIM (fluorescence lifetime imaging) data 
• Hand image in SWIR (hyperspectral) 

The list of files might be updated. You will be redirected to a web browser. IDCube file format will 
download automatically.  

References: 
For more information on the example files like size and instrument, visit our website at 
https://www.idcubes.com/examples  

https://www.idcubes.com/examples
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Recent IDCube Datasets 
The function allows the user to reopen recently opened files. The function shows files opened during the 
current session of the software 

 

Export Setup 
NOTE: Can be used to export the panel views without performing screenshots. Available for the Main 
Interface and all toolboxes. 

Features: Customizes figures and interfaces before saving.  

The example below shows how to use the EXPORT SETUP window to customize a figure before saving. 
It shows how to change the figure size, background color, font size, and line width. It also shows how to 
save the settings and apply them to other figures and toolboxes before saving them. 

Set the figure size by clicking File → Export Setup. In the toolboxes, this function is located in the Export 
→ Export Setup. 
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Set Figure Size 
Specify the desired dimensions in the Width and Height fields, for example, 5-by-4 inches. The 
dimensions include the entire interface window except for the frame, title bar, menu bar, and toolbars. If 
the specified width and height are too large, then the figure might not reach the specified size. 

To make the axes fill the figure, select Expand axes to fill the figure. 

 
Click Apply to Figure. Applying the settings changes the appearance of the Interface figure on the screen. 
All settings from the EXPORT SETUP dialog are applied to the figure. Thus, more than just the figure size 
can change. For example, by default, IDCubePro® converts the background color of the saved figure to 
white. 

Set Figure Background Color 
Set the figure background color by clicking the Rendering property in the EXPORT SETUP window. In 
the Custom color field, specify either a color name from the table or an RGB triplet. For example, set the 
background color to yellow by typing ‘y’ in the custom color field. 

 
 



v. 2.78   

161 
 

 
An RGB triplet is a three-element row vector whose elements specify the intensities of the red, green, and 
blue components of the color. The intensities must be in the range [0,1], for example, [0.4 0.6 0.7]. 
This table lists some common RGB triplets that have corresponding color names. To specify the default 
gray background color, uncheck the Custom Color checkbox. 

Long Name Short Name Corresponding RGB Triplet 

white w [1 1 1] 
yellow y [1 1 0] 

magenta m [1 0 1] 
red r [1 0 0] 

cyan c [0 1 1] 
green g [0 1 0] 
blue b [0 0 1] 
black k [0 0 0] 

Set Figure Font Size and Line Width 
Change the font by clicking the Fonts property. Specify a fixed font size and select a font name, font-
weight, and font angle. For example, use the default font. The tick mark locations might change to 
accommodate the new font size. 
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Change the line width by clicking the Lines property. Specify a fixed line width, for example, 2 points. 

 
Click Apply to Figure on the right side of the Export Setup dialog. 

Save Figure to File 

Save the figure to a file by first clicking Export, and then specify a file name, location, and 
desired format. For more information about file formats, see the following chapter Save 
Interface Image As… 

 
Save Figure Settings for Future Use 
Save your settings to use for other figures (i.e., toolboxes) by creating an export style. In the Export Styles 
section, type a style name, for example, MyCustomSettings. Then, click Save. 

 
Apply Settings to Another Figure 
Apply your settings to another figure by opening the Export Setup box from its figure menu. In the 
EXPORT STYLES section, select the style name and click Load. Next, click Apply to Figure on the right 
side of the Export Setup dialog. MATLAB applies the saved style settings to the figure. 
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Restore Figure to Original Settings 
Restore the figure on the screen to the original settings by clicking Restore Figure. 

 

Copy Interface View 

NOTE: Can be used with the Main Interface, all toolboxes, and many pop-ups. In the toolboxes, this 
function is in the Export tab. 

Feature: Enables the user to copy the entire interface of the selected frame or window. 

Steps: 

1. Open a file. 

Select File → Copy Interface View (or Cltr+R). In the toolboxes, this function is located in the Export 
→ Copy Interface View (or Cltr+R). 
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2. Open Word, PowerPoint, or any other software and paste (i.e. by clicking Ctrl+V). 

Save Interface View As… 

NOTE: Common for the Main Interface, all toolboxes, and many pop-ups.  

Feature: Enables the user to save the entire image of the IDCubePro® Main interface and toolboxes. 

Steps: 

1. Open a file. 

2. Select File → Save Interface View As…  In the toolboxes, this function is located in the Export 
→ Save Interface View As… 

 

 

 

 

3. You will be asked to name the file and select the folder. By default, the folder will be the same as 
where the original file is located. 
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NOTE: The saved image might look different from the actual image. For example, you might see white 
fields around the panels. To remove this white background use Export Setup, select Rendering and 
uncheck the custom color (w stands for white).  

 
Click Apply to Figure and OK to close the Export Setup dialogue window. The white background will 
be replaced with the original gray.  
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Save and Close in IDCube Format 
Features: This function is used to prompt users whether they want to save the image before returning to 
the original view without exiting the application. The same function is available from the toolbar by 

clicking the corresponding icon . 

 

Call this feature by selecting File → Save and Close in IDCube format (.m) and choose a format. Once 
called, the function will open a new figure window, asking the user if they would like to save the file before 
exiting the application. 

 

 

In the figure, there are two buttons: "YES" and "NO". The user should click on one of these buttons to 
proceed. 
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If the user clicks "YES", the new datacube file will be saved in the IDCube format (.mat file) in the default 
directory and asks for the file name.  

 

A waitbar will appear, displaying the progress of the saving operation. When the data has been saved, a 
message box appears informing the user that the data cube has been saved. 

 

The function will then close the figure window and return to the original screen. 

 

If the user clicks "NO", instead of saving the data, it simply closes the window and displays a message 
box saying that the data cube has not been saved. 
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Save Data As... 

Features: Enables the user to save and export the processed dataset into several formats including tiff, 
raw/hdr, avi, and .xlsx which are commonly used by a variety of data and image analyses.  

Load the image file and select File → Save Data As… and choose a format.  Available options are: 

• Saving in the IDCube format 
• Saving as a tiff stack of frames in a tif/tiff format 
• Saving in an ENVI (raw/hdr) format 
• Saving datacube into a video (avi) format 
• Saving the entire datacube in an Excel (xlsx) format 
• Saving the current frame in an Excel (4) format 

 

 

Save in IDCube format (.m)  
You can use this function to save the changes in the IDCube format. A pop-up window will ask for the 
name of the new file and the folder. By default, IDCubePro® uses the original folder for saving.  

You can opt for automatic opening of the saved file by checking the Automatically open data after saving 
box.  

 



v. 2.78   

169 
 

Save as a stack of frames in tif/tiff format 
This option allows the user to save the entire dataset into a tiff stack of frame-by-frame tiffs. You will be 
asked to select a folder.  

 
The stack of frames in a tiff format will be automatically saved in the selected directory.  

 

 

Save in ENVI (raw/hdr) format 
This option allows the user to save the entire dataset into one of the most common hyperspectral imaging 
formats used by ENVI Image Processing & Analysis Software and other companies.  

Select Raw/HDR radio button and specify a folder from the pop-up window. Click Convert.  

 

Save in a video (avi) format 
You can use this function to generate a frame-by-frame movie. This function can also be combined with a 
Single Channel and Two-Channel option with selected equations. A new pop-up will ask for the name of 
the new file and the folder. By default, IDCube uses the original folder for saving. 
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After the file is formed, it can be opened via a variety of programs that support the avi format. 

 

Convert the Entire Datacube into the Excel format 
Click Save As…→ Excel → Entire Datacube and put the name of the file. Click Save.  

 
A pop-up message will warn that this operation might take time. A pop-up message box will inform when 
the conversion is complete. 
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The number of tabs in the Excel spreadsheet is equivalent to the number of bands/channels. For example, 
if the file has 103 channels, there will be 103 tabs labeled 1-103. The assignment of the channels to 
wavelengths will be implemented in future versions of IDCube.  

 

Save the Current Image into the Excel format 
Click Save As… → Excel → Current Image and select the folder and the name of the file. Click Save. A 
pop-up message box will inform when the conversion is complete.  

 
Open an Excel file. The rows and columns correspond to the spatial dimensions of the saved image.  

 
Additional Information: 

All saving functions, except the movie, can be also activated through the Export Tab.  
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Additional saving functions (such as interactive Mean spectrum from the area, and All Spectra from the 
area) are available from the Export Tab.  

 
Save Histogram-Modified Dataset 

Features: This function enables saving the entire dataset after adjusting monochromatic histogram in the 
HISTOGRAM panel. The intensity of pixels outside the boundaries defined by the HISTOGRAM panel 
will become equal to zero. 

Steps: After adjustment the histogram select File → Save Histogram-Modified Dataset and select a 
destination folder. By default, the current folder will be opened. You can create a different folder. Press 
Select Folder. 

 
A message box will pop-up to display a message indicating that the file is being saved.  

 
The saved file will be named automatically. The original filename will be appended with a timestamp. 
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Print Preview and Print 
NOTE: Plastic Bowl file is used as an example.  

Features: 

Enables the users to print a currently active figure window 

Common for the Main Interface and all toolboxes 

Steps:  

We recommend adjusting the printing area by using Print Preview before printing. 

1. Activate the window by clicking somewhere on the window. Select File  → Print Preview   

 
2. A Print Preview dialogue box will appear. This box controls the layout and appearance of figures 

before sending them to a printer or print file. A scaled version of the figure is displayed in the right-
hand pane of the dialog box. Controls are grouped into four tabbed 
panels: LAYOUT, LINES/TEXT, COLOR, and ADVANCED. 

You can position and scale plots on the printed page using the rulers in the right-hand pane of the Print 
Preview dialog.  

• Use the outer ruler handlebars (black boxes pointed by red arrows) to change margins. Moving 
them changes plot proportions.  

• Use the center ruler handlebars to change the position of the plot on the page. Plot proportions do 
not change, but you can move portions of the plot.  

• The buttons on that pane let you refresh the plot, close the dialog (preserving all current settings), 
print the page immediately, or obtain context-sensitive help.  

• Use the Zoom box and scroll bars to view and position page elements more precisely. 

Tip: To print the entire view of the window of interest (active window) select Use manual size and 
position the radio button and click Best fit.   
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3. Click Print and select printing preferences. (This function can be also activated from File → Print 

or Ctrl+P) 
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Layout  

Use the LAYOUT tab, shown above, to control the paper format and placement of the plot on printed pages. 
The following table summarizes the Layout options: 

Group Option Description 

Placement Auto Let IDCube decide the placement of the plot on the page. 
  Use manual... Specifies position parameters for a plot on the page. 
  Top, Left, Width, Height Standard position parameters in current units. 
  Use defaults Reverts to the default position. 
  Fill page Expands figure to fill printable area. 
  Best fit Expands figure to fill printable area, center the figure, and preserve the 

figure’s aspect ratio. 
  Center Centers plot on the printed page. 
Paper Format Allows U.S. and ISO® sheet size selector. 
  Width, Height Sets sheet size in current units. 
Units Inches Uses inches as units for dimensions and positions. 
  Centimeters Uses centimeters as units for dimensions and positions. 
  Points Uses points as units for dimensions and positions. 
Orientation Portrait Sets upright paper orientation. 
  Landscape Sets sideways paper orientation. 
  Rotated Currently the same as Landscape. 

Lines/Text Tab 
Use the LINES/TEXT tab, shown below, to control the line weights, font characteristics, and headers for 
printed pages. The following table summarizes the LINES/TEXT options: 
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Group Option Description 

Lines Line 
Width 

Scales all lines by a percentage from 0 upward (100 being no change), print lines at a 
specified point size, or default line widths used on the plot. 

  Min Width Sets smallest line width (in points) to use when printing; defaults to 0.5 point. 
Text Font 

Name 
Selects a system font for all text on the plot, or default to fonts currently used on the 
plot. 

  Font Size Scales all text by a percentage from 0 upward (100 being no change), print text at a 
specified point size, or default to this used on the plot. 

  Font 
Weight 

Selects Normal ... Bold font styling for all text from the drop-down menu or default to 
the font weights used on the plot. 

  Font 
Angle 

Selects Normal, Italic, or Oblique font styling for all text from the drop-down menu or 
default to the font angles used on the plot. 

Header Header 
Text 

Allows typing the text to appear on the header at the upper left of printed pages, or leave 
it blank for no header. Header text only supports plain text characters. 

  Date Style Selects a date format to have today's date appear on each printed page, or none for no 
date. 

Color Selection Tab 
Use the Color tab, shown below, to control how colors are printed for lines and backgrounds. The following 
table summarizes the Color options: 
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Group Option Description 

Color Scale Black and White Select to print lines and text in black and white but use color for patches and 
other objects. 

  Gray Scale Convert colors to shades of gray on printed pages. 
  Color Print everything in color, matching colors on the plot; select RGB (default) 

or CMYK color model for printing. 
Background 
Color 

Same as figure Print the figure's background color as it is. 

  Custom Select a color name or type a colorspec for the background; white (default) 
implies no background color, even on colored paper. 

Advanced Tab 
Use the ADVANCED Tab, shown below, to control finer details of printing, such as limits and ticks, 
renderer, and resolution. The following table summarizes the ADVANCED options: 

Group Option Description 

Axes limits 
and ticks 

Recomputes limits 
and ticks 

Redraws x- and y-axes ticks and limits based on printed plot size (default). 

  Keeps screen limits 
and ticks 

Uses the x- and y-axes ticks and limits shown on the plot when printing the 
previewed figure. 

Miscellaneous Renderer Selects a rendering algorithm for printing: painters, openGl, 
or auto (default). 

  Resolution Select resolution to print in dots per inch: 150, 300, 600, or auto (default), 
or type in any other positive value. 

  Print UIControls Not available in IDCube Pro. 
 

Alternatives: Use File → Print Preview on the figure window menu to access the Print Preview dialog 
box, described below. IDCube also offers additional controls such as Lines/Text, Color, and Advanced. 
Some functions and buttons might not be available for IDCubePro® users. 
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Print  
NOTE: We highly recommend adjusting the printing parameters by using Print Preview first. 

Features:  Enables the users to print the currently active figure window.  Common for the Main Interface 
and all toolboxes 

Steps: 

1. Select File → Print or press Ctrl+P   

 
2. Select the printer and press OK 

 

Generate Report  

Feature: Reports are generated showing which functions were applied to the datacube. IDCubePro® stores 
many steps that were applied to the dataset.  

Select File → Generate Report to generate a list of functions that were applied to the dataset. This is 
usually done at the end of the image processing session. 
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Pressing Generate Report automatically activate a pop-up dialog window. Select the directory, enter the 
file name and click Save. The default directory is where the original dataset is located.  

 

 
Open the saved file outside of IDCubePro®. The report lists all functions that were applied to the dataset.  
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7.2. Export Tab  
NOTE: This tab is not available in the Main Interface window. The equivalent functions are located under 
the File Tab. 

The functions implemented under the Export Tab enable changing the visualization of the interface, 
improving the visual appearance of the interface, and copying and saving the view of the interface. The 
functions also provide additional information regarding the dataset.  

 

  

Tabs Function Additional info 

View Tab Export Setup See description in File Tab – Export Setup section 
 Copy Interface View (Ctrl+R) See description in File Tab – Copy Interface View  section 
 Save Interface View As… See description in File Tab – Save Interface View As… section 
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7.3. View Tab 
The functions implemented under the View Tab provide changes to the visual appearance of the entire 
IDCubePro® package with all connected toolboxes, add/remove toolbars, and improve the visual 
appearance of the image on the Image Display. The functions also provide additional information regarding 
the dataset.  
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Changing the Colortheme  of the Interface 

Features: Enables the users to change the color of the interface work in three different colorthemes. 

Select View → Colortheme and select one of the following options: Gray (default), Dark Grey, Dark Blue. 
All toolboxes will also follow the selection and will have the selected colortheme. 

 
Gray (default): 

Tabs Function Additional info 

View Tab Changing the Colortheme of The Software Additional menu 
 Close/Open Color LUT toolbar Toggles the appearance of the 

colortheme 
 Camera Toolbar Enables Camera toolbar 
 LUT Generator Opens an interactive LUT generator 
 View All Frames Visualizes all frames in a 2D format 
 List of Bands/Channels A pop-up window shows all bands in 

the dataset 
 Image Scale Adds scale to the image 
 Expanded View Expands the image in X-dimension 
 View Header Information Pop-up window open the header 

information  
 View Image Information Pop-up window shows the current 

image information 
 View Image HeatMap Visualizes the image with in a HeatMap 

view (opens as a separate window) 
 Edit Plot Interactive changes in the layout 
 Turn Instructions Off (toggle) Prevents pop-up notification and 

suggestions 
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Dark Gray: 

 

Dark Blue: 

 

LUT generator  
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: The LUT generator GUI allows you to create and customize a color Lookup Table (LUT) using 
a graphical user interface.  

The LUT generator GUI provides an intuitive interface for creating and customizing a color Lookup Table. 
By following the steps outlined in this manual, you can select colors, create gradients, save and load LUTs, 
and clear the color selections. Experiment with different color combinations and gradients to generate the 
desired LUT for your application. 

Steps to Use the LUT Generator GUI: 

Step 1: Launch the GUI 
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To launch the LUT generator GUI, press the brush icon or select View → Colormap Editor. The GUI 
window titled "IDCubePro: Colormap Editor" will appear. 

 
Step 2: Select Colors 

The GUI window displays 50 color strips as push buttons. Each button represents a color in the LUT. Follow 
these steps to select and customize colors: 

1. Click on a color strip button, for example the first box on the left to open the Color Picker dialog. 
(Color Picker allows many ways to select the color) 

     
In the color picker dialog, choose your desired color and click "OK." 

2. The selected color will be applied to the corresponding color strip button. 
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3. Repeat steps 1-3 to customize other color strips as needed manually. 

Step 3: Create Gradients 

To create a gradient between two selected color strips: 

1. Click on the first color strip button. 

2. While holding the Shift key, click on the second color strip button. 

3. The color strips between the selected strips will now form a gradient. The gradient is 
automatically calculated and displayed. In this example, the first button was assigned to yellow and 
the last button to blue colors.  

 
4. You can generate more complex multicolor gradients by assigning colors to different buttons. In 
this example, the first button is yellow, the middle button is blue, and the last button is green. 

 
 

Step 4: Save and Load LUT 

You can save and load the created LUT using the provided buttons: 

1. Click the "Save LUT" button to save the current LUT. 

   - Choose a file name and location to save the LUT as a .mat file. In this example we save the 
multigradient LUT as New_Lut.mat 

2. Click the "Load LUT" button to load a previously saved LUT. 

   - Choose the saved .mat file to load the LUT into the GUI. 
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Step 5: Clear Colors 

To clear all the colors and reset the LUT: 

1. Click the "Clear Colors" button. 

   - All color strips will be set to their default color. 

   - The LUT will be reset to its initial state. 

 

Step 6. Applying a new colormap 

You can call the saved custom colormap by selecting Custom Colormap icon that at the start looks like 
the o .  

 
That opens a dialogue where you can open a saved LUT. Select the file and click OPEN. 

 
The new LUT will be automatically applied to the image. 
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View All Frames 

Features: The function is designed to visualize hyperspectral datacube images all at the same time as 
thumbnails. 

The function processes a hyperspectral datacube, applies spatial (currently not implemented) and spectral 
binning (combining neighboring wavelength bands to reduce the number of frames), and visualizes all 
resulting images in a grid format. Each image corresponds to a different wavelength band of the data 
cube. Furthermore, the function provides an option to enlarge individual images upon clicking them. 

1. Select View → Colortheme. The function retrieves all necessary color data from the preset 
function. 
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2. Binning: The function then performs spatial (not implemented) and spectral binning on the data 
cube to reduce its size. It ensures that the number of binned wavelengths doesn't exceed 40. 

3. Presenting frames: A grid of subplots is created to display the images from the binned data cube. 
The number of rows and columns in the grid is determined based on the number of binned 
wavelengths.  

 

4. Interactivity: Each image from the binned data cube is displayed on a subplot. Each subplot title 
is clickable (shown by a red arrow) and opens an enlarged version of the image when clicked. 

Enlarged image can be interactively processed through the toolstrip bar . 
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5. If the number of binned wavelengths is less than the original number of wavelengths in the data 
cube, a warning message is displayed to the user about the limitation of the number of frames. The 
user is also informed that they can click on the subplots to enlarge the images. 

 

 

Notes: 

- The function was designed to handle large hyperspectral data cubes. However, due to the size of such 
data cubes, the visualization might take some time. 

- If the number of wavelengths in your datacube is very large (more than 40), the function will limit the 
number of displayed frames by binning the wavelengths. A warning message will inform you about this. 

List of Bands/Channels    

NOTE: PAVIA dataset is used as an example 

Features: Enables viewing a list of bands and channels in the dataset. 

IDCube uses the following notation: bands are assigned the order number (1, 2, 3, etc.), while the channels 
have units (i.e., wavelengths, 430, 434, 438, etc.) as illustrated in the screenshot below.  

Steps: 
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1. Open a hyperspectral imaging file through the Main interface: File → Open dataset in IDCube 
format. 

2. Click View → List of bands/channels. 

   

3. Copy the list of the bands with the corresponding channels to Excel or another software. 

a. By clicking on the Copy menu option. 

b. By highlighting the desired data and right-clicking. 

c. By highlighting the desired data and using Ctrl+C. 

Image Scale  
NOTE: The default image does not show a scale. The addition of the scale to the image is temporary. 

Features: Enables the users to see the scale in pixels. The same effect can be achieved by using a hotkey: 
a spacebar on the keyboard. 

Steps: 

Select View →  Image Scale (Ctrl+G) to visualize the scale. Move any of the sliders or engage any of the 
functions to remove the Image Scale. 

Or click on the Image Display and press the spacebar to activate scale (See Keyboard and Mouse 
Shortcuts).  
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Expanded View 
NOTE: Enables temporary expansion of the image over the entire IMAGE DISPLAY panel. 

Features: Enables the users to automatically adjust the image to the entire view. The same effect can be 
achieved by using hot keys: n – expanded view, e – normal view (default) from the keyboard. 

Steps: 

1. Select View →  Expanded View (Ctrl+N) to visualize the image over the entire IMAGE 
DISPLAY panel. 

 

View Header Information  
Features: Extracts header information from a limited number of formats. Currently, only hdr files from the 
ENVI format are fully supported. 
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View Image Information  
NOTE: IMAGE INFORMATION panel only shows the information of the visualized frame. The panel 
also pops up after changes to the spatial coordinates (i.e., cropping, binning).  

Features: Enables the users to view basic information about the entire dataset. 

Steps: 

1. Open a file.  

2. Select View → Image Information or use a hot key (Ctlr+I).  

 
3. Visualize the information about the image. The IMAGE INFO panel includes the width (x-

dimension) and height (Y-dimension) of the image, class of data (single, double), image type 
(intensity for monochromatic, and truecolor for RGB), the minimum and maximum intensity of the 
currently shown image, the number of bands (z-axes), and the size of the file calculated as  

Size = [(columns x rows x bands) x 8] / (1000^2), MB  
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NOTE: The size of the file is determined based on MATLAB's conventions. This calculated size may differ 
from the actual displayed size. This discrepancy can occur due to the difference in storage units used, 
overhead from the file system, and the file compression methods used by the operating system. For instance, 
a file named 'Pavia' has an image size of 610x340x103 in the double class, which translates to 170897600 
bytes or approximately 170.8976 MB. However, when you look at the size of this file in the File Explorer, 
it shows as only 48.990 MB. 

View Image HeatMap 

Features: This feature visualizes the image as a Heatmap that allows the user to visualize the values of 
individual pixels after the zoom. 

 
A new window Heat Map will be activated. Zoom on the window to visualize values of individual pixels.  
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Tips 

To interactively explore the data in your heatmap, use these options: 

o Zoom — Use the scroll wheel of the mouse or the + and - keys to zoom. 

o Pan — Click and drag the heatmap or use the arrow keys to pan across the rows or columns. 

o Data tips — Hover over the heatmap to display a data tip. 

o Rearrange rows and columns — Click and drag a row or column label to move it to a different 
position. 

o Sort values — Click the icon that appears when you hover over the row or column label. Click once 
to sort the values in ascending order, twice to sort the values in descending order, and a third time 
to reset the order. 

NOTE: The changes made with this feature will not affect your original data or the data used in the Main 
interface. 
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Edit Plot 

 
This action will activate the Edit Plot mode that can be also activated by pressing Ctrl+E. In this mode 
you can move most of the objects including buttons and frames. This function is equivalent to pressing the 

button . After activation the button will turn blue. 

Exit the Edit Plot mode by clicking the button  located in the Main Toolbar. NOTE: the changes 
made in the Edit Plot mode can be undone using Ctrl+Z. See more about Edit Plot mode in the dedicated 
section. 

Turn Instructions Off  

Features: Many toolboxes provide brief instructions in the form of pop-up message boxes. This function 
enables the users to turn Instructions off. 
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7.4. Edit tab 

Functions implemented in the Edit Tab allow you to modify your dataset. All changes are global, which 
means the changes are saved internally and replace the original dataset during the computation session. 
However, no changes are applied to the original data stored in your folder. Your original data will not be 
affected.  

Rotate and Flip 

NOTE: PAVIA dataset is used as an example. 

Features: Enables rotation of the entire dataset. 

Steps: 

1. Open a hyperspectral imaging file such as PAVIA through File  Open Dataset in IDCube 
format.  

2. Click Edit, Rotate and select one of the rotation options or select the icons:  

a. Flip Horizontally 

b. Flip Vertically 

c. Rotate Clockwise 90 Degree 

d. Rotate Anticlockwise 90 Degree.  

Tabs Function Additional info 

Edit tab  Rotate and Flip Additional menu 
 Spatial Crop Additional menu 
 Bin (spatial and spectral) Additional menu 
 Compression  
 Spectral Crop Dialogue window 
 Change Bands Replaces with new bands 
 Remove Bands Pop-up window 
 Remove Bad Pixels Pop-up window 
 Annotations (textboxes, arrows) Additional menu 
 Edit Plot Mode Activates interactive plot 
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Example: Rotate Clockwise 90 Degree: 

 
Click Reset to return to the original view. NOTE: this will reset the entire image including a crop or filter.  

Spatial Crop 
NOTE: PAVIA dataset is used as an example.  

Features: Enables spatial cropping of the entire dataset. 

Steps: 

1. Open a hyperspectral imaging file through the Main Interface.  

2. Click Edit → Crop and select one of the cropping options or select of the icons:  
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3. Click Spatial crop (also can be triggered by using an icon  ). 

4. Alternatively, click Interactive crop in the DATA REDUCTION panel. 

 

 
5. Move the boundaries of the active frame. 

NOTE: Spatial crop activates an interactive rectangular (active frame) that enables the user to select the 
region of interest and crop the rest of the image. Move the boundaries of the active frame with the mouse. 
The coordinates of the frame in a format [left bottom width height] can be seen below the image. The 
meaning of the coordinates is shown below. The units are pixels. When the active frame size is adjusted, 
IDCube automatically updates the coordinates to the new values. 

 
6. Click Apply Crop. The change will be applied globally and a new datacube will be stored in the 

internal memory. A new pop-up window with the information about the new dataset will appear 
in the left corner showing the dimension of the new frame, type of data, color, and maximum and 
minimum. In the case of the RGB, the maximum and minimum will not be shown.  
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7. Click Reset to return to the original view. NOTE: this will rest the entire image back to the 

original including any filters or histogram adjustments.  

8. The new dataset can be saved using a standard Save function. 

Spectral Crop 

Features: Enables spectral (z-dimension) cropping of the entire dataset. 

Steps: 

1. Open a hyperspectral imaging file through the Main interface (File → Open). 

2. Click Edit → Crop → Spectral Crop. 

 
A new window pops up. Enter the value for the lowest spectral limit and the upper spectral limit: 

 

Click OK. The new datacube will be spectrally cropped. The original data will not be affected. 
Alternatively, this can be done from the DATA REDUCTION panel on the Main interface: 
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Bin (spatial and spectral) 

NOTE: PAVIA dataset is used as an example. 
Features: Performs spatial and spectral binnings of the entire dataset. 

Steps: 

1. Open a hyperspectral imaging file through the Main Interface. 

2. Click Edit → Bin and select one of the binning options: 

a. Spatial binning – only perform binning in the spatial coordinate to decrease the number 
of pixels. 

b. Spectral binning – only perform binning in the spectral coordinate to decrease the number 
of spectral bands. 
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3. Click Reset to return to the original view. 

NOTE: Reset will reset all changes made including crop and filters. 

4. The new dataset can be saved using the standard Save function. Alternatively, Spatial Binning can 
be done from the Main Interface. 

 

Compression 
There are several compression algorithms that can be used for hyperspectral imaging. Some commonly 
used ones: 

Lossy compression algorithms: These algorithms compress the data by removing some of the less 
significant information. Popular lossy compression algorithms for hyperspectral imaging include Principal 
Component Analysis (PCA), Independent Component Analysis (ICA), and Wavelet Transform. These 
compression functions are implemented in the IDCubePro. Another popular compression function Discrete 
Cosine Transform (DCT) will be implemented in future releases 

Lossless compression algorithms: These algorithms compress the data without any loss of information. 
Some popular lossless compression algorithms for hyperspectral imaging include Huffman coding, 
Arithmetic coding, and Run-length encoding. These compression functions will be implemented in future 
releases. 

Hybrid compression algorithms: These algorithms combine both lossless and lossy compression techniques 
to achieve better compression ratios. One example of a hybrid algorithm is the Spectral-Spatial 
Hyperspectral Image Compression (SSHIC) algorithm These compression functions will be implemented in 
future releases. 

The choice of compression algorithm will depend on the specific requirements of the application, such as 
the desired compression ratio and the level of compression artifacts that can be tolerated. 

PCA compression 
Step 1. Select a compression method: Edit → Compress → PCA compression 
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Step 2. Select the desired percent variance from a dialogue window. Higher number of variance will give 
more bands and low compression ratio. Significant level of information might be preserved. Lower number 
will have very few principal components.  

 

Step 3. Select a folder to save the compressed datafile. The file name will be generated automatically as 
compressed datacube_96%.mat, where the number indicated selected percent variance.  

 

 

After completion, IDCube calculates the compression ratio by comparing the size of the original data and 
the size of the compressed data. This information, along with the number of independent components and 
the size of the saved file, is then displayed to the user. 
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The message box indicates that the new compressed datacube file can be opened in a usual way. 

 

 

 

Additional Information 

Principal Component Analysis (PCA) is a technique often used to reduce the dimensionality of large data 
sets, such as hyperspectral images, by transforming a large set of variables into a smaller one that still 
contains most of the information in the larger set. 

Hyperspectral images contain hundreds to thousands of bands for each pixel in an image, which results in 
a huge amount of data. PCA can be used to compress this data by finding new variables, or principal 
components, that capture most of the variance in the original data set. To compress the hyperspectral data 
using PCA with a percent variance as a criteria the algorithm follows the following steps: 

• Reshapes the datacube into a 2D matrix, where each row represents a spatial location and each 
column represents a spectral band. Also, center and scale the data to have zero mean and unit 
variance along each band. 

• Computes the covariance matrix of the centered and scaled data matrix. Computes the eigenvectors 
and eigenvalues of the covariance matrix. Then, sorts the eigenvectors in descending order of their 
corresponding eigenvalues. 

• Computes the cumulative variance explained by each principal component. 
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• Chooses the number of principal components to retain based on the desired percent variance (input 
from the user) views to preserve. For example, to retain 95% of the variance, you can find the index 
of the first principal component whose cumulative variance is greater than or equal to 0.95. 

• Projects the centered and scaled data matrix onto the selected principal components to obtain the 
compressed data matrix. Reshapes the compressed data matrix back into the original 3D datacube. 

The saved compressed dataset contains the compressed hyperspectral datacube, where the number of 
spectral bands has been reduced to number of principal components. 

ICA compression 
Step 1. Select a compression method: Edit → Compress → ICA compression. 

 

 

 

Step2: ICA Input. The function prompts the user to enter the number of independent components to be 
extracted (used as a measure of how much to compress the data, the default value is 10 components) and 
the regularization parameter lambda. The default value is 1. The regularization parameter is used in the ICA 
algorithm to control the trade-off between data fit and complexity of the model.  
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After completion, IDCube calculates the compression ratio by comparing the size of the original data and 
the size of the compressed data. This information, along with the number of independent components and 
the size of the saved file, is then displayed to the user. 

 
The message box indicates that the new compressed datacube file can be opened in a usual way. 

 
Additional Information: 

Independent Component Analysis (ICA) is a computational method for separating a multivariate signal into 
independent non-Gaussian signals. It is a method that attempts to decompose a multivariate signal into 
independent subcomponents. It is a more general form of Principal Component Analysis (PCA), which only 
decorrelates signals. 

For instance, imagine you have multiple microphones placed in different positions in a room and multiple 
people are speaking simultaneously. Each microphone captures all the voices, but the volume of each 
speaker's voice will vary based on their distance from the microphone. ICA can be used to separate the 
individual voices (independent components) from the mixed recordings (multivariate signal). 

Compared to PCA, which only looks for uncorrelated factors in the data, ICA goes a step further to find 
independent factors. While uncorrelated components can be statistically related, independent components 
are not. PCA tends to find the axes in the data that account for the most variance, but it does not necessarily 
find the actual source signals. 

ICA assumes that the signal sources are statistically independent, while PCA does not require this 
assumption. Because of this, ICA can often provide a more meaningful decomposition of complex datasets 
and is often used when we expect some underlying factors are driving the patterns in the data. 
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ICA assumes that the hyperspectral image is a linear mixture of spectrally pure components, or 
endmembers. The purpose of applying ICA is to unmix the hyperspectral datacube into these endmembers 
and their corresponding abundances. The number of independent components to be extracted is typically 
less than the number of original bands in the hyperspectral image, leading to data compression. 

The actual compression in this case does not involve any physical compression or data encoding. Rather, 
the datacube is compressed in the sense that it is represented by a smaller set of independent components 
(endmembers) and their abundances. This is an example of data reduction rather than data compression in 
the traditional sense. 

PCA vs ICA: 

PCA is often used for dimensionality reduction in hyperspectral imaging, projecting the data onto a new 
coordinate system where the variance of the data is maximized. This results in a set of Principal Components 
(PCs) that are ordered by the amount of variance they explain in the data, which is beneficial for noise 
reduction and data compression. However, the PCs are not necessarily physically meaningful and do not 
correspond to actual material spectra. 

On the other hand, ICA attempts to find a set of statistically independent spectral signatures (endmembers) 
and their abundances, which can be physically meaningful in the context of hyperspectral imaging. These 
independent components can represent the spectra of different materials present in the hyperspectral image. 
In this sense, ICA can not only compress the hyperspectral data but also unmix it into its constituent material 
spectra, making it more interpretable. 

Wavelet Compression 
NOTE: This function performs compression in combination with spectral cropping as specified below. 

Features:  

The Wavelet Compression function performs wavelet-based compression on hyperspectral data and 
generates a dataset w. It prompts the user to enter the type of wavelet and the level of decomposition. The 
hyperspectral data is loaded, and the wavelet transform is applied to each pixel's spectral signature. The 
resulting compressed data is saved in a separate file. 

Step 1. When the file is opened, select Wavelet compression method: Edit → Compress → Wavelet 
compression. 

 

The function will prompt you to enter the type of wavelet (e.g., 'db1') and the level of decomposition (a 
positive integer). Specify the wavelet type and decomposition level in the input dialog and click OK. The 
function will apply the wavelet transform to the hyperspectral data, compressing it. 

Currently supported wavelets families: 
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Wavelet Family Code Vanishing number(N) Wavelet Family Name 

haar none Haar wavelet 

dbN From 1 to 10 Daubechies wavelets 

symN From 2 to 8 Symlets 

coifN From 1 to 5 Coiflets 

 

 
A waitbar will show the progress of the compression. 

 
After setting parameters, a popup dialogue will ask for a folder to store the wavelet processed file.  

 
 

After compression, a dialog box will appear showing the wavelet type, level of decomposition, the size of 
the saved file. 

The message box indicates that the new compressed datacube file can be opened in a usual way. Click OK 
on the dialog box. Another dialog box will appear indicating that compression is complete. The name of 
the file will be generated automatically as Wavelet_compressed_datacube_db1_3.mat, where the db1 
corresponds to the type of wavelet and “3” to the level of decomposition. 
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Step 3. Open the saved file and explore the spectrum of the region of interest.  

Original After wavelet transform 

  
 

You will find that the spectrum seems to be “compressed”.  

NOTE: after a wavelet transform, the bands in the spectral analysis window do not correspond to the actual 
physical values such as wavelengths.  

Step 4. Perform Spectral Cropping. Using Data Tips from the Strip Toolbar identify the end of the 
spectrum as shown below and enter a similar value in the Upper Limit field in the Spectral Crop panel. 
Click Apply. You can save the datacube as a new dataset. The new dataset will have significantly lower 
number of bands and therefore significantly smaller size.   
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NOTE: different types of wavelets and different level of decomposition will provide a different level and 
quality of compression.  

Additional Information:  

Wavelets are small waves. Wavelet compression methods for hyperspectral data offer several advantages 
by achieving good compression ratios while preserving important spectral information and minimizing data 
loss. Additionally, wavelet compression methods can exploit the inherent spectral redundancy present in 
hyperspectral data, leading to efficient compression. 

IDCube wavelet compression method for hyperspectral data relies on transform-based methods. These 
methods involve decomposing the hyperspectral data into wavelet coefficients using the discrete wavelet 
transform (DWT). The coefficients with smaller magnitudes (Y-value on the spectrum) can be discarded, 
resulting in compression. 

Notation:  

Family of wavelets: Wavelets come in many families, each with different characteristics that make them 
useful and unique for different types of signal analysis. IDCube supports most common families of 
wavelets. Haar Wavelets: These are the simplest type of wavelets and the first to be introduced. Haar 
wavelets are discontinuous and resemble step functions. Daubechies Wavelets: Named after Ingrid 
Daubechies, these most common wavelets are designed to have a maximal number of vanishing moments 
for a given support width. This means they can compactly represent polynomial signals. Symlets: These are 
nearly symmetric wavelets that are also designed by Daubechies. They're similar to the Daubechies 
wavelets but have better symmetry, which can be advantageous in imaging applications. The symlets are 
nearly symmetrical wavelets proposed by Daubechies as modifications to the db family. This characteristic 
can be advantageous in certain applications, for example, in image processing where symmetric filters are 
often preferred (Gaussian filter is an example of a symmetric filter). Coiflets: Another type of wavelets 
designed by Daubechies, Coiflets are designed to have 2N moments equal to 0 and have good localization 
in both the spatial and frequency domains.   
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Vanishing moments: Some common families of wavelets denoted by 'nameN', are characterized by having 
N vanishing moments. For example, for a 'db6' wavelet, there are 6 vanishing moments. This property 
means that the 'db6' wavelet is orthogonal to all polynomials of degree less than 6, making it able to 
effectively represent polynomial signals of up to degree 5. This characteristic contributes to the ability of 
the 'db6' wavelet to compactly represent smooth signals. Wavelets with more vanishing moments can more 
effectively capture smooth parts of a signal, but can make it less effective at capturing abrupt changes or 
discontinuities in the signal 

Levels of decomposition: Decomposition in wavelet transforms is a process that involves breaking down 
imaging data set into different frequency subbands. This process is crucial for data compression, as it helps 
to analyze the frequency characteristics of the data, which can then be exploited for efficient compression. 
Higher levels of decomposition divide the data into a more granular set of frequency bands. This allows for 
a more precise analysis of the data, which can result in more efficient compression, especially for complex 
signals or images. This allows for a more precise analysis of the data, which can result in more efficient 
compression, especially for complex signals or images. High levels of decomposition enables the algorithm 
to capture small-scale features that may be missed at lower levels of decomposition. By using higher levels 
of decomposition, the wavelet transform can better capture the correlations or redundancies within the data, 
leading to better compression ratios. However, the trade-off for using higher levels of decomposition is that 
it increases the computational complexity of the wavelet transform and hence, the compression process. 
More levels require more computations, which can slow down the compression. 

The shapes of the supported wavelets are given below: 

Haar (Equivalent to Db1) 

 
Daubechies wavelet (DbN) N=1-10 
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Coiflets (coifN) N= 1-5 

 
Symlets (symN), N= 2-8 

 
Levels of decomposition: 

Decomposition in wavelet transforms is a process that involves breaking down a signal or data set into 
different frequency subbands. This process is crucial for data compression, as it helps to analyze the 
frequency characteristics of the data, which can then be exploited for efficient compression.  

Higher levels of decomposition divide the data into a more granular set of frequency bands. This allows for 
a more precise analysis of the data, which can result in more efficient compression, especially for complex 
signals or images. It enables the algorithm to capture small-scale features that may be missed at lower levels 
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of decomposition. By using higher levels of decomposition, the wavelet transform can better capture the 
correlations or redundancies within the data, leading to better compression ratios. However, the trade-off 
for using higher levels of decomposition is that it increases the computational complexity of the wavelet 
transform and hence, the compression process. More levels mean more computations are required, which 
can slow down the compression. 

One of the advantages of wavelet-based compression is that it can be "lossy" or "lossless", depending on 
how much data is discarded during compression. However, too many levels of decomposition might lead 
to the loss of essential information, causing the quality of the reconstructed data to decrease after 
decompression. Overly high levels of decomposition can also introduce artifacts or distortions into the 
compressed data. This is because the decomposition process itself is not entirely free from introducing 
errors into the data, and these errors can accumulate as the level of decomposition increases. 

Choosing the appropriate level of decomposition is a balancing act that depends on the specific 
requirements of the compression task, including the complexity of the data, the acceptable loss of 
information, and the computational resources available. 

References: 

MATLAB documentation on wavelet transforms describes a variety of wavelets: 
https://www.mathworks.com/help/wavelet/  

Change Bands 

Features: 

• Changes set of bands to another set of bands. The new bands has to be set either in the excel or text 
file as a column. The dimension of the new set of bands (1 × n) must be equivalent of the current 
dimension. 

 

For changing the bands, click Edit – Change Bands and select the file  

https://www.mathworks.com/help/wavelet/
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After completion, the changes will be confirmed by a message box. 

 

Confirm the changes by looking at the spectra. 

Remove Bands   
NOTE: PAVIA dataset is used as an example.  

Features: 

• Enables removing specific bands or groups of bands from the dataset. 

• IDCube uses the following notation: bands are assigned the order number (1, 2, 3, etc.), while the 
channels have units (i.e., wavelengths, 430, 434, 438, etc.). Removal of any band/channel will 
reassign the band numbers, but not the channels.  

Steps: 

1. Open a hyperspectral imaging file through the Main interface: File → Open dataset in IDCube 
format. 

2. Click Edit → Remove bands/channels to see the following options: 

a. Individual bands/channels removal (Table) 

b. Range of bands removal 

c. Range of channels removal 

3. To delete individual bands or channels select Individual bands/channels removal (Table) and 
click on the appropriate one or many checkboxes.  

4. Click Remove Band/Channel button. The bands/channels will be removed from further 
consideration. To cancel the deletion, click the blue Reset button on the Main Interface. 
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To delete the range of either bands or channels select Range of Bands Removal or Range of Channels 
Removal and add the bands/channels in the box using the specified format. 

 

 

Click Apply button. The bands/channels will be removed from further consideration.  

To cancel the deletion, click Reset on the Main Interface.  

Bad Pixel Removal 
NOTE: Plastic and Coin dataset is used as an example.  

Features: Enables rapid removing of spikes from the dataset 

Bad pixel removal is a common preprocessing step for hyperspectral datasets to remove pixels that are 
noisy or have other artifacts. One way to do this is to use a median filter to smooth the data and identify 
pixels that are more than a certain distance from the median.  

Steps: Select Edit → Bad Pixel Removal. 
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In the dialog box enter the Median average value n that will perform (n × n), the default value is 3. 

Enter Median absolute deviation (MAD) for each pixel using the median function. The algorithm identifies 
bad pixels as those that are more than m MADs from the median, the default value is 5. 

 
The completion of the algorithm will be notified with the message box 

 

 

The example below shows the effect of Bad Pixel Removal different values on the dataset 

Untreated data Median averaging =3,  
Median absolute deviation = 5 
 

Median averaging =3,  
Med absolute deviation = 3 
 

   
 

Click Reset to return to the original dataset 
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Additional Information:  

This algorithm first applies a median filter to each individual band of the dataset using function. The 
resulting filtered data is temporarily stored. The algorithm then calculates the Median and Median absolute 
deviation (MAD) for each pixel using the median function. The algorithm identifies bad pixels as those that 
are more than m MADs from the median, and replace them with the median value. Finally, the algorithm 
displays the corrected hyperspectral image. 

The median absolute deviation (MAD) is a robust measure of variability or dispersion of a dataset. It is 
defined as the median of the absolute deviations of the data points from the median of the dataset. In other 
words, it measures the average distance of each data point from the median. MAD is calculated using the 
following formula: 

MAD = median(|xi - median(X)|) 

where X is the dataset, xi is the i-th data point, and |.| denotes the absolute value. 

MAD is a useful measure of dispersion when the dataset contains outliers or is not normally distributed. It 
is less sensitive to extreme values than the standard deviation, which makes it a better choice for skewed or 
heavy-tailed distributions. MAD is often used in conjunction with the median to estimate the spread of a 
dataset. In hyperspectral data analysis, the median ± m × MAD is used to define the range of "normal" 
values, where m is a scaling factor chosen to reflect the variability of the dataset. 

Annotations    
NOTE: PAVIA dataset is used as an example.  

Features: Enables adding interactive textboxes and arrows into the image display. 

Steps: 

1. Open a hyperspectral imaging file through the Main interface: File → Open dataset in IDCube 
format. 

2. Click Edit → Annotations. Two options are available.  

a. Add Textbox 

b. Add Arrow. 

These objects have preset feature designs and are different from the general use annotations that are 
available from the Annotation Toolbar. 

3. Select an option and it will be placed on the Image Display. 

4. The user can type text, move, or resize the annotations. 

5. NOTE: this tool automatically activates the Edit Plot. To disconnect the Edit Plot, click the icon 

 or deactivate through Edit → Edit Plot or Ctrl+E. 

6. Annotations can be changed or deleted at any time by activating Edit Plot mode. 

7. When the Edit Plot is activated, use Ctrl+Z to cancel the changes. 
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Use the Strip Toolbar in the upper right-hand corner of the image display to copy the image with the 
annotations. 

Edit Plot Mode 
NOTE: PAVIA dataset is used as an example. 

Features: 

• Allows the user to activate the interactive mode and rearrange the home page for a more 
personalized visualization experience. 

• Allows the user to modify and delete annotations (see Toolbar → Edit Mode). 

Steps to modify the layout: 

1. Open a hyperspectral imaging file through the main interface File → Open dataset in IDCube format. 

2. Click on Edit → Edit Plot or select the icon  or press Ctrl+E  

3. Click on any of the static frames to visualize the boundaries of the frame and move, expand or delete. 
You can cancel the change by pressing Ctrl+Z.  

NOTE: some of the panels are fixed. That includes the HISTOGRAM panel, DATACUBE 
MATHEMATICS panel, and DATA REDUCTION panel. Buttons can be moved within the parent frame.   

Click on the Edit Plot icon to return to the functional view. 
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The changes in the layout cannot be returned back by the Reset button. Instead, you can go all the way back 
to the original layout by activating the Edit Plot again and repositioning the frames, or by pressing Ctrl+Z 
several times until you get to the original layout. In the screenshot below, the SPECTRAL ANALYSIS 
panel went to the left, and the IMAGE DISPLAY panel was increased. 
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7.5. Plots Tab 
NOTE: Plastic and Coin dataset (cropped) is used as an example. 

Features: 

Enables the user to visualize the current image in a variety of 2D and 3D ways.  The visualization is 
temporary and will return to the default view with further data manipulation.  

Steps: 

1. Load the image file and select File → Plots and choose a type of plot.  Available options are given 
in the table below. 

 

 
 

Tabs Function Additional info 

Plots Tab Contour 2D plot  

 Contour-filled 2D plot  

 Mesh 3D plot Activates Camera Toolbar. 
 Surface 3D plot Activates Camera Toolbar. 
 Contour 3D plot Activates Camera Toolbar. 
 Remove All Plots Returns to the default single channel image. 
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Selection of 3D plots automatically adds a Rotate 3D button to the Strip Toolbar menu located in the right 
corner of the image. You can click it to rotate. 

 

 
The selection of 3D plots also automatically activates a Camera Toolbar that enables a large variety of 
manipulations of three-dimensional objects.  

 

 
 

Tip: You can use different color LUTs from the toolbar or Interactive colorbar functions (via the Right 
click on the colorbar) to fine-tune the colors of the plots. 

To return to the default plots, click   or move any band/channel functions. Examples 
of the plots are shown below  
  

Type of plot Graphical Description Description 

Contour 2D  

 

Creates a contour plot containing the isolines of matrix Z, where Z contains 
intensity values on the x-y plane as height.  IDCube automatically selects the 
contour lines to display. 

Contour filled 2D  

 

Creates a filled contour plot containing the isolines of matrix Z, 
where Z contains height values on the x-y plane. IDCube automatically selects 
the contour lines to display. 

Mesh 3D  

 

Creates a 3D mesh plot that has solid edge colors and no face colors. The 
function plots the intensity values Z as heights above a grid in the x-y plane 
defined by X and Y. The edge colors vary according to the heights specified by Z. 

Surface 3D 

 

Creates a 3D surface plot that has solid edge colors and solid face colors.  The 
function plots the intensity values Z as heights above a grid in the x-y plane 
defined by X and Y. The edge colors vary according to the heights specified by Z. 

Contour 3D 

 

Creates a 3D contour plot containing the isolines of matrix Z, where Z presents 
intensity values on the x-y plane as height. IDCube automatically selects the 
contour lines to display. 

Hybrid 3D 

 

Creates a 3D surface plot with a contour 2D plot underneath.  A combination of 
a Surface 3D and Contour 2D. 
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Contour 2D plot 

 

Contour-filled 2D plot 

 
Mesh 3D plot 

 

Surface 3D plot 

 
Contour 3D plot 

 

Hybrid 3D plot 
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7.6. Image Statistics Tab 

Image Quality Plot (BRISQUE, NIQE and PIQE algorithms) 

NOTE: PAVIA dataset is used as an example. 

Features: 

• Image Quality calculates the no-reference image quality score for the image using several 
methods. The range of the Quality Score is from 0 to 100. A smaller score indicates better 
perceptual quality.  

• Calculates the quality of the images as the function of the wavelength. 

Steps (could be used in random order) 

1. Load the data using File → Open… The Quality score of the image is located in the text box 
under the image as shown below. This value is calculated using BRISQUE algorithm. 

 
2. Go to the Filtering and Enhancement → Image Quality and select Image Quality Plot to 

visualize the image quality as the function across the entire z-axis (band/channel/wavelength). The 
available algorithms are:  

a. BRISQUE  

b. NIQE 

c. PIQE 

   

Tabs Function Additional info 

Filtering and Enhancement Tab Image Quality Plot  Additional menu 
 Anomaly Pixels Pop-up window 
 Texture features Pop-up table 
 Haussdorff Fractal Dimension Pop-up value 
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The plots below indicate relatively poor-quality images at wavelengths <450 nm corresponding to large 
values of indices. 

 

Tip: You can save Quality plots spectra in Excel format using a Brush button from a Strip Toolbar. Hover 
over the spectral window to activate a Strip Toolbar and click the Brush icon. When clicked, the Brush 
icon will turn blue. Brush the entire or part of the plotted spectrum and right-click. Select Copy Data to 
Clipboard. Paste the copied data into Excel or a text file. 

   

Additional Information: 

The algorithm predicts the BRISQUE score by using a Support Vector Regression (SVR) model trained on 
an image database with the corresponding differential mean opinion score (DMOS) values. The database 
used for this algorithm contains images with known distortion such as compression artifacts, blurring, and 
noise, and it contains pristine versions of the distorted images. The image to be scored must have at least 
one of the distortions for which the model was trained. 
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PIQE (Perception-based Image Quality Evaluator) scores the image distorted due to blocking artifacts and 
Gaussian noise. The algorithm generates spatial quality masks that indicate the high spatially active blocks, 
noticeable artifacts blocks, and noise blocks in the image. 

NIQE (Naturalness Image Quality Evaluator) measures the distance between the natural scene statistics 
(NSS) based features calculated from the image to the features obtained from an image database used to 
train the model. The features are modeled as multidimensional Gaussian distributions. 

References: 

BRISQUE:  

Mittal, A., A. K. Moorthy, and A. C. Bovik. "No-Reference Image Quality Assessment in the Spatial 
Domain." IEEE Transactions on Image Processing. Vol. 21, Number 12, 2012, pp. 4695–4708. 

Mittal, A., A. K. Moorthy, and A. C. Bovik. "Referenceless Image Spatial Quality Evaluation Engine." 
Presentation at the 45th Asilomar Conference on Signals, Systems, and Computers, Pacific Grove, CA, 
2011. 

PIQE:  

Venkatanath, N., D. Praneeth, Bh. M. Chandrasekhar, S. S. Channappayya, and S. S. Medasani. "Blind 
Image Quality Evaluation Using Perception Based Features", In Proceedings of the 21st National Conference 
on Communications (NCC). Piscataway, NJ: IEEE, 2015. 

Sheikh, H. R., Z. Wang, L. Cormack, and A.C. Bovik, "LIVE Image Quality Assessment Database Release 
2 ", https://live.ece.utexas.edu/research/quality/ . 

NIQE:  

Mittal, A., R. Soundararajan, and A. C. Bovik. "Making a Completely Blind Image Quality Analyzer." IEEE 
Signal Processing Letters. Vol. 22, Number 3, 2013, pp. 209–212. 

Anomalous Pixels 

NOTE: Plastic and Coin dataset is used as an example dataset.  

Features: Identifies anomalous pixels in the 3D datasets using Reed-Xialoi (RX) detection algorithm. 

Steps: 

1. Select Filtering and Enhancement → Anomalous pixels 

 

2. Enter the Confidence coefficient to set a threshold at which any pixels with a higher confidence 
coefficient will be considered anomalous. The default level is 0.99. This threshold represents the 
RX score above which a pixel is an anomaly with 99.0 % confidence. 

https://live.ece.utexas.edu/research/quality/
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3. As the first step, we suggest using the default value and pressing Apply. You can identify a more 
suitable Confidence coefficient value by analyzing the Plot of the cumulative probability 
distribution of RX score values (see below). 

 

IDCubePro® will compute the plot of the Cumulative probability distribution of RX score values (scale 
from 0 to 1). Pixels with a high RX score are likely anomalous pixels. IDCubePro® also displays the RX 
score map where each pixel in the dataset is assigned the raw RX score. Both graphs appear in a pop-up 
panel Reed-Xialoi (RX) Scores side-by-side as shown below:  

 

Tip 1: Use the Strip Toolbar from the right upper corner of the graph (to see this toolbar, hover over the 
right upper corner of the graph) to identify the threshold (shown 0.988). Enter this new threshold value into 
the Confidence coefficient field to tune the anomalous pixel detection.  

 
Tip 2: Right-click on the Colorbar to change the colorscheme or adjust the colors using an interactive 
colorbar shift.  

IDCubePro® automatically applies a threshold criterion to detect anomalous pixels with an RX score 
greater than the computed threshold. The result is a binary image in which the anomalous pixels are assigned 
the intensity value 1 and other pixels are assigned 0. This binary image is generated in a second pop-up 
panel named Detected Anomalous Pixels (binary). The detected anomalous pixels are overlaid with the 
automatically generated pseudo-RGB image shown in Overlaid Image panel.  

NOTE: many anomalous pixels found in the coin. These anomalous pixels correspond to highly reflective 
areas of the coin’s surface. 
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Additional Information:   

The method detects anomalous pixels in the hyperspectral data using the Reed-Xialoi (RX) detector. The 
RX detector calculates a score for each pixel as the Mahalanobis distance between the pixel and the 
background. The background is characterized by the spectral mean and covariance of the datacube. 

The RX score for each pixel is computed according to the following equation.  

 
Where r is the pixel under test and μC and ΣC are the spectral mean and covariance respectively. Anomalous 
pixels typically have high RX scores. 

References: 

[1] Reed, I.S., and X. Yu. “Adaptive Multiple-Band CFAR Detection of an Optical Pattern with Unknown 
Spectral Distribution.” IEEE Transactions on Acoustics, Speech, and Signal Processing 38, no. 10 (October 
1990): 1760–70. https://doi.org/10.1109/29.60107. 

[2] Chein-I Chang and Shao-Shan Chiang. “Anomaly Detection and Classification for Hyperspectral 
Imagery.” IEEE Transactions on Geoscience and Remote Sensing 40, no. 6 (June 2002): 1314–25. 
https://doi.org/10.1109/TGRS.2002.800280. 

Texture Features 

NOTE: Only works for monochromatic images. Some features result in NaN or equal to 0 (zero) need to 
be ignored.  Does not produce meaningful results on RGB type images. 

Features: The function calculates 14 image parameters known as Haralick Features.  

To compute the Haralick features select Image Statistics and select Texture Features. 

https://doi.org/10.1109/TGRS.2002.800280
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A table of Haralick texture features will pop-up. 
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Additional Information:   

Haralick texture features are common texture descriptors in image analysis. They are statistical features that 
describe the texture of an image. They are based on the co-occurrence matrix, which is a matrix that 
describes the frequency of occurrence of pairs of pixels with certain values in an image. The traditional 
histogram based methods (first order statistics) show only the distribution of grey-levels in individual pixels 
ignoring the spatial distribution of grey values. The texture analysis method uses higher-order statistics, 
and consider the relation between two or more pixels at a time. One advantage of Haralick features is that 
they are robust and can capture different types of texture information such as smoothness, coarseness, and 
regularity, making them suitable for a wide range of applications such as medical image analysis, remote 
sensing, and computer vision. Another advantage of Haralick features is their computational efficiency. 
They can be computed quickly and easily, even for large images, using algorithms such as the Gray-Level 
Co-occurrence Matrix (GLCM).  

References: 

Haralick, Robert M., Karthikeyan Shanmugam, and Its'hak Dinstein. "Textural features for image 
classification." IEEE Transactions on systems, man, and cybernetics 6 (1973): 610-621. 

Kumar, Rekhil M., and K. Sreekumar. "A survey on image feature descriptors." Int J Comput Sci Inf 
Technol 5 (2014): 7668-7673. 

  

Texture Meaning and range 

Angular Second Moment (Energy)  Angular Second Moment measures the image homogeneity. Is high when 
image has very good homogeneity or when pixels are very similar. 

Contrast Equal to 0 for a constant image and become larger as the pixel intensities 
in a local neighborhood become more disparate. 

Correlation Measures the linear dependency of grey levels of neighboring pixels -1 
to 1. 

Variance  Increasing weight given to greater gray value differences. 

Inverse Difference Moment 
(Homogeneity) 

It is high when local gray level is uniform is close to 1 when only a few 
dominant gray-tones are present. 

Sum Average Average sum of gray levels. 

Sum Variance Variance of sum of gray levels. 

Sum Entropy Uniform (flat) distribution of sum of gray levels has maximum entropy. 

Entropy  Reflects the amount of randomness in intensity of an image and 
increases with the images local complexity.  

Difference Variance Variance of difference of gray levels 

Difference Entropy Uniform (flat) distribution of difference of gray levels has maximum 
entropy 

Information Measure of Correlation I Normalized mutual information. 

Information Measure of Correlation II Difference between joint entropy and joint entropy assuming 
independence. 

Maximal Correlation Coefficient Relates to how fast the Markov chain converges. Calculates how 
transition matrix for a Markov chain of neighboring pixel gray levels. 
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Acknowledgment:  
In part based on Rune Monzel (2023). haralickTextureFeatures, MATLAB Central File Exchange. 
Retrieved March 4, 2023, (https://www.mathworks.com/matlabcentral/fileexchange/58769-
haralicktexturefeatures ) 

Haussdorff fractal dimension 

NOTE: Only works for monochromatic images. Does not work on RGB type images (produces NaN value). 

Features: The function calculates Haussdorff fractal dimension of the presented image.  

To compute the Haussdorff fractal dimension, select Image Statistics and select Haussdorff Fractal 
Dimension. 

 

A value corresponding to the Haussdorff fractal dimension will pop-up. 

 
 

Additional Information:   

Haussdorff fractal dimension measurement is a mathematical method used to quantify the complexity or 
irregularity of an object or pattern. In imaging, this method can be used to measure the complexity of an 
image, such as the branching patterns of blood vessels or the surface texture of an object. 

The Haussdorff fractal dimension measurement provides a way to describe the level of complexity in an 
image by measuring how much the pattern repeats itself at different scales. The measurement is based on 
the idea that fractals exhibit self-similarity, meaning that they have the same structure at different levels of 
magnification. The Haussdorff fractal dimension measurement calculates the degree of self-similarity by 
measuring the amount of space that is filled by the fractal pattern at different scales. 

Applications of Haussdorf fractal dimension measurement in imaging include the analysis of medical 
images, such as identifying the level of complexity of tumors or analyzing the branching patterns of blood 
vessels. It can also be used in remote sensing, where it can help identify and quantify landscape features 
such as rivers, forests, and mountains. Additionally, it has applications in computer vision, where it can 
help identify and classify complex images, such as recognizing handwritten characters or classifying 
different types of textures.  

References:  

https://www.mathworks.com/matlabcentral/fileexchange/58769-haralicktexturefeatures
https://www.mathworks.com/matlabcentral/fileexchange/58769-haralicktexturefeatures
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Bruno, Odemir Martinez, et al. "Fractal dimension applied to plant identification." Information 
Sciences 178.12 (2008): 2722-2733. 

Ghosh, Jayanta Kumar, Ankur Somvanshi, and R. C. Mittal. "Fractal feature for classification of 
hyperspectral images of Moffit Field, USA." Current Science (2008): 356-358. 

Acknowledgment:  
Based on Alceu Costa (2023). Hausdorff (Box-Counting) Fractal Dimension, 
(https://www.mathworks.com/matlabcentral/fileexchange/30329-hausdorff-box-counting-fractal-
dimension), MATLAB Central File Exchange. Retrieved March 5, 2023. 

7.7. Filtering and Enhancement Tab 
Functions implemented in the Filtering and Enhancement Tab allow you to modify your dataset by 
removing noise as well as other modifications outlined in the table below. Additional functions allow for 
evaluating the quality of the data and the results of filtering. All changes to the dataset are global, which 
means the changes are saved internally and replace the original dataset during the computation session. 
However, no changes are applied to the original data stored in your folder. Your original data are will not 
be affected.  

 

 

Mean Spatial Filter 
NOTE: PAVIA dataset is used as an example.  

Features: Removes spatial noise in the entire datacube by averaging nearby pixels. This filtering is global 
and will be retained for all other functions and treatments. 

Steps: 

Tabs Function Additional info 

Filtering and Enhancement Tab Mean Spatial Filter Dialogue window 
 Mean Spectral Filter Applied to the Image 
 Gaussian Filter Applied to the Image 
 NGmeet Filter Applied to the Image 
 Spatio-Spectral Total Variation (SSTV) Filter Dialogue window 
 FFT Filters (low and high pass) Dialogue window 
 Savitzky-Golay Filter Dialogue window 
 Asymmetric Least Square Smoothing Dialogue window 
 Standard Deviation  Applied to the Image 
 Decorrelation Stretch Applied to the Image 
 Color Inversion Applied to the Image 
 Normalization Additional menu 
 Contrast Enhancement Additional menu 
 Structure Similarity Index  Generates a value 

https://www.mathworks.com/matlabcentral/fileexchange/30329-hausdorff-box-counting-fractal-dimension
https://www.mathworks.com/matlabcentral/fileexchange/30329-hausdorff-box-counting-fractal-dimension
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1. Select Filtering and Enhancement → Mean Spatial Filter.   

 
2. Select the filter cutoff (N) as an odd number from the pop-up dialogue window. The default value 

is N=3. The filter applies an N-by-N median spatial filter in two spatial dimensions. Each output 
pixel in the output image contains the median value in the N-by-N neighborhood around the 
corresponding pixel in the original dataset. The original image is padded by mirroring border 
elements. Press Apply. 

 
3. After completion click Apply and visualize the filtered image.  

 
The filtered image can be returned to the original by using Filtering and Enhancement → Remove all 
Filters and Enhancements or Reset button.   
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Mean Spectral Filter  
NOTE: PAVIA dataset is used as an example.  

Features: Removes spectral noise in the entire datacube by averaging nearby bands/channels. This filtering 
is global and will be retained for all other functions and treatments. 

Steps: 

1. Select Filtering and Enhancement →   Mean Spectral Filter.   

 

2. Select the filter parameters. The entered value indicates how many N bands will be averaged. If 
N=3, three signals will be averaged over three bands.  

 
a. After completion, click OK and visualize the filtered image.  

 



v. 2.78   

234 
 

b. The filtered image can be returned to the original by using Filtering and Enhancement 
→ Remove all Filters and Enhancements or Reset button. 

NOTE: The Reset button is global and will revert all changes. 

Additional Information: 

The filter applies an N-median spectral filter along the spectral dimensions. Each band/channel in the output 
dataset contains the median value in the N neighborhood bands/channels around the corresponding band in 
the original dataset. The original spectral dimension is padded by mirroring border elements.  

Gaussian Filter 
NOTE: PAVIA dataset is used as an example.  

Features: Removes spatial and spectral noise in the entire datacube by applying a Gaussian Filter. This 
filter is global and will be retained for all other functions and treatments. 

 Steps: 

1. Select Filtering and Enhancement → 3D Gaussian Filter.   

 

2. A dialogue window will popup: 

 

Sigma: The Sigma is a smoothing parameter and represents the standard deviation of a three-dimensional 
Gaussian smoothing kernel. This value can either be a scalar (single value) or a vector comprising three 
positive elements. When Sigma is specified as a scalar, a cubic Gaussian kernel is applied, where the same 
standard deviation is used in all three dimensions. The default value is 0.5 
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Filter Size: This is a parameter which can be either a scalar or a three-element vector, consisting of positive, 
odd integers that determine the dimensions of the Gaussian filter. If a single number Q is provided, the 
Gaussian filter becomes a cubic filter with dimensions [Q Q Q]. By default, the filter size is calculated as 
2ceil(2Sigma)+1 (where ceil(x) rounds the elements of x to the nearest integers  towards infinity) which 
ensures the filter is large enough to cover about two standard deviations on each side of the mean in a 
Gaussian distribution. 

3. After completion, click OK and visualize the filtered image.  

 
4. The filtered image can be returned to the original by using Filtering and Enhancement → 

Remove all Filters and Enhancements or Reset button. 

Additional Information: 

The algorithm filters the datacube with a 3D Gaussian smoothing kernel with a standard deviation of 0.5 
and returns the filtered image. All voxels in the image must have values.  

NGMeet filter 
NOTE: PAVIA dataset is used as an example.  

Features: You can use the NGMeet function to remove noise from hyperspectral data by using the non-
local meets global approach. 

 Steps: 

1. Select Filtering and Enhancement → NGmeet Filter.   

 

2. A dialogue window will popup: 
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Sigma (level of smoothing): A positive scalar value that controls the level of smoothing. Increasing this 
value results in more smoothing of input datacube. The default value is 0.1 times of estimated noise 
variance. 

Spectral Subspace: A positive scalar integer value which specifies the number of channels in the reduced 
datacube on which the denoising process can be applied which improves the algorithm performance and 
reduces computational complexity. The value of Spectral Subspace must be greater than 0 and less                        
than or equal to number of channels present in CUBE. The default value is 6. 

Number of Iterations: A positive scalar integer value which specifies the number of iterations used for 
denoising process. Increasing this value improves the denoising performance. The default value is 2. 

 

Notes: 

1. Increasing Number of Iterations increases the accuracy and execution time. A non-default, 
smaller Number of Iterations can be specified to trade-off accuracy for execution time.  

2. To estimate the value for Spectral Subspace, count Endmembers from running the Endmembers 
Toolbox. 

3. The default value of Sigma is 0.1 times of estimated noise variance. Used standard deviation of 
a middle channel of the CUBE for estimation of noise.     

3. After completion, click OK and visualize the filtered image.  

 
4. The filtered image can be returned to the original by using Filtering and Enhancement → 

Remove all Filters and Enhancements or Reset button. 

Additional Information: 

The NGMeet method estimates the denoised datacube by using these steps. For each iteration, i 

1. Compute spectral low-rank approximation of the noisy input data (Yi) by using singular value 
decomposition. The approximation results in a reduced datacube (Mi) and the related orthogonal 
basis Ai. 
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2. Perform spatial de-noising of the reduced datacube Mi by using non-local similarity filtering. You can 
control the degree of smoothing by specifying the smoothing parameter 'Sigma'. 

3. Perform inverse projection. Map the denoised reduced datacube Mi to the original space by using the 
orthogonal basis Ai. The result is the denoised output (Xi) obtained at iteration i. 

4. Perform iterative regularization. Update the noisy input data, Yi+1 = λXi + (1-λ)Yi. 

5. Repeat steps 1 to 4, for the specified number of iterations. The final value Xi is the denoised 
hyperspectral data. 

References: 

He, Wei, Quanming Yao, Chao Li, Naoto Yokoya, and Qibin Zhao. “Non-Local Meets Global: An 
Integrated Paradigm for Hyperspectral Denoising.” In 2019 IEEE/CVF Conference on Computer Vision and 
Pattern Recognition (CVPR), 6861–70. Long Beach, CA, USA: IEEE, 2019. 
https://doi.org/10.1109/CVPR.2019.00703. 

Spatio-Spectral Total Variation (SSTV) Filter 

Notes: Plastic and Coin dataset is used as an example.  

Features: Removes Gaussian and sparse mixed noise. 

Steps: 

1. Open a file and select Filtering and Enhancement → Spatio-Spectral Total Variation (SSTV) 
Filter. 

 
2. Select SSTV filter parameters from the pop-up dialogue window.  

 
a. The value of parameter λ adjusts the de-noising strength corresponding to sparse noise, 

whereas parameters μ and ν provide the tradeoff between retaining the original image and 
smoothness by total-variation regularization, respectively.  

https://doi.org/10.1109/CVPR.2019.00703
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b. The default parameter values λ = 0.1, μ = 0.2, and ν = 0.2 have been found empirically (see 
the ref. below). These parameters can be adjusted to get the desired denoising strength.  

c. The algorithm seems to be weakly sensitive to the specific values of these parameters and 
allows a broad range of values. The number of iterations = 40 seems to be optimal to 
achieve convergence (see the graph below).   

3. After completion, click OK and visualize the filtered image.  

 
4. Visualize the results. You can also run Filtering and Enhancement → Image Quality → Image 

Quality (BRISQUE). The improvement of the image quality is shown in the chart below. A lower 
level of BRISQUE score indicates a higher quality of the image. 

 

Notes: The algorithm is computationally demanding. Decreasing the number of iterations might 
significantly decrease the computation time.  

Tip: Optimize the filter’s parameters on a smaller size by first cropping the image. 

Additional Information: 

Gaussian noise is a kind of signal noise that has a probability density function (pdf) equal to that of the 
normal or Gaussian distribution. Major sources of Gaussian noise in digital images arise during acquisition 
e.g., sensor noise caused by poor illumination and/or high temperature, electronic circuit noise, and others. 
The sparse noise includes random valued impulse noise, salt-and-pepper noise, and horizontal and vertical 
deadlines.  

References: 

H. K. Aggarwal and A. Majumdar, "Hyperspectral Image Denoising Using Spatio-Spectral Total 
Variation," in IEEE Geoscience and Remote Sensing Letters, vol. 13, no. 3, pp. 442-446, March 2016, doi: 
10.1109/LGRS.2016.2518218. 
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FFT Filters 

Low Pass Frequency Domain Spectral Filtering    
NOTE: PAVIA dataset is used as an example. Can be used in conjunction with the Low Pass FFT function 
from the SPECTRA MATHEMATICS panel.  

Features: 

• Use this filter to remove high-frequency components from the spectral coordinate in the entire 
dataset. No filtering is applied to the spatial coordinates. 

• The Fast Fourier Transform (FFT) is used to transform the input spectra. To perform the FFT filters 
efficiently, IDCube enables users to first optimize and visualize the performance of these filters on 
a spectrum from the selected regions of interest (available from the SPECTRAL ANALYSIS 
panel). 

• The FFT filtering of the image is performed in three steps automatically. First, the filter executes a 
pixel-by-pixel Fourier transform of the spectrum, converting the original spectra into their 
corresponding frequency domain spectra. In the second step, a low-pass filter with a specified cut-
off frequency is applied. In the third step, the inverted Fourier transform algorithm is applied to 
generate a new dataset where only low frequencies are kept. 

Steps: 

1. Load the file. 

2. Select Spectra Mathematics Select → FFT Low Pass Filter. 

 
A pop-up dialog will ask you to enter a Low-Frequency cutoff value. A higher value indicates that high 
frequencies will be removed before the reconstruction resulting in the low-frequency image where 50% of 
the high frequencies are cut. NOTE: that the scale is between 0 and 1. 

(To Visualize Spectra after FFT analysis, go to the Spectral Analysis chapter of this manual). 

 



v. 2.78   

240 
 

The resulting image with 50% cutoff high frequencies will be shown in the IMAGE DISPLAY panel. 

 
 

Similar to other filters, the processed dataset is temporarily stored and available for other processing 
algorithms. 

References: 

The algorithm is built using part of the fftl library developed by Shmuel Ben-Ezra in 2009:  

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-
results?s_tid=srchtitle  

High Pass Frequency Domain Spectral Filtering  
NOTE: PAVIA dataset is used as an example. Can be used in conjunction with the High Pass FFT function 
from the SPECTRA MATHEMATICS panel.  

Features: 

• Use this filter to remove low-frequency components from the spectral coordinate in the entire 
dataset. No filtering is applied to the spatial coordinates. 

• The Fast Fourier Transform (FFT) is used to transform the input spectra. To perform the FFT filters 
efficiently, IDCube enables users to first optimize and visualize the performance of these filters on 
a spectrum from the selected regions of interest. 

• The FFT filtering of the image is performed in three steps automatically. First, the filter executes a 
pixel-by-pixel Fourier transform of the spectrum, converting the original spectra into their 
corresponding frequency domain spectra. In the second step, a high pass filter with a specified cut-
off frequency is applied. In the third step, the inverted Fourier transform algorithm is applied to 
generate a new dataset where only high frequencies are kept. 

Steps: 

1. Load the file. 

2. Select Spectra Mathematics Select → FFT High Pass Filter. 

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-results?s_tid=srchtitle
https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-results?s_tid=srchtitle
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3. Press Generate and put a Cutoff value number in the pop-up dialog. The number reflects the % 

of Nyquist frequency in the range between 0 and 1. A higher value indicates that more low 
frequencies will be removed before the reconstruction. The value of 0.5 means that 50% of the 
low frequencies are cut.  

 
(To Visualize Spectra after FFT analysis, go to the Spectral Analysis chapter of this manual). 
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Like most other filters, the filtered dataset is temporarily stored and available for other processing 
algorithms. 

References: 

The algorithm is built using part of the fftl library developed by Shmuel Ben-Ezra in 2009:  

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-
results?s_tid=srchtitle 

 

Savitzky-Golay Filter  
NOTE: Plastic dataset is used as an example. Can be used in conjunction with the Savitzky-Golay 
smoothing from the SPECTRA MATHEMATICS panel.  

Features: The filter smooths raw noisy signal data from the spectral coordinate using a least-squares digital 
polynomial filter. 

 Steps:  

1. Select Filtering and Enhancement → Savitzky-Golay. 

 

2. The pop-up dialogue window will ask for additional parameters Polynomial Order and Frame 
size.  

Polynomial Order corresponds to the degree of the polynomial fitted to the points in the moving frame. 
The default value is 2. Polynomial Order value must be smaller than Frame Size if the frame size is a 
positive integer. The default value is 10. 

Frame Size modifies the frame size for the smoothing function. If the Frame Size value is greater than 1, 
the rolling window is the size of the input number (i.e., 10) and independent of the number of 
bands/channels. Higher values smooth the signal more with an increase in computation time. If the Frame 
Size is less than 1, the window size is a fraction of the number of points in the total number of channels. 
For example, if the Frame Size value is 0.05, the window size is equal to 5% of the number of points in 
the total number of channels. 

https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-results?s_tid=srchtitle
https://www.mathworks.com/matlabcentral/fileexchange/25017-fft-filter-clean-your-signals-and-display-results?s_tid=srchtitle
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The smoothing of the spectra occurs in a pixel-by-pixel manner. When the process is complete, the new 
image will replace the original image. A pop-up message box will inform that the process is complete. Click 
OK to remove the message box. 

 

(Optional) You can estimate the effect of the filter on the resulting image by running the Structure 
Similarity Index. For that, select Filtering and Enhancement → Structure Similarity Index from the 
menu bar. This index calculates the structural similarity (SSIM) index comparing the original dataset with 
the filtered one. A value closer to 1 indicates higher similarity and a value closer to 0 indicates low 
similarity. 

  

(Optional) You can also estimate the result of filtering the images using image quality measurements. For 
that select Filtering and Enhancement → Image Quality → Image Quality (BRISQUE). A new window 
with the image quality index for every channel will be calculated. Lower values correspond to better quality. 
In this example, Savitzky-Golay smoothing with the default values significantly increases the quality of the 
images between 1100 nm and 1550 nm.  
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Additional Information: 

IDCubePro® uses a modified version of the Savitzky-Golay algorithm. The original algorithm developed 
by Savitzky and Golay assumes the input vector corresponding to the band/channel dimension has 
uniformly spaced separation units, while the current algorithm also allows one that is not uniformly spaced.  

When the input bands/channels vector is evenly spaced, the least-squares fitting is performed once so that 
the signal is filtered with the same coefficients, and the speed of the algorithm increases considerably. 

The algorithm specifies the degree of the polynomial fitted to the points in the moving frame. The default 
order of the polynomial fitted to the points in the moving frame is equal to 2. The default frame size 
is 10 samples. Both parameters can be modified in the IDCubePro®.  

Asymmetric Least Square Smoothing 
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: The filter is based on asymmetric least squares smoothing for multiple spectra baseline 
correction. The algorithm also eliminates scatter effects on the spectra.   

For large images, Asymmetric Least Square Smoothing might be computationally expensive. The algorithm 
might take several minutes depending on the size of the image and the number of iterations. We recommend 
using Spectrum Background Removal implemented in the Feature Finder toolbox from the Toolbox 
menu to optimize parameters. 

Steps: 

1. Load a file and select Filtering and Enhancements → Asymmetric Least Square Smoothing. 
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2. Select the smoothing parameters from the pop-up dialog.  

 
Smoothness defines how smooth the baseline should be (default 100). 

Asymmetry defines how "low" the baseline should be. The range is from 0 to 1. Lower peaks require 
asymmetry approaching 0, while high peaks require asymmetry value approaching 1. 

Iterations define the number of iterations to reach the converge (default 20). The calculation time is 
proportional to the number of iterations.  

3. Press Apply and visualize the smoothed image after the computation is complete.  

 
4. (optional) Click Multi-Spectra Mode in the SPECTRAL ANALYSIS panel and draw a region of 

interest to visualize the spectrum before and after the smoothing procedure. The original spectrum 
(shown as mean +/- standard deviation) shows numerous sharp peaks related to noise. After 
filtering, the new spectrum shows no sharp peaks and a much smaller standard deviation. 
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We recommend using the Feature Finder toolbox to optimize filter parameters. Feature Finder toolbox 
has an option to generate three spectra: the original spectrum (green line), the baseline spectrum (red dotted 
line), and the corrected spectrum (blue solid line). Corrected spectrum = Original spectrum – Baseline 
Spectrum. An example of this optimization with the adjusted Asymmetry parameter is shown below.  

    
 Smoothness: 5000 

Asymmetry: 0.001 
Iterations: 10 

Smoothness: 5000 
Asymmetry: 0.01 

Iterations: 10 

Smoothness: 5000 
Asymmetry: 0.1 

Iterations: 10 

Reference: 

Eilers, P. H., & Boelens, H. F. (2005). Baseline correction with asymmetric least squares smoothing. Leiden 
University Medical Centre Report, 1(1), 5. 

Standard Deviation Filter 

NOTE: PAVIA dataset is used as an example.  

Features: Modifies the dataset with a Standard Deviation filter to visualize the edges of the objects. This 
filter is global and will be retained for all other functions and treatments.  

Steps: 

Select Filtering and Enhancement → Standard Deviation filter. After completion, click OK and 
visualize the filtered image. 

 
The filtered image can be returned to the original image by using Filtering and Enhancement → 
Remove all Filters and Enhancements or Reset button. 
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Additional Information: 

The algorithm performs standard deviation filtering of the dataset (spatial only) for each frame and returns 
the filtered image. The value of each output pixel is the standard deviation of the 3-by-3 neighborhood 
around the corresponding input pixel. For pixels on the borders, the algorithm uses symmetric padding 
where the values of padding pixels are a mirror reflection of the border pixels. 

Decorrelation Stretch 
NOTE: PAVIA dataset is used as an example.  

Features: 

• Applies a decorrelation stretch to the dataset. The primary purpose of decorrelation stretch is visual 
enhancement.  

• Decorrelation stretching is a way to enhance the color differences in an image.  

• This filter is global and will be retained for all other functions and treatments. 

Steps: 

1. Select Filtering and Enhancement → Decorrelation Stretch. Visualize the resulting image after 
the decorrelation stretch is completed.  

         

The image can be returned to the original by using the Filtering and Enhancement → Remove all Filters 
and Enhancements or Reset button. NOTE: Reset button is global and will revert the processed dataset 
back to the original dataset. 

Color Inversion 
NOTE: PAVIA dataset is used as an example.  

Features: The algorithm computes the complement of the image where black and white colors are reversed. 
In the output image, dark areas become lighter and light areas become darker. For color images, reds 
become cyan, greens become magenta, blues become yellow, and vice versa. 

This operation is global and will be retained for all other functions and treatments. 

Steps: 
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1. Select Filtering and Enhancement → Color Inversion. Visualize the complement (inverted) 
image.  

      

The Color Inversion algorithm can also be applied to the RGB presentation. Each color channel of the 
resulting image is the complement of the corresponding complementary color channel in the original image. 
Dark regions become light, red colors become cyan, green colors become magenta, blue becomes yellow, 
and vice versa. Below is an example of the original pseudo RGB image [w1=466 nm, w2=725 nm, w3=671 
nm] (Left) and its complement (Right). 

 

 

 

Original pseudo RGB image Complement pseudo RGB 
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This inverted image can be returned to the original by using the Filtering and Enhancement → Remove 
All Filters and Enhancements or Reset button. 

Additional Information: 

In the complement of a grayscale or color image, each pixel value is subtracted from the maximum pixel 
value. The difference is used as the pixel value in the output image. In the output image, dark areas become 
lighter and light areas become darker. For color images, reds become cyan, greens become magenta, blues 
become yellow, and vice versa. 

Normalization 

Normalization [0 1] 
NOTE: PAVIA dataset is used as an example.  

Features: 

• Applies a normalization algorithm to the spectral axis of the dataset having all intensity values in 
the range between 0 and 1.  

• This operation is global and will be retained for all other functions and treatments. 

Steps: 

Select Filtering and Enhancement → Normalization → Normalization [0 1]. Visualize the 
normalized image. The colorbar values are between 0 and 1. 
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This rescaled image can be returned to the original by using Filtering and Enhancement → Remove 
all Filters and Enhancements or Reset button.  

NOTE: PAVIA is used as an example.  

Features: 

Applies a normalization algorithm to the spectral axis of the dataset having all intensity values in the range 
of the Z-score. Z-score describes the deviation from the mean in a number of standard deviations. The Z-
score is positive when the sample is above the mean and negative when below. 

This operation is global and will be retained for all other functions and treatments. 

Steps: 

1. Select Filtering and Enhancement → Normalization → Z-score Normalization  

 

2. After completion, click OK and visualize the normalized image. The colorbar values are within 
the Z-score.  

 
3. This rescaled image can be returned to the original by using Filtering and Enhancement 

→  Remove all Filters and Enhancements or Reset button.  
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Tip: Use the histogram to visualize parts of the image with positive or negative Z score values. 

Additional Information: 

Z-Score calculation: 

z = (x-m)/𝜎𝜎  
where x is the sample value, m is the sample mean, and 𝜎𝜎 is the standard deviation of the distribution. z 
describes the deviation from the mean in a number of standard deviations and is positive, when the sample 
is above the mean, and negative when below.  

Contrast Enhancement  
NOTE: PAVIA dataset is used as an example.  

Features: Improves the visualization of the image through image-improving algorithms such as Image 
Adjustment, Histogram Equalization, and Contrast-Limited Adaptive Histogram Equalization (CLAHE). 
The algorithms convert the low-contrast image into a higher contrast. 

Image Adjustment increases the contrast of the image by mapping the values of the input intensity image 
to new values, by default, 10% of the data is saturated at low and high intensities of the input data.  

Histogram Equalization performs image histogram equalization. It enhances the contrast of images by 
transforming the values in an intensity image so that the histogram of the output image approximately 
matches a specified histogram (uniform distribution by default). 

Contrast-Limited Adaptive Histogram Equalization (CLAHE) performs contrast-limited adaptive 
histogram equalization. Unlike Histogram Equalization, it operates on small data regions (tiles, default 
8x8) rather than the entire image. Each tile's contrast is enhanced so that the histogram of each output region 
approximately matches the specified histogram (uniform distribution by default). The contrast enhancement 
can be limited to avoid amplifying the noise which might be present in the image.  

NOTE: to apply these algorithms, the image will be first converted into a pseudo-RGB mode with random 
channels.  

 

Steps:  

1. Select Filtering and Enhancement → Contrast enhancement → Image adjustment 
(Histogram Equalization, or CLAHE). 

 

2. After completion, click OK and visualize the image in the pseudo-RGB format. 
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Examples of different image adjustments.  

Original Image adjustment Histogram 
Equalization 

CLAHE 

    
 

3. This resulting image can be returned to the original by using Filtering and Enhancement → 
Remove all Filters and Enhancements or Reset button.  

Reference 

Zuiderveld, Karel. “Contrast Limited Adaptive Histogram Equalization.” Graphic Gems IV. San 
Diego: Academic Press Professional, 1994. 474–485. 

Structure Similarity Index (SSIM) 
NOTE: The structural similarity index (SSIM) is only possible between two datasets of the same 
dimensions. 

Features: Calculates the SSIM score for 3D datasets after datacube processing using the original datacube 
as the reference image. This metric quantifies image changes caused by processing such as data filtering. 
A value closer to 1 indicates a higher similarity to the original image. 
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Steps:  

1. Open a file and perform one of the image processing algorithms. For example, remove Gaussian 
noise by selecting Filtering and Enhancement → 3D Gaussian filtering.   

2. After the filter is applied and completed, select Filtering and Enhancement → Structure 
Similarity Index.  

 

A new pop-up window SSIM Score will produce the calculated structural similarity index. A value closer 
to 1 indicates higher similarity and a value closer to 0 indicates low similarity. 

   

References: 

Wang, Z., Simoncelli, E.P., Bovik, A.C. Multiscale Structural Similarity for Image Quality Assessment. 
In: The Thirty-Seventh Asilomar Conference on Signals, Systems & Computers, 2003, 1398–1402. Pacific 
Grove, CA, USA: IEEE, 2003.  https://doi.org/10.1109/ACSSC.2003.1292216  

Remove All Filters and Enhancements 
Feature: The function is equivalent to Reset. It removes all changes and return the dataset to the original 
one. 

https://doi.org/10.1109/ACSSC.2003.1292216
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After completion a window will pop-up 

 

 
7.8. Data Corrections Tab 

Functions under the Data Corrections tab apply corrections to hyperspectral data related to issues with data 
acquisition or object properties. The tab handles issues with uneven illumination, light scattering in thick 
materials, distortion of optics, and other common problems.  

 

Background Data Correction  
NOTE: PAVIA dataset is used as an example.  

Features: Performs background data correction of the entire dataset based on the selected area (background 
area). 

Steps:  

1. Open a file. 

Tabs Function Additional info 

Data Corrections Tab Background Data Correction Interactive menu 
 Continuum Hull Removal Method selection 
 Polynomial Baseline Removal Method selection 
 Flat Field Correction Interactive menu 
 Multiplicative Scatter Correction (MSC) Interactive menu 
 Standard Normal Variate (SNV) Interactive menu 
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2. Select Data Corrections → Background data correction.  

 
A pop-up message will ask to draw a region on the image that will be used as a background. 

 
3. Draw an area that can be used as a background. The spectrum of the background will appear in the 

SPECTRAL ANALYSIS panel.  The entire dataset will be corrected for the selected background 
within a few seconds.  

The effect of this procedure is illustrated in the following table.  

 

 

Spectrum of the bowl before 
background correction 

Spectrum of the background Spectrum of the bowl after 
background correction 

   

Continuum Hull Removal from the Image 
NOTE: Plastic and Coin dataset is used as an example. See also Continuum Hull Removal from the 
SPECTRAL MATHEMATICS panel. 

Features: Enables rapid removal of continuum hull from the spectra across the entire dataset. See also 
Continuum hull removal from spectrum section.  

Additional Information 
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Continuum hull removal is a pre-processing technique used in hyperspectral image analysis to remove the 
spectral continuum from the data. The spectral continuum refers to the background signal in the image that 
is not associated with any specific spectral features or information. This background signal can obscure or 
distort the spectral information of interest, making it more difficult to analyze and interpret the data. 

Step 1. Select Data Correction Tab and press Continuum Hull Removal. 

 

Step 2. Select a method from a popup dialogue and press Apply.  

  

Step 3. The completion of the algorithm will ne informed by a message box.  

 

The choice of the method is usually made by trial and error (use also Continuum Hull Removal from the 
SPECTRAL MATHEMATICS panel to visualize the removal on a specific region of interest. For example, 
after application of ‘makima’ the corrected spectrum will look like shown below: 
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Method Description Comments 

'makima' Modified Akima cubic Hermite interpolation. The data is modeled 
using a cubic polynomial that is based on a set of Hermite basis 
functions, which are used to interpolate the data. The Modified Akima 
method improves upon the Akima method by adding a smoothing 
factor that reduces the impact of any noisy or erratic data points on 
the interpolation results 

particularly useful in situations 
where the data is noisy or contains 
outliers, as it can provide a smooth 
interpolation. 

Memory requirements are like those 
of 'spline'. 

'linear' Linear interpolation. The interpolated value at a query point is based 
on linear interpolation of the values at neighboring grid points in each 
respective dimension. This is the most common interpolation method. 

Requires more memory and 
computation time than nearest 
neighbor. 

'nearest' Nearest neighbor interpolation. The interpolated value at a query 
point is the value at the nearest sample grid point. 

Modest memory requirements 

Fastest computation time 

'next' Next neighbor interpolation. The interpolated value at a query point 
is the value at the next sample grid point. 

Same memory requirements and 
computation time as 'nearest' 

'pchip' Shape-preserving piecewise cubic interpolation. The interpolated 
value at a query point is based on a shape-preserving piecewise cubic 
interpolation of the values at neighboring grid points. 

Requires more memory and 
computation time than 'linear'. 

'cubic' Cubic convolution used in MATLAB 5. Points must be uniformly spaced. 

This method falls back 
to 'spline' interpolation for 
irregularly spaced data. 

Similar memory requirements and 
computation time as 'pchip' 

'v5cubic' Same as 'cubic'. 

'spline' A spline is a piecewise polynomial function that is defined by a set of 
control points, which are the known data points in the case of spline 

Uses the cubic spline as it provides a 
good balance between smoothness 
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Method Description Comments 

interpolation. The spline curve is constructed by fitting a series of 
polynomial segments to the control points, with the requirement that 
the curve is smooth and continuous at each control point. 

and accuracy Requires more memory 
and computation time than 'pchip' 

The continuum hull removal technique involves estimating the continuum spectrum using a polynomial or 
other mathematical function and subtracting it from the original hyperspectral data. The goal is to remove 
the background signal while preserving the spectral information of interest. The specific method used for 
continuum hull removal may depend on the characteristics of the data and the analysis goals. After the 
continuum is estimated and subtracted, the resulting data is referred to as the "continuum-removed" 
spectrum. This spectrum represents the spectral features of the image without the background signal, 
making it easier to identify and analyze the specific spectral signatures associated with different materials 
or phenomena. 

Acknowledgement 

The code in part was developed by Marian-Daniel Iordache, Copyright (April 14, 2016):   

Polynomial Baseline Removal from the Image 
NOTE: Plastic and Coin dataset is used as an example. See also Polynomial Baseline Removal from the 
SPECTRAL MATHEMATICS panel. 

Features: Enables removing of the baseline from the spectra across the entire dataset. It can improve the 
accuracy of data analysis by removing unwanted noise and artifacts in the signal. 

Additional Information 

Polynomial baseline removal is a pre-processing technique used in hyperspectral image analysis to remove 
the baseline from the data. The idea behind Polynomial Baseline Removal is to fit a polynomial function to 
the baseline of the signal and then subtract it from the original signal to obtain the corrected signal. 

Here are the steps involved in performing Polynomial Baseline Removal. Go to Data Corrections tab and 
select Polynomial Baseline Removal.  

 
Select the degree of polynomial (from 1 to 9) and click Apply to perform fitting 
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After the conversion a pop-up message will appear: 

 
Additional Information 

The algorithm performed fours steps: 1. Fits a polynomial function to the baseline with the selected degree 
of the polynomial function depends on the complexity of the baseline simple linear function (degree=1) or 
a higher-degree polynomial function (degree > 1). 2. Subtracts the polynomial function from the original 
signal. 3. Shifts the spectrum to have minimum values at zerois. 4. Moves to another pixel and perform the 
procedures 1-3. 

The choice of the degree of the polynomial function is usually made by trial and error (use Polynomial 
Baseline Removal from the SPECTRAL MATHEMATICS panel to visualize the removal on a specific 
region of interest. For example, after application of the 2 degree polynomial the corrected spectrum will 
look like shown below. 

 
The polynomial function fits to the spectrum using a least-squares regression algorithm. The polynomial 
order is typically chosen based on the noise level and complexity of the data, with higher-order polynomials 
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providing more accurate fits but also increasing the risk of overfitting. After the baseline is estimated and 
subtracted, the resulting spectrum data are shifted to have minimum value at zerois. The final spectrum is 
referred to as the "baseline-removed" spectrum. The entire algorithm is performed over all pixels in the 
image. This spectrum represents the spectral features of the image without the background signal, making 
it easier to identify and analyze the specific spectral signatures associated with different materials or 
phenomena. 

Flatfield Correction 
NOTE: PAVIA dataset is used as an example. 

Features: Performs flat field correction on the entire dataset. This post-imaging procedure cancels the 
effects of image artifacts caused by variations in the detector or the light sources resulting in a more uniform 
(flatfield) output with more uniform color and brightness across the frame. 

Steps:  

1. Open a file. 

2. Select Data Corrections → Flatfield correction. A pop-up dialogue window will ask to identify 
a reference spectrum.  

 

 

4. Click OK and draw an area that needs to be corrected. A valid ROI has these characteristics: 

a. Topographically flat 

b. Spectrally flat (uniform spectral response) 

c. Shows a strong signal source to reduce the impact of random noise 

Original image After flatfield correction 
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The entire dataset will be corrected for the selected area. The spectrum of the middle structure is corrected 
for the flat field. 

 

References: 

Roberts, D. A., Yamaguchi, Y., and Lyon, R., "Comparison of various techniques for calibration of AIS 
data" in Proc. of the 2nd Airborne Imaging Spectrometer Data Analysis Workshop, 1986, JPL Publication, 
86-35, pp. 21-30. 

Multiplicative Scatter Correction (MSC) 
NOTE: Plastic and Coin dataset is used as an example.  

Features: Corrects spectra in the datacube.  

Steps: 

1. Open a file and select Data Correction  → Multiplicative scattering correction (MCS). 
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2. A pop-up dialogue window will ask to identify a reference spectrum.  

 

3. Click OK and draw an area. A mean spectrum from this area will serve as a reference spectrum. 
When selecting an area select a more or less uniform part of the image. After the calculations are 
complete, visualize the resulting image that is corrected for scattering. 

 

Original image After flatfield correction 

  
 

The effect of MSC can be visualized by looking at the individual spectra from one of the objects. For 
example, spectra from the multiple spots in the plastic bowl (located at the top of the image) show large 
changes. After correction with MSC, all spectra are much more similar.  
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Additional Information: 

Performing scattering correction is generally a challenging task and ideally gets rid of all effects that are 
unrelated to the chemical nature of the sample, but it depends on the sample morphology and measurement 
geometry.  

Multiplicative scatter correction (MSC) is a widely used classic normalization technique to correct spectra 
in such a way that they are as close as possible to a reference spectrum. In IDCube the reference spectrum 
is the mean of the selected area. 

MSC requires a reference spectrum. This is the most important difference between MSC and SNV which 
is also implemented in IDCube.  

The reference spectrum is ideally a spectrum free of scattering effects. For the reference spectrum, we 
suggest selecting a uniform area with minimum changes in morphology. If the spectral data are reasonably 
uniform, the average spectrum from the area is a close approximation to the ideal reference spectrum. This 
is the main assumption behind MSC. 

Mathematically, if Xm is the mean spectrum from the area, the multiplicative scatter correction is done in 
two steps. We first regress a spectrum for each pixel Xi  against the mean spectrum. This is done by ordinary 
least squares:  

Xi  ≈ ai+biXm 

The corrected spectrum for each pixel is then calculated: 

Ximsc  = (Xi−ai)/bi 

References: 

Isaksson, Tomas, and Tormod Næs. "The effect of multiplicative scatter correction (MSC) and linearity 
improvement in NIR spectroscopy." Applied Spectroscopy 42.7 (1988): 1273-1284. 

Burger, James, and Paul Geladi. "Spectral pre-treatments of hyperspectral near-infrared images: analysis of 
diffuse reflectance scattering." Journal of Near Infrared Spectroscopy 15.1 (2007): 29-37.   
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Standard Normal Variate (SNV) 
NOTE: Plastic and Coin dataset is used as an example.  

Features: Removes light scattering from the image and reduces differences in the global intensities of the 
signals. 

Steps:  

1. Open a file. Select the Data Correction tab and select Standard Normal Variate (SNV). 

 
2. From the pop-up dialogue window, select a Sliding window size. The default value is 10, which is 

equivalent to 10x10 pixels. 

 
A sliding window is a computational imaging technique that uses a small number of pixels in a grid of cells, 
of a specified size (i.e., 2 x 2) to perform calculations and reduce the calculation time. The grid of cells 
passes through the spatial dimension of the image. At each pass, the calculation within the window is 
performed and the first pixel in the window takes the values from the calculation. IDCube uses the length 
of one dimension as the window size. Here is the illustration of the Window size = 2.  

 
The resulting image shows an image with significantly less distortion of color. However, some additional 
artifacts, such as the apparent three-dimensionality of the objects can be observed.  

 

Sliding window



v. 2.78   

265 
 

 
  

The right and bottom border of the new image shown in green is the size of the sliding window in pixels 
(here is 10-pixel width). 

Additional Information: 

Performs a normalization of the spectra that consists in subtracting each spectrum by its own mean and 
dividing it by its own standard deviation. After SNV, each spectrum will have a mean of 0 and a standard 
deviation of 1.  

When using SNV, the spectra always have positive and negative values centered on 0, which may make 
interpretation difficult. 

SNV assumes that multiplicative effects are uniform over the whole spectral range, which is not always the 
case, so artifacts could be introduced by this transformation 

References: 

Barnes, R.J., Dhanoa, M.S., Lister, S.J. 1989. Standard normal variate transformation and detrending of 
near-infra-red diffuse reflectance spectra. Applied Spectroscopy 43, 772–777.  
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7.9. Toolboxes Tab 
IDCubePro® offers a variety of toolboxes to perform diverse operations. Our toolboxes are standalone 
software packages connected to the Main Interface via a one-way channel. The datasets from the Main 
interface are the input for the toolboxes.  Any changes to the datasets in toolboxes will not go back to the 
Main Interface and will not affect your data in the Main Interface. We suggest saving new datasets 
generated by toolboxes and opening them later. For the best performance, we suggest using only one 
toolbox at a time and closing it before opening another toolbox.  

 

  

Tabs Function Additional info 

Toolboxes Principal Component Analysis (PCA) Toolbox Pop-up toolbox 
 Maximum Noise Fraction (MNF) Toolbox Pop-up toolbox 
 Image Classification Toolbox Pop-up toolbox 
 Spectral Signature Matching Toolbox Pop-up toolbox 
 Endmembers Extraction Toolbox Pop-up toolbox 
 Image Indices Toolbox Pop-up toolbox 
 Contrast Maximization Toolbox Pop-up toolbox 
 Correlation Matrix (R-Squared) Pop-up toolbox 
 t-SNE Clustering Toolbox  Pop-up toolbox 
 Phasor Clustering Toolbox Pop-up toolbox 
 3D Viewer Toolbox Pop-up toolbox 
 Feature Finder with Spectrum Background Removal Pop-up toolbox 
 Fusion MSI/HSI (Pansharpening) Pop-up toolbox 
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Principal Component Analysis (PCA) Toolbox 
NOTE: PAVIA dataset is used as an example. 

Features: transforms the data to a lower dimensional space and finds principal component vectors with 
their directions along the maximum variances of the input bands. The principal components are in 
descending order of the amount of total variance. 

• Identifies the principal components from the hyperspectral data (Part A) 
• Combines principal components in a pseudo-color image (Part A). 
• Plots spectra of components (Part A). 
• Plots Cumulative Fraction of Variance (Part A).  
• Saves PCA data in IDCube format (Part A). 
• Quantifies the area by each component (Part B). 
• Performs scatter analysis and K-means to identify classes (Part C). 
• Saves PCA segmented regions as labels for Machine Learning toolbox (Part B and C) 
• Saves PCA clusters as new datacubes (Part C). 
• Saves PCA inverted clusters as new datacubes (Part C) 

  Steps: 

Select Principal Component Analysis from the Toolbox tabs from the Main Interface. Two windows 
will popup: PCA and Scatter plot in 3D. The scatter plot PCA 1, 2 and 3 corresponds to the components 
selected in the PCA popup. Changing components will automatically change the image and the scatter 
plot.  

  
In addition to visualizing the components the toolbox offers advanced segmentation either based on 
quantifying individual components (button Quantify), or cluster analysis (button PCA Clustering) 

A message box with instructions will pop-up. NOTE: The instructions can be turned off by clicking View 
→ Turn Instructions Off. 
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PCA toolbox analysis consists of three major parts. Part A: Visualization, Part B: Quantification, Part C: 
Scatter analysis. 

PART A: Visualization of components  
Move sliders of individual components to see the combined pseudo-RGB image. The default position of 
sliders in 1, 2, and 3 that corresponds to Red, Green, and Blue. 

Adjust the weight of each component. The default value is 1 for each component.  

1. In the COMPONENT SELECTION panel, scroll through different principal components assigned 
to different color channels. (Default Component #1 is red, component #2 is green, and component 
#3 is blue). The combined image in a pseudo RGB format. NOTE: Only the first 20 principal 
components can be accessed. 

2. Assign Weight to any of the channels to enhance the signal at a specific channel. Default values = 
1 for each channel. Higher/lower weight of the component will increase/decrease the color of the 
corresponding component. 

3. In the Spectra of Selected Compounds panel make a right click to activate a menu. You can save 
all three spectra of the principal components in the Excel format. 

 

When spectra are saved an info box pops-up 



v. 2.78   

269 
 

 

4. Image enhancement enables to improve the visualization. Current options are: 

a. Contrast Saturation Limit (%). The default value is 0. The range is from 0 to 49%. 

b. Gamma Correction. Gamma Correction takes values between 0 and infinity. The default 
value is 1. If gamma is <1, the image is weighted toward brighter pixels, if gamma is >1, 
the image is weighted toward darker pixels.  

5. To visualize the scatter plot in different view rotate the plot with a rotation tool shown with a red 
arrow, or make a right click and visualize options:  

         
PART B. Quantification of Principal Components  

1. Click Quantify to open a dialog with the following options. 

 
2. Set Threshold value, %. The default level is 30% and will be applied to each component. You do 

not need to adjust the value; you can do that in the next step. 
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a. Select the Principal Components Number(s) that you would like to quantify. Use the format 
such as 1 2 3 4 with spaces between the numbers. NOTE: The limit is 10 components. 

b. Select an Overlay method. The available options are: 

i. SAM (Spectral Angle Map) – default. 

ii. SID (Spectral Information Divergence). 

iii. SIDSAM (Spectral Information Divergence-Spectral Angle Mapper Hybrid 
method). 

3. Click Apply Overlay. The new pop-up PCA Quantification will show the following information: 

a. Pseudo RGB rendering of the original dataset. 

b. Threshold values, % selection box for individual Principal Component (the limit is 10 
components). 

c. Threshold Segmented Regions (based on the input of the threshold value) image with the 
overlaid principal components. 

d. Histograms that correspond to each of the components. 

e. Area of each component in pixels (located in the title of each histogram plot component). 

 

4. Adjust the Threshold value for each component. NOTE: The colors of each component might 
overlay with the map of the early listed principal component number. To verify overlap, assign the 
previous component Threshold value to 0. 

5. Save the segmented image as a Label file for the Machine Learning toolbox. For that, select a 
single component in step 5. Make a right click on the segmented image to activate Save as a Label 
File tab. NOTE: we suggest using only one component as a label such as show below.  
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Click the tab and specify the file name. The .png and .mat files will be generated 

Additional Information: 

• Each image can be zoomed and panned by using a mouse. Each image can be also modified using 

shortcuts. Click  to see the list of standard mouse functions.  

• You can click on each image to see it in a larger separate window. Each image can be saved.  

The toolbox includes the following algorithms: a) PCA and b) Overlay which includes three algorithms: 
SAM, SID, and SAMSID. The calculations are similar to the abundance method used in the endmembers 
mapping but using principal components instead of endmembers. 

References: 

SAM: Kruse, F. A., A. B. Lefkoff, J. B. Boardman, K. B. Heidebrecht, A. T. Shapiro, P. J. Barloon, and A. 
F. H. Goetz. "The Spectral Image Processing System (SIPS) - Interactive Visualization and Analysis of 
Imaging spectrometer Data." Remote Sensing of Environment 44 (1993): 145-163. 

SID: Chein-I Chang. “An Information-Theoretic Approach to Spectral Variability, Similarity, and 
Discrimination for Hyperspectral Image Analysis.” IEEE Transactions on Information Theory 46, no. 5 
(August 2000): 1927–32. https://doi.org/10.1109/18.857802. 

SIMSAD: Chang, Chein-I. “New Hyperspectral Discrimination Measure for Spectral Characterization.” 
Optical Engineering 43, no. 8 (August 1, 2004): 1777. https://doi.org/10.1117/1.1766301. 
  

https://doi.org/10.1109/18.857802
https://doi.org/10.1117/1.1766301
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PART C: Cluster analysis with K-medoids 
1. Click PCA Clustering to start PCA segmentation based on k-medoids of the clusters. 

 
2. Select the Number of clusters and the Distance Metric. The results of clustering will be seen in 

the CLUSTER OUTPUT panel on the right lower panel.  

 

 
A pop-up instructions will suggest further steps.  
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Click the green button Select Class button to visualize the cluster in the image. 

A pop-up will appear asking for which class/cluster the user would like to view.  

 
The area covered by the selected cluster (in a bright color with the area measured in pixels) will appear at 
the bottom of the image. 
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1. Save the segmented image as a Label file for the Machine Learning toolbox. After selecting the 
class, make a right click on the segmented image to activate Save as a Label File tab. Click the 
tab and specify the file name. The .png and .mat files will be generated.  

2. You can also save only the data that belongs to the cluster area as a new datacube by selecting Save 
Cluster as a Datacube file. In this case others the pixel values of the object will be preserved as 
original, while the other pixels will be assigned as 0 (zeroes) across the entire datacube. By selecting 
Save Inverted Cluster as a Datacube File, the saving will be inverted. The pixels from the area 
occupied by the cluster will be assigned to zero, while the other values across the object will remain.  

 

 
Additional Information: 

Distance Metrics 

A distance metric is a function that defines a distance between two observations. Distance metrics can be 
specified by one of the following. Definitions of the distance metrics are given in the Table: 

Value Description 

euclidean  Euclidean distance. 

squaredeuclidean  Squared Euclidean distance. (This option is provided for efficiency only. It does not 
satisfy the triangle inequality.) 

seuclidean  Standardized Euclidean distance. Each coordinate difference between observations is 
scaled by dividing by the corresponding element of the standard deviation,  

mahalanobis  Mahalanobis distance using the sample covariance of X, C = cov(X,'omitrows'). 

cityblock  City block distance. 

minkowski  Minkowski distance. The default exponent is 2. 

chebychev  Chebychev distance (maximum coordinate difference). 

cosine  One minus the cosine of the included angle between points (treated as vectors). 

correlation  One minus the sample correlation between points (treated as sequences of values). 

hamming  Hamming distance, which is the percentage of coordinates that differ. 

jaccard  One minus the Jaccard coefficient, which is the percentage of nonzero coordinates that 
differ. 
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Value Description 

spearman  One minus the sample Spearman's rank correlation between observations (treated as 
sequences of values). 
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Maximum Noise Fraction (MNF) Toolbox 
NOTE: PAVIA dataset is used as an example. 

Features: transforms the data to a lower dimensional space and finds principal component vectors after 
noise removal with their directions along the maximum variances of the input bands. The principal 
components are in descending order of the amount of total variance. 

• Identifies the noise removed principal components from the hyperspectral data (Part A) 
• Combines principal components in a pseudo-color image (Part A). 
• Plots spectra of components (Part A). 
• Saves MNF data in IDCube format (Part A). 
• Quantifies the area by each component (Part B). 
• Performs scatter analysis and K-means to identify classes (Part C). 
• Saves MNF segmented regions as labels for Machine Learning toolbox (Part B and C) 
• Saves MNF clusters as new datacubes (Part C). 
• Saves MNF inverted clusters as new datacubes (Part C). 

  Steps:  

Select Maximum Noise Fraction from the Toolboxes tab from the Main Interface. Two windows 
will popup: PCA and Scatter plot in 3D. The scatter plot PCA 1, 2 and 3 corresponds to the components 
selected in the PCA popup. Changing components will automatically change the image and the scatter 
plot.   

  

In addition to visualizing the components the toolbox offers advanced segmentation either based on 
quantifying individual components (button Quantify), or cluster analysis (button MNF Clustering) 

A message box with instructions will pop-up. NOTE: The instructions can be turned off by clicking View 
→ Turn Instructions Off. 
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MNF toolbox analysis consists of three major parts. Part A: Visualization, Part B: Quantification, Part C: 
Scatter analysis. 

PART A: Visualization of principle components  
Move sliders of individual components to see the combined pseudo-RGB image. The default position of 
sliders in 1, 2, and 3 that corresponds to Red, Green, and Blue. 

1. In the COMPONENT SELECTION panel scroll through different principal components assigned 
to different color channels. (Default Component #1 is red, component #2 is green, and component 
#3 is blue). NOTE: Only the first 20 principal components can be accessed. 

2. Assign Weight to any of the channels to enhance the signal at a specific channel. Default values 
=1 for each channel. Higher/lower weight of the component will increase/decrease the color of the 
corresponding component. 

3. In the Spectra of Selected Compounds panel make a right click to activate a menu. You can save 
all three spectra of the principal components in the Excel format. 

 
When spectra are saved an info box pops-up: 

 
4. Image enhancement enables to improve the visualization. Current options are: 

a. Contrast Saturation Limit (%). The default value is 0. The range is from 0 to 49%. 
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b. Gamma Correction. Gamma Correction takes values between 0 and infinity. The default 
value is 1. If gamma is <1, the image is weighted toward brighter pixels, if gamma is >1, 
the image is weighted toward darker pixels.  

 
PART B. Quantification of Principal Components  

1. Click Quantify to open a dialog with the following options. 

 
2. (Optional) Set Threshold value, %. The default level is 30% and will be applied to each 

component. You do not need to change the value at this moment; you can do that in the next step. 

3. Select the Principal Components number(s) that you would like to quantify. Use the format such 
as 1 2 3 4 with spaces between the numbers. NOTE: The limit is 10 components. 

4. Select an Overlay method. The available options are: 

a. SAM (Spectral Angle Map) – default. 
b. SID (Spectral Information Divergence). 
c. SIDSAM (Spectral Information Divergence-Spectral Angle Mapper Hybrid Method). 

5. Click Apply Overlay. The new pop-up NMF Quantification will show the following information: 

a. RGB rendering of the original dataset. 
b. Threshold values, % selection box for individual Principal Component (the limit is 10 

components). 
c. Thresholded image (based on the input of the threshold value) with the overlaid principal 

components. 
d. Histograms that correspond to each of the components. 
e. Area of each component in pixels (located in the title of each histogram plot component). 
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Adjust the Threshold value for each component. Note that the colors might overlay with the map of the 
early listed principal component number being on top. To verify overlap, assign the early component 
Threshold value to 0. 

6. Save the segmented image as a Label file for the Machine Learning toolbox. Make a right click 
on the segmented image to activate Save as a Label File tab. NOTE: we suggest to use only one 
component as a label such as show below.  

 
Click the tab and specify the file name. The .png and .mat files will be generated. 

Tips: 
• Each image can be zoomed and panned by using a mouse. Each image can be also modified using 

shortcuts.  

• You can click on each image to see it in a larger separate window. Each image can be saved.  

 

PART C: Cluster analysis with K-medoids 
1. Click PCA Clustering to start PCA segmentation based on k–means of the clusters. 

2. Select the Number of clusters and the Distance Metric. The results of clustering will be seen in 
the CLUSTER OUTPUT panel on the right lower panel.  
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A pop-up instructions will suggest further steps.  

 
3. Click the green button Select Class button to visualize the cluster in the image. A pop-up will 

appear asking for which class/cluster the user would like to view.  

 
The area covered by the selected cluster (in a bright color with the area measured in pixels) will appear at 
the bottom of the image. 
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4. Save the segmented image as a Label file for the Machine Learning toolbox. After selecting the 

class, make a right click on the segmented image to activate Save as a Label File tab. Click the 
tab and specify the file name. The .png and .mat files will be generated.  

You can also save only the data that belongs to the cluster area as a new datacube by selecting Save 
Cluster as a Datacube file. In this case others the pixel values of the object will be preserved as 
original, while the other pixels will be assigned as 0 (zeroes) across the entire datacube. By selecting 
Save Inverted Cluster as a Datacube File, the saving will be inverted. The pixels from the area 
occupied by the cluster will be assigned to zero, while the other values across the object will remain.  

 
Additional Information: 

MNF toolbox computes a specified number of principal component bands by using the Maximum Noise 
Fraction (MNF) transform. To achieve spectral dimensionality reduction, the specified number of principal 
components must be less than the number of spectral bands in the input datacube. MNF computes the 
principal components that maximize the signal-noise-ratio, rather than the variance. MNF transform is 
particularly efficient at deriving principal components from noisy band images. The principal component 
bands are spectrally distinct bands with low interband correlation. 

The components derived using MNF transform are also called non-adjusted principal components and the 
MNF transform arranges principal components in the decreasing order of the principal component's image 
quality. 
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MNF transform is equivalent to a two-stage transformation in which the data are first transformed so 
that the noise covariance matrix is the identity matrix and the second stage is the principal components 
transform. 

MNF transformation gives a better signal-to-noise ratio (SNR) than PCA transformation when signal-
dependent noise is present in the input data. PCA transformation works better than MNF transformation 
when Gaussian white noise is present in the input data. 
The toolbox includes the following set of algorithms: a) MNF (noise removal +PCA) and b) Overlay which 
includes three algorithms: SAM, SID, and SAMSID. The calculations are similar to the abundance maps 
method used in the endmembers mapping but using principal components instead of endmembers.  

Distance Metrics 

A distance metric is a function that defines a distance between two observations. Distance metrics can be 
specified by one of the following. Definitions of the distance metrics are given in the Table: 

Value Description 

euclidean  Euclidean distance. 

squaredeuclidean  Squared Euclidean distance. (This option is provided for efficiency only. It does not 
satisfy the triangle inequality.) 

seuclidean  Standardized Euclidean distance. Each coordinate difference between observations is 
scaled by dividing by the corresponding element of the standard deviation,  

mahalanobis  Mahalanobis distance using the sample covariance of X, C = cov(X,'omitrows'). 

cityblock  City block distance. 

minkowski  Minkowski distance. The default exponent is 2. 

chebychev  Chebychev distance (maximum coordinate difference). 

cosine  One minus the cosine of the included angle between points (treated as vectors). 

correlation  One minus the sample correlation between points (treated as sequences of values). 

hamming  Hamming distance, which is the percentage of coordinates that differ. 

jaccard  One minus the Jaccard coefficient, which is the percentage of nonzero coordinates that 
differ. 

spearman  One minus the sample Spearman's rank correlation between observations (treated as 
sequences of values). 

References: 

MNF: Green, A.A., M. Berman, P. Switzer, and M.D. Craig. “A Transformation for Ordering Multispectral 
Data in Terms of Image Quality with Implications for Noise Removal.” IEEE Transactions on Geoscience 
and Remote Sensing 26, no. 1 (January 1988): 65–74. https://doi.org/10.1109/36.3001. 

SAM: Kruse, F. A., A. B. Lefkoff, J. B. Boardman, K. B. Heidebrecht, A. T. Shapiro, P. J. Barloon, and A. 
F. H. Goetz. "The Spectral Image Processing System (SIPS) - Interactive Visualization and Analysis of 
Imaging spectrometer Data." Remote Sensing of Environment 44 (1993): 145-163. 

SID: Chein-I Chang. “An Information-Theoretic Approach to Spectral Variability, Similarity, and 
Discrimination for Hyperspectral Image Analysis.” IEEE Transactions on Information Theory 46, no. 5 
(August 2000): 1927–32. https://doi.org/10.1109/18.857802. 

https://doi.org/10.1109/18.857802
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SIMSAD: Chang, Chein-I. “New Hyperspectral Discrimination Measure for Spectral Characterization.” 
Optical Engineering 43, no. 8 (August 1, 2004): 1777. https://doi.org/10.1117/1.1766301.  
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Image Classification Toolbox  
NOTE: PAVIA dataset is used as an example.  

Features: 

• Performs Classification using several algorithms based on the selected seed areas. 

• Quantifies the area and other parameters.  

Steps: 

1. Open a hyperspectral file through the Main Interface. 

2. Navigate to Toolboxes → Classifications. A new window will pop up. 

3. Select an algorithm from the ALGORITHM SELECTION panel. Currently available options are: 

a. Spectral Matching - supports only one class.  

b. Spectral Angle Mapping (default) - supports several classes (areas of interest). 

Spectral Angle Mapping  
4. Select Spectral Angle Mapping. 

5. Click Add Class and select a region of interest. Click Classify to perform classification. Adjust the 
output by specifying Threshold Parameters Alpha and Beta Values.  

Tip: Start by changing the Beta Value 0.5 units up and down. Click Classify to perform the mapping. 

 
You can select many regions by clicking Add Class again and selecting another region. 

NOTE: the colors in the classified image are assigned randomly. To change the colors click Classify again 
without changing any other parameters. If you need to select a different region or add another class after 
you performed classification, click Reset and repeat the steps.  

To copy results to Excel, click Export Data to Excel. Alternatively, highlight the results with Ctrl+A and 
copy (Ctrl+C). Paste the results to Excel or other software. 



v. 2.78   

285 
 

With one selected class: 

 

With three selected classes: 

 

Spectral Matching 
1. Select Spectral Matching (only one class can be selected). 
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2. Click Add Class and select a region of interest. Click Classify to perform classification. A new pop-
up window along with a dialog will appear. The left image will show a new map where each pixel is 
measured against the average spectrum from the selected region of interest. The lower Score (dark blue 
in the default colorscheme) corresponds to the higher similarity. The plot on the right shows the 
histogram Number of Pixels vs. Score.  

3. From the histogram, identify the first feature in the histogram, (i.e., the first peak) and put the value 
into the dialog window. Click OK to visualize the resulting image to the right. The segmented image 
can be viewed in different look-up tables (LUTs) that could be selected from the Color Toolbar menu. 
The colorschemes show the similarity between objects of the image but in different colors. Very close 
(matched) objects will have the same colors, slightly different will be colored differently.   

 

4. To copy results to Excel, click Export Data to Excel. Alternatively, select the results with Ctrl+A and 
copy (Ctrl+C), then paste the results to Excel or other software. 

Additional Information:  

Alpha and beta parameters: These parameters act as threshold values that binarize the output image based 
on the selected classification algorithm. The main threshold value is based on the following equation: 

𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿  =  �(𝑔𝑔𝑔𝑔𝑔𝑔𝑔𝑔𝑔𝑔ℎ𝑟𝑟𝑟𝑟𝑟𝑟ℎ𝑜𝑜𝑜𝑜𝑜𝑜 ⋅ 𝑜𝑜𝑜𝑜𝑜𝑜𝑜𝑜𝑜𝑜𝑜𝑜) + 𝑎𝑎𝑎𝑎𝑎𝑎ℎ𝑎𝑎� ⋅ 𝑏𝑏𝑏𝑏𝑏𝑏𝑏𝑏 

Here, 𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿𝐿 is the threshold value to binarize the remapped output image.  
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Spectral Signature Matching Toolbox 
NOTE: Requires spectra saved in the ECOSTRESS format (name_spectrum.txt). 

Features:  

• Compares the similarity of each pixel spectrum to the reference spectrum.  

• Detects a target in the hyperspectral image by using a specified spectral signature matching method. 

• Shows the area that corresponds to the reference spectrum in the ECOSTRESS format 
(https://www.mathworks.com/help/images/ref/readecostresssig.html).  Spectra can be recorded in 
the ECOSTRESS format from a SPECTRAL ANALYSIS panel and ENDMEMBERS 
EXTRACTION toolbox (see corresponding sections). 

• Calculates the area (in pixels) that matches a specific spectrum with the user input threshold value. 

• Enables batch processing. 

 

Steps: 

1. Browse your directory to select the reference spectrum name_spectrum.txt file in the ECOSTRESS 
format. You can select multiple spectra. 

2. Click Load Library Spectra. 

3. If only pne spectrum is selected, you can select the method of spectral matching from the dropdown 
menu. The methods are described below. Available options are: 

• Spectral Angular Mapper (SAM) 

• Jeffries Matusita SAM (JM SAM) 

• Normalized Spectral Similarity (NS3) 

• Spectral Information Divergence (SID) 

• Spectral Information Divergence - Spectral Angular Mapper Hybrid (SIDSAM) 

https://www.mathworks.com/help/images/ref/readecostresssig.html


v. 2.78   

288 
 

4. Click Match to visualize the matching score. A lower score indicates a better match with the 
uploaded spectrum. 

5. The software automatically generates histograms of all score intensities under the HISTOGRAM 
OF SCORE MAP. Select a threshold close to the first feature (i.e., a peak) on the histogram.  

6. The orange color object(s) are generated and overlapped with the original image. The total area of 
the match in pixels appears in the title of the IMAGE DISPLAY panel. 

7. If multiple spectra are selected, the dropdown menu will become inactive. Click Match to activate 
a pop-up Multiple Signature Matching box. You can leave a threshold value as default (=0.2) or 
change with the range from 0 to 1 for SAM or other ranges for SID and SIDSAM. Select the 
Overlay method (SAM, SID, SIDSAM) and click Match. 

 
 

 
You can adjust the threshold based on the corresponding histogram to visualize the location of the area 
with the matched spectrum 

Additional Information: 

Spectral Angle Mapper (SAM) is a spectral image processing classification that matches the spectra from 
pixels to reference spectra. The algorithm determines the spectral similarity between two spectra by 
calculating the angle α between the spectra. Smaller angles represent closer matches to the reference 
spectrum. Reference spectra can be uploaded from known sources or directly extracted from an image as a 
region of interest (ROI) mean spectra (from the Main Interface see Main Interface manual). 
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JMSAM is a spectral image processing classification that matches the spectra from each pixel (test 
spectrum) to a reference spectrum. The method computes spectral similarity based on the Jeffries Matusita 
(JM) and SAM distances between two spectra. A smaller JMSAM score indicates a strong match between 
the test spectrum and the reference spectrum. 

NS3 computes spectral similarity based on the Euclidean and SAM distances between the test spectrum and 
the specified reference spectrum by using the normalized spectral similarity score (NS3) method. 

SID measures the spectral similarity between the spectra of each pixel in the hyperspectral data and the 
specified reference by using the spectral information divergence (SID) technique. The method computes 
spectral similarity based on the divergence between the probability distributions of the two spectra. 

SIDSAM measures the spectral similarity between the spectra of each pixel in the hyperspectral data and 
the specified reference by using a hybrid SID-SAM hybrid score. 

References: 

SAM: Kruse, F. A., A. B. Lefkoff, J. B. Boardman, K. B. Heidebrecht, A. T. Shapiro, P. J. Barloon, and A. 
F. H. Goetz. "The Spectral Image Processing System (SIPS) - Interactive Visualization and Analysis of 
Imaging spectrometer Data." Remote Sensing of Environment 44 (1993): 145-163. 

JMSAM: Padma, S., and S. Sanjeevi. “Jeffries Matusita Based Mixed-Measure for Improved Spectral 
Matching in Hyperspectral Image Analysis.” International Journal of Applied Earth Observation and 
Geoinformation 32 (October 2014): 138–51. https://doi.org/10.1016/j.jag.2014.04.001. 

NS3: Nidamanuri, Rama Rao, and Bernd Zbell. “Normalized Spectral Similarity Score (NS3) as an 
Efficient Spectral Library Searching Method for Hyperspectral Image Classification.” IEEE Journal of 
Selected Topics in Applied Earth Observations and Remote Sensing 4, no. 1 (March 2011): 226–40. 
https://doi.org/10.1109/JSTARS.2010.208643 

SID: Chein-I Chang. “An Information-Theoretic Approach to Spectral Variability, Similarity, and 
Discrimination for Hyperspectral Image Analysis.” IEEE Transactions on Information Theory 46, no. 5 
(August 2000): 1927–32. https://doi.org/10.1109/18.857802. 

SIDSAM: Chang, Chein-I. “New Hyperspectral Discrimination Measure for Spectral Characterization.” 
Optical Engineering 43, no. 8 (August 1, 2004): 1777. https://doi.org/10.1117/1.1766301. 
  

https://doi.org/10.1016/j.jag.2014.04.001
https://doi.org/10.1109/JSTARS.2010.208643
https://doi.org/10.1109/18.857802
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Endmembers Extraction Toolbox 
NOTE: PAVIA dataset is used as an example. 

Features: 

• Identifies the number of endmembers from the hyperspectral data. 

• Extracts individual endmember spectra and saves them in Excel and the ECOSTRESS format. 

• Quantifies the area given by each endmember. 

 

Select PPI function to estimate the endmembers by using the PPI approach. The PPI approach projects the 
pixel spectra to an orthogonal space and identifies extreme pixels in the projected space as endmembers. 
This is a non-iterative approach, and the results depend on the random unit vectors generated for orthogonal 
projection. To improve results, you must increase the random unit vectors for projection, which can be 
computationally expensive. 

Use the FIPPI function to estimate the endmembers by using the FIPPI approach. The FIPPI approach is 
an iterative approach, which uses an automatic target generation process to estimate the initial set of unit 
vectors for orthogonal projection. The algorithm converges faster than the PPI approach and identifies 
endmembers that are distinct from one another. 

Use the N-FINDR function to estimate the endmembers by using the N-FINDR method. N-FINDR is an 
iterative approach that constructs a simplex by using pixel spectra. The approach assumes that the volume 
of a simplex formed by the endmembers is larger than the volume defined by any other combination of 
pixels. The set of pixel signatures for which the volume of the simplex is high are the endmembers. 

Steps: 

1. Select option in Endmember Calculation Method. Available options are:  

a. NWHFC 
b. PFA 
c. Noise Whiten -False 
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2. Specify the method that calculates the number of endmembers under Endmember Estimation 
Method. Available options are:  

a. N-FINDR 
b. Specify the number of iterations. If the field is empty, the default is the Number of 

Iterations = 3 x the number of endmembers. NOTE: The computation time of the algorithm 
increases with the increase in the number of iterations. 

c. FIPPI 
d. PPI  
e. Alternatively, type the number of endmembers you expect to find (shown 5, default is 0). 

The number must be less or equal to the number of channels. If this box is filled with a 
number, the method selection is irrelevant. 

3. Select the reduction method. If this argument is specified, the function first reduces the spectral 
dimension of the input data by using the specified method. Then, it computes the endmember 
signatures from the reduced data. Available options are:  

a. Principal Component Analysis 
b. Maximum Noise Fraction (default) 

4. After the endmembers spectra are calculated (can be seen in the ENDMEMBER SPECTRA panel), 
single endmember images are produced in the ABUNDANCE MAP IMAGES panel. At the same 
time, the best three images are combined in the ESTIMATED RGB IMAGE panel. 

5. Select Monochromatic/PseudoRGB options to visualize the image on the IMAGE DISPLAY panel. 
Available options are: 

a. Monochromatic 
b. Pseudo RGB  

Use a slider to move between the images (in a monochromatic mode) or combine the images in the pseudo-
RGB mode. Up to three images can be combined. 

Click the Quantify button to measure the area covered by each of the selected endmember. A new pop-up 
menu will be opened followed by a new panel (See the Quantify manual). 

Tips: You can click on each image to see it in a larger separate window. Each image can be saved. 

Each produced endmember spectrum can be saved either in Excel or the ECOSTRESS format. To save the 
spectra, right-click on the ENDMEMBERS SPECTRA panel. In the case of ECOSTRESS, the spectra 
have to be saved one by one. When Save Spectra in ECOSTRESS format is selected, a pop-up dialogue 
window ECOSTRESS Format Parameters will request additional information, like the Endmember number 
(mandatory field), name, type, etc.   
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Additional Information: 

The toolbox includes several types of algorithms: a) to find the number of endmembers, b) to identify their 
spectra, and c) to calculate endmembers’ abundance maps. 

Noise-whitened Harsanyi–Farrand–Chang (NWHFC) finds the number of endmembers present in a 
hyperspectral datacube by using the NWHFC method. When 'NoiseWhiten – false' is checked, the algorithm 
does not perform noise-whitening of the data before extracting the endmembers. In that case, the method is 
also known as the Harsanyi–Farrand–Chang (HFC) method. 

The method also requires the input for the Probability of False Alarm (PFA). The default value for PFA is 
10-3 (default). A smaller value will provide more endmembers. 

N-FINDR is an iterative approach for finding the endmembers of a hyperspectral dataset. The method 
assumes that the volume of a simplex formed by the endmembers (purest pixels) is larger than any other 
volume defined by any other combination of pixels. Computes principal component bands and reduces the 
spectral dimensionality of the input data by using MNF or PCA. The number of principal component bands 
to be extracted is set equal to the number of endmembers to be extracted. The endmembers are extracted 
from the principal component bands. 

Pixel Purity Index (PPI) extracts endmember signatures from hyperspectral datacube by using the pixel 
purity index algorithm. The method computes the orthogonal projections of hyperspectral data values on a 
set of randomly generated unit vectors known as the skewers. Then, the method computes the PPI count for 
each data value. PPI count is the number of times a data value results in an extreme point when projected 
onto these skewers. Those data values with more than the expected number of PPI count comprise the 
endmembers of the hyperspectral data. PPI is a non-iterative method and the steps involved use MNF or 
PCA to reduce the dimensionality of the input data. The number of principal component bands to be 
extracted is set equal to the number of endmembers to be extracted. 

Fast Iterative Pixel Purity Index (FIPPI) is an approach that iteratively selects the better candidates for 
endmembers after each iteration. Unlike the pixel purity index (PPI) technique, the FIPPI method selects 
the initial set of skewers by using the automatic target generation process (ATGP). As a result, the algorithm 
converges faster and generates a unique pixel for each endmember. The steps involved in FIPPI approach 
use MNF or PCA to reduce the dimensionality of the input data. 

References: 

NWHFC: Chang, C.-I., and Q. Du. “Estimation of Number of Spectrally Distinct Signal Sources in 
Hyperspectral Imagery.” IEEE Transactions on Geoscience and Remote Sensing 42, no. 3 (March 2004): 
608–19. https://doi.org/10.1109/TGRS.2003.819189  

N-FINDR: Winter, Michael E. “N-FINDR: An Algorithm for Fast Autonomous Spectral End-Member 
Determination in Hyperspectral Data.” Proc. SPIE Imaging Spectrometry V 3753, (October 1999): 266–75. 
https://doi.org/10.1117/12.366289. 

PPI: J.W Boardman, F.A. Kruse and R.O. Green, "Mapping target signatures via partial unmixing of 
AVIRIS data.", Technical Report, California, USA, 1995.https://ntrs.nasa.gov/citations/19950027316  

FIPPI: Chang, C.-I., and A. Plaza. “A Fast Iterative Algorithm for Implementation of Pixel Purity Index.” 
IEEE Geoscience and Remote Sensing Letters 3, no. 1 (January 2006): 63–67. 
https://doi.org/10.1109/LGRS.2005.856701. 
 

https://doi.org/10.1109/TGRS.2003.819189
https://doi.org/10.1117/12.366289
https://ntrs.nasa.gov/citations/19950027316
https://doi.org/10.1109/LGRS.2005.856701
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Image Indices Toolbox 
NOTE: AVIRIS file “Lakes” is used as an example. 

Features: 

• Applies established indices to the dataset. 
• Saves the new indices. 
• Combines established and new indices in a pseudo color image, generating a composite index. 

  Steps: 

1. After opening a file, from the Main Interface, select Toolboxes → Image Indices → Vegetation 
Indices → AVIRIS. 

 

A new window toolbox will appear. 

 
The toolbox interface has four panels:  

1. IMAGE DISPLAY panel shows a 2D image after applying the index. By default, it shows a Random 
Wavelength Index, which is simply a slice of a datacube at a randomly selected band/channel. Other 
standard indices are given in the following table.  

2. STANDARD INDEX panel presents a selection of the established standard indices. Selection of the 
index from the dropdown menu and clicking Display Output updates the image on the Image Display 
panel.  

3. CUSTOM INDEX panel allows you to develop your own index. Currently, IDCube supports two- and 
three-channel indexes. You can select the available channels from the dropdown menu and visualize the 
result on the IMAGE DISPLAY panel by clicking Display Output located on this panel and pressing Save 
New Index. You can add the new index to the list of indexes in the COMPOSITE INDEX panel (see 
below). The panel also allows opening a stored index via the Upload Index button.  

4. COMPOSITE INDEX panel allows you to combine images generated by up to three individual indices 
into a pseudo-RGB image. This panel has three subpanels. The sliders under the individual subpanels reflect 
the color of the channel: the left slider – contributes to the red channel, the middle slider – to the green 
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channel, right slider – to the blue channel. The sliders also help the user to adjust the image before sending 
it to the Image display. Each slider has two sub-sliders that can be moved.  

NOTE: To be combined in the RGB image, each index image in the subpanel is normalized to [0, 1].  

Index Image Display panel 
The panel allows you to visualize established and newly developed indices as monochromatic images and 
composite indices in the RGB format. Each index comes with its own colormap. Some of the colormaps 
are specifically designed by IDCubePro® team for the corresponding indices. Other colormaps such as 
preset colormaps from the Color Toolbar or the Right click menu on the colorbar can be also applied.   

Standard Index panel 

Steps: 

1. Select an option from the dropdown menu. There are currently 23 indices in our AVIRIS, AVIRIS-
NG, and Hyperion index databases. Each index is made of two or three wavelengths. Wavelength 
selection for the same index differs across platforms because of differences in the hyperspectral 
hardware.  

Standard Index Platforms supported 

1. Random wavelength index AVIRIS,  AVIRIS-NG, Hyperion 
2. Normalized Difference Vegetation Index (NDVI) AVIRIS,  AVIRIS-NG, Hyperion 
3. Modified Chlorophyll Absorption in Reflectance Index (MCARI-1) AVIRIS,  AVIRIS-NG, Hyperion 
4. Modified Chlorophyll Absorption in Reflectance Index (MCARI-2) AVIRIS,  AVIRIS-NG, Hyperion 
5. Normalized Difference Water Index (NDWI) AVIRIS,  AVIRIS-NG, Hyperion 
6. Modified Triangular Vegetation Index 1 (MTVI 1) AVIRIS,  AVIRIS-NG, Hyperion 
7. Modified Triangular Vegetation Index 2 (MTVI 2) AVIRIS,  AVIRIS-NG, Hyperion 
8. Renormalized Difference Vegetation Index (RDVI) AVIRIS,  AVIRIS-NG, Hyperion 
9. Leaf Area Index (LAD) AVIRIS,  AVIRIS-NG, Hyperion 
10. Modified Simple Ratio (MSR) AVIRIS,  AVIRIS-NG, Hyperion 
11. Soil-Adjusted Vegetation Index (SAVI) 2 AVIRIS,  AVIRIS-NG, Hyperion 
12. Modified SAVI with self-adjustment factor L (MSAVI) AVIRIS,  AVIRIS-NG, Hyperion 
13. Optimized Soil-adjusted Vegetation Index (OSAVI) AVIRIS,  AVIRIS-NG, Hyperion 
14. Normalized Difference Nitrogen Index (NDNI) AVIRIS,  AVIRIS-NG, Hyperion 
15. Normalized Difference Salinity Index (NDSI) AVIRIS,  AVIRIS-NG, Hyperion 
16. Red-edge Inflection Point 1 REIP-1 AVIRIS,  AVIRIS-NG, Hyperion 
17. Transformed Chlorophyll Absorption Ratio (TCARI) AVIRIS,  AVIRIS-NG, Hyperion 
18. Triangular Vegetation Index (TVI) AVIRIS,  AVIRIS-NG, Hyperion 
19. Photochemical Reflectance Index (PRI) AVIRIS,  AVIRIS-NG, Hyperion 
20. Cellulose Absorption Index (CAI) AVIRIS,  AVIRIS-NG, Hyperion 
21. Cellulose Absorption Index 2 (CAI-2) AVIRIS,  AVIRIS-NG, Hyperion 
22. Simple Ratio Water Index (SRWI) AVIRIS,  AVIRIS-NG, Hyperion 
23. Plant Water Index (PWI) AVIRIS,  AVIRIS-NG, Hyperion 
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2. The information about the index will be automatically shown in the ABOUT THE INDEX 

subpanel. The image corresponding to the selected index will be shown in the IMAGE DISPLAY 
panel.  

 

 
3. Click Display Output to visualize the index image 

Custom Index panel  

Steps: 

1. Activate the panel by Selecting the Custom Indices radio button. 

2. Select the number of variables. Current choices: 

a. Two variables: allows user to enter two bands. 

b. Three variables: allows user to enter three bands. 

3. Type a formula (See Appendix 1 on notation and selections of available functions).  
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4. Visualize the result on the INDEX IMAGE DISPLAY panel by clicking Display Output located 

on this panel. 

5. Save the index by clicking the Save New Index button. 

(Optional). You can add a new index to the list of indices in the COMPOSITE INDEX panel by checking 
Add to the Composite Index box. A new index called custom1 will appear at the bottom of the list of 
indices in the COMPOSITE INDEX panel. 

6. You can also open a previously stored index via the Upload Index button. 

Composite Index panel 

Steps:  

1. There are three subpanels. Select an index from the dropdown menu on each of the subpanels. The 
index images will be immediately shown as monochromatic images. Pixel intensities on the image 
are normalized between 0 and 1 values. 

2. Use sliders to adjust the visual appearance of the image. Each slider box has two small sliders. To 
move the small slider, click on it to activate (changes the color from grey to color) and then use the 
left and right boxes to move the slider. Repeat the procedure to the second slider.   
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3. Repeat the steps on all three subpanels. 

4. Check View on Image Display to combine the index images together and visualize them on the 
INDEX IMAGE DISPLAY panel by pressing Combine as RGB on the Image Display button. 
You can continue adjusting the subpanels with sliders. After every adjustment, click Combine as 
RGB to visualize on the INDEX IMAGE DISPLAY panel. 

  
References:  

The design of the sliders was based on the work by Danielle Ripsman, (2022). superSlider 
https://www.mathworks.com/matlabcentral/fileexchange/43285-superslider), MATLAB Central File 
Exchange. Retrieved May 11, 2022. 
  

https://www.mathworks.com/matlabcentral/fileexchange/43285-superslider
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Contrast Maximization Toolbox 
NOTE: The toolbox works best when the original image in the Main Interface is monochromatic. If you 
see issues, please close this toolbox, return to the Main Interface and select Single Channel radio button.  
Features: 

1. Finds the channel/wavelength for the best contrast between two selected regions of interest (ROIs). 

2. Finds the channel/wavelength for the best contrast and the corresponding bandwidths between two 
selected regions of interest (ROIs). 

3. Identify whether there is a difference between two ROIs and quantify the difference using 
Bhattacharyya distance (Db). Higher Db corresponds to better contrast between two ROIs 

4. Identifies new indexes. 

 

Quantitative measurement of contrast using Bhattacharyya Distance (Db). 
Higher contrast corresponds to the higher value of Db. 

Steps:  

1. Load the file and select Toolboxes → Contrast Maximization 

 
 

A toolbox window with instructions will pop up.  
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2. Select Mathematics. Available options are:  

 Description Mathematical Expression or function  

 Single channel: w1 
 Summation (two channels) w1 + w2 
 Simple Ratio (two channels) w1./w2   
 Normalized Ratio (two channels) (w1-w2)/(w1+w2) 
 Weber Ratio (two channels) (w1-w2)/w2 
 Log10(Ratio) (two channels) Log10(w1./w2) 
 Multiplication (two channels) w1 x w2 
 Log10(multiplication) (two channels) Log10(w1 + w2) 
 Logical AND (two channels) w1 AND w2 
 Logical OR (two channels) w1 OR w2 
 Logical XOR (two channels) w1 XOR w2 
 Image complement (Single band only) imcomplement(w1) 
 First derivative (Single band only) gradient(w1) 
 Second derivative (Single band only) gradient(gradient(w1)) 

 

3. Select the Selection Tool. Available options are: 

a. Ellipse 
b. Polygon 
c. Freehand 
d. Rectangular 

4. Select the Band Shape. Available options are: 

a. Rectangular Band Shape 
b. Gaussian Band Shape  
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5. Select the method for finding the best channel(s) for contrast. Available options are: 

a. Exhaustive Search without the bandwidths 
b. Monte Carlo Search with the bandwidths 

 

 
6. Draw the first region of interest with the cursor and adjust. Click ENTER to fix the selection and 

draw a second area. Adjust the second area and click ENTER to fix the selection. The calculations 
will start immediately. 

          
 

If the single channel is selected the resulting screen will provide a Contrast Plot showing the contrast 
between the areas vs wavelength, and the image panel will show the image with the highest (best) contrast.   
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If the two channels from the Mathematics panel is selected, then instead of a Contrast Plot, a 2D Contrast 
Space will be shown. The best combination of the wavelengths will be given as a title 

 
 

If the Monte Carlo is selected, then a new dialog asks to put the minimum and maximum bandwidths as 
well as the number of samples. (NOTE: The number of samples depends on the size of the image. A higher 
number will make the calculation slower.) 
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The results are displayed as a new image and a contrast map. The title of the image gives the wavelengths. 
Toolbox display once processing has been completed. Note the title of the image gives the specific max 
contrast values. 

 

Additional Information: 

The algorithm implies relatively homogenous intensities within the region of interest. Adjust the size of the 
ROI accordingly.  

References: 

T Du, DK Mishra, L Shmuylovich, A Yu, H Hurbon, ST Wang, MY Berezin. Hyperspectral imaging and 
characterization of allergic contact dermatitis in the short‐wave infrared, Journal of Biophotonics 13 (9), 
e202000040, 2020 

DM Kim, H Zhang, H Zhou, T Du, Q Wu, TC Mockler, MY Berezin. Highly sensitive image-derived 
indices of water-stressed plants using hyperspectral imaging in SWIR and histogram analysis Scientific 
Reports 5 (1), 1-11, 2015  

https://scholar.google.com/citations?view_op=view_citation&hl=en&user=Uk8VhXEAAAAJ&sortby=pubdate&alert_preview_top_rm=2&citation_for_view=Uk8VhXEAAAAJ:Huv_iBJ06lEC
https://scholar.google.com/citations?view_op=view_citation&hl=en&user=Uk8VhXEAAAAJ&sortby=pubdate&alert_preview_top_rm=2&citation_for_view=Uk8VhXEAAAAJ:Huv_iBJ06lEC
https://scholar.google.com/citations?view_op=view_citation&hl=en&user=Uk8VhXEAAAAJ&cstart=20&pagesize=80&sortby=pubdate&alert_preview_top_rm=2&citation_for_view=Uk8VhXEAAAAJ:4DpXlaHga4wC
https://scholar.google.com/citations?view_op=view_citation&hl=en&user=Uk8VhXEAAAAJ&cstart=20&pagesize=80&sortby=pubdate&alert_preview_top_rm=2&citation_for_view=Uk8VhXEAAAAJ:4DpXlaHga4wC
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t-SNE Clustering Toolbox 
NOTE: The Toolbox supports parallel computing to accelerate computation. Plastic is used as an example. 
Large files might a take a long time to compute. A typical time for a 50Mb file (Pavia, 340 x 610 x 103) 
takes about 10 minutes on an average desktop computer. 

Features: 

• Builds a 2D or 3D scatter map from the entire datacube. 

• Enables a user to separate clusters via the k-means and visualize their position on an image. 

• Enables a user to visualize up to 10 clusters. 

• Calculates the area covered by each cluster (in pixels). 

 Steps: 

3. Open a file. 

4. Select Toolboxes → t-SNE Clustering 

 
Calculations for t-SNE are computationally demanding. For that, the datacube size is minimized 
by using the pre-binning step in both spectral (bin=3) and spatial bin (3x3) dimensions. The 
preprocessing calculation starts immediately. 
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5. Select a method: available options are: 

a. Barnes-Hut variation of t-SNE is used to speed the t-SNE algorithm and to cut down on 
its memory usage. The Barnes-Hut algorithm groups nearby points together to lower the 
complexity and memory usage of the t-SNE optimization step. The Barnes-Hut algorithm 
is an approximate optimizer, not an exact optimizer. There is a nonnegative tuning 
parameter Theta that affects a tradeoff between speed and accuracy. Larger values of 
Theta give faster but less accurate optimization results. The algorithm is relatively 
insensitive to Theta values in the range (0.2 - 0.8).  

b. Exact method. 

6. Select a type of embedding to specify the type of scatter plot that you will receive. Available options 
are: 

a. 2D (default) 

b. 3D 

7. Under Distance Metric from the top, chose the parameters for the calculations (see Additional 
Information for further explanation): 

a. Distance metric  

b. PCA components 

c. Exaggeration parameter 

d. Perplexity parameter 

e. Standardize 

f. Under Optimization Control 

8. Click the green Run t-SNE button. The t-SNE scatter plot will be generated on the right upper 
panel.  

9. Select the Number of clusters and the Distance Metric. The results of clustering will be seen in 
the CLUSTER OUTPUT panel on the right lower panel.  
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Click the green Select Class button to compare which cluster is relevant to various areas in the datacube. 

 
A pop-up will appear asking for which class/cluster the user would like to view.  

 
The area covered by the selected cluster (in a bright color with the area measured in pixels) will appear at 
the bottom of the image. 
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10. Save the segmented image as a Label file for the Machine Learning toolbox. After selecting the 

class, make a right click on the segmented image to activate Save as a Label File tab. Click the 
tab and specify the file name. The .png and .mat files will be generated.  

You can also save only the data that belongs to the cluster area as a new datacube by selecting Save 
Cluster as a Datacube file. In this case others the pixel values of the object will be preserved as 
original, while the other pixels will be assigned as 0 (zeroes) across the entire datacube. By selecting 
Save Inverted Cluster as a Datacube File, the saving will be inverted. The pixels from the area 
occupied by the cluster will be assigned to zero, while the other values across the object will remain.  

 
Additional Information: 

There are two t-SNE algorithms, specified as Exact or Barnes-Hut.  

The Exact algorithm optimizes the Kullback-Leibler divergence of distributions between the original space 
and the embedded space.  

The Barnes-Hut algorithm performs an approximate optimization faster and uses less memory when the 
number of data rows is large.  

For both algorithms, t-SNE uses squared pairwise distances to calculate the Gaussian kernel in the joint 
distribution of X. 
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Exaggeration: Size of natural clusters in data, scalar value 1 or greater, 4 (default).  Size of natural clusters 
in data, specified as a scalar value 1 or greater. A large exaggeration makes t-SNE learn larger joint 
probabilities of Y and creates relatively more space between clusters in Y. t-SNE uses exaggeration in the 
first 99 optimization iterations. If the value of Kullback-Leibler divergence increases in the early stage of 
the optimization, try reducing the exaggeration. 

Number PCA Components: PCA dimension reduction nonnegative integer, 0 (default). PCA dimension 
reduction, specified as a nonnegative integer. Before t-SNE embeds the high-dimensional data, it first 
reduces the dimensionality of the data to Number PCA Components using the PCA function. 
When Number PCA Components is 0, t-SNE does not use PCA. 

Perplexity: Effective number of local neighbors of each point positive scalar, 30 (default). Effective 
number of local neighbors of each point, specified as a positive scalar. Larger Perplexity causes t-SNE to 
use more points as nearest neighbors. Use a larger value of Perplexity for a large dataset. 
Typical Perplexity values are from 5 to 50. In the Barnes-Hut algorithm, t-
SNE uses min(3×Perplexity,N-1) as the number of nearest neighbors.  

The 'Perplexity' value cannot be greater than the number of rows of X. 

Standardize: Normalize input data, false (default) / true. Normalize input data, specified as false or true. 
When true, t-SNE centers and scales X by dividing the columns by their standard deviations. When features 
in X are on different scales, set 'Standardize' to true. Do this because the learning process is based on 
nearest neighbors, so features with large scales can override the contribution of features with small scales. 

Learn Rate: Learning rate for the optimization process, 500 (default), positive scalar. Typically, set values 
from 100 through 1000. When Learn Rate is too small, t-SNE can converge to a poor local minimum. 
When Learn Rate is too large, the optimization can initially have the Kullback-Leibler divergence 
increase rather than decrease. 

Theta: Barnes-Hut tradeoff parameter, 0.5 (default), scalar from 0 through 1. Barnes-Hut tradeoff 
parameter, specified as a scalar from 0 through 1. Higher values give a faster but less accurate optimization. 
Applies only when Algorithm is Barnes-Hut. 

Distance Metrics 

A distance metric is a function that defines a distance between two observations. Distance metrics can be 
specified by one of the following. Definitions of the distance metrics are given in the Table: 

Value Description 

euclidean  Euclidean distance. 
squaredeuclidean  Squared Euclidean distance. (This option is provided for efficiency only. It does not 

satisfy the triangle inequality.) 
seuclidean  Standardized Euclidean distance. Each coordinate difference between observations is 

scaled by dividing by the corresponding element of the standard deviation,  
mahalanobis  Mahalanobis distance using the sample covariance of X, C = cov(X,'omitrows'). 
cityblock  City block distance. 
minkowski  Minkowski distance. The default exponent is 2. 
chebychev  Chebychev distance (maximum coordinate difference). 
cosine  One minus the cosine of the included angle between points (treated as vectors). 
correlation  One minus the sample correlation between points (treated as sequences of values). 
hamming  Hamming distance, which is the percentage of coordinates that differ. 

https://www.mathworks.com/help/stats/tsne.html#bvh3rti-Y
https://www.mathworks.com/help/stats/pca.html
https://www.mathworks.com/help/stats/tsne.html#bvh3rti-X
https://www.mathworks.com/help/stats/tsne.html#bvh3rti-Algorithm
https://www.mathworks.com/help/stats/pdist.html#f1207226_sep_shared-DistParameter
https://www.mathworks.com/help/stats/pdist.html#f1207226_sep_shared-DistParameter
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Value Description 

jaccard  One minus the Jaccard coefficient, which is the percentage of nonzero coordinates that 
differ. 

spearman  One minus the sample Spearman's rank correlation between observations (treated as 
sequences of values). 

 

k-Medoids Clustering: k-Medoids clustering is a partitioning method commonly used in domains that 
require robustness to outlier data, arbitrary distance metrics, or ones for which the mean or median does not 
have a clear definition. It is similar to k-Means, and the goal of both methods is to divide a set of 
measurements or observations into k subsets or clusters so that the subsets minimize the sum of distances 
between a measurement and the center of the measurement’s cluster. In the k-Means algorithm, the center 
of the subset is the mean of measurements in the subset, often called a centroid. In the k-Medoids algorithm, 
the center of the subset is a member of the subset, called a medoid. 

k-Medoid is more robust to noise and outliers as compared to k-Means because it minimizes a sum of 
pairwise dissimilarities instead of a sum of squared Euclidean distances. The k-Medoids algorithm returns 
Medoids, which are the actual data points in the data set. This allows you to use the algorithm in situations 
where the mean of the data does not exist within the data set. This is the main difference between k-Medoids 
and k-Means where the centroids returned by k-Means may not be within the data set. Hence k-Medoids are 
useful for clustering categorical data where a mean is impossible to define or interpret. 

Performance of t-SNE:  

Performance depends on data sizes and algorithms. t-SNE can take a good deal of time to process data. If 
you have N data points in D dimensions that you want to map to Y dimensions, then 

• Exact t-SNE takes of order D×N2 operations. 

• Barnes-Hut t-SNE takes of order D×Nlog(N)×exp(dimension(Y)) operations. 

For Pavia, N is greater than 1000 or so and has the embedding dimension Y is 2 or 3 hence the Barnes-Hut 
algorithm can be faster than the exact algorithm. 

References: 

van der Maaten, Laurens, and Geoffrey Hinton. "Visualizing Data using t-SNE." J. Machine Learning 
Research 9, 2008, pp. 2579–2605. 

van der Maaten, Laurens. Barnes-Hut-SNE. arXiv:1301.3342 [cs.LG], 2013. 

Jacobs, Robert A. "Increased rates of convergence through learning rate adaptation." Neural Networks 1.4, 
1988, pp. 295–307. 

k-Medoids: 

Kaufman, L., and Rousseeuw, P. J. (2009). Finding Groups in Data: An Introduction to Cluster Analysis. 
Hoboken, New Jersey: John Wiley & Sons, Inc. 

Park, H-S, and Jun, C-H. (2009). A simple and fast algorithm for k-Medoids clustering. Expert Systems 
with Applications. 36, 3336-3341. 

  

https://arxiv.org/abs/1301.3342
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Spectral Phasor Clustering Toolbox 
NOTE: This Toolbox supports parallel computing to accelerate computation. PAVIA dataset is used as a 
sample. 

Features: 

• Builds a density map from the entire datacube. 

• Enables a user to select a cluster and visualize their position on a black and white image. 

• Enables user to visualize up to three clusters. 

• Calculates the area covered by each cluster (in pixels). 

• Enables searching of the region of interest on a cluster. 

 Steps: 

1. After loading a file, select Toolboxes → Phasor Clustering. 

 
A set of pop-ups will guide you through the process. 

 
2. Select a Method. Available options are: 

a. Original image. 

b. Subtraction (help to spread the scatter plot). For this option, select a wavelength using 
either a slider or type a band/channel/wavelength.  

3. Click a Start button to generate a scatter plot (PHASOR SCATTER panel) and a gray image 
(RECONSTRUCTION panel). 

A: Visualize portions of the cluster on the RECONSTRUCTION panel by clicking the blue Reconstruct 
button. Click Reconstruct and select the first region of interest using either a rectangular or an ellipsoid 
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selection tool. This will produce the areas on the cluster as matching colors on the grayscale image. Click 
Check/Uncheck the “Overlay original image” to show/unshow the original image as a background. 

 

B: Visualize selected areas from the RECONSTRUCTION panel on the PHASOR SCATTER panel using 
the Search button. 

4. Press the Search button and select the area of interest to see the location of the corresponding 
cluster (as red, green, or blue dots). You can repeat this selection up to three times. 

5. Use Band Selection to visualize the image within a specific wavelength range. 

 
6. Save the segmented image as a Label file for the Machine Learning toolbox. After reconstructing, 

make a right click on the reconstructed image (right panel) to activate Save as a Label File… tab. 
Click the tab and specify the file name. The .png and .mat files will be generated. NOTE: we 
suggest using a single reconstruction for saving as a label file.   
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Additional Information: 

The toolbox uses the Fourier Transform function that computes and plots the transformed spectrum from 
each pixel as a scatter plot.  
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Correlation Matrix (R-squared) 
NOTE: Plastic and Coin dataset is used as an example.  

Features: 

• Builds a correlation matrix to visualize the cross correlation between bands. 

• The matrix identifies groups of highly correlated bands in the dataset for potential compression of 
data. 

• The toolbox allows manual deletion of the redundant bands. 

Steps: 

1. Open a file. 

2. Select Toolboxes → Correlation Matrix (R-squared).  

 
The calculation will start immediately and produce a correlation matrix with the histogram. 

 

Remove Highly Correlated Bands (Optional): 



v. 2.78   

313 
 

1. Press Remove Bands to launch a Table with all bands in the dataset.  

2. Select the bands with the highest values of correlation (i.e., 75-90) and click Remove.  

The removal of the bands is global and will affect the original data. 

3. To see a new correlation matrix, you will need to run the Correlation Matrix toolbox again. Within 
the toolbox, the numbering of bands will reflect the deletion. 

 

Additional Information: 

The toolbox uses a square of a function that computes a Pearson correlation matrix. 

Pearson's linear correlation coefficient is the most used linear correlation coefficient. For a band Xa in X and 
a band Yb in matrix Y, having means 

 
where n is the length of each spectrum. 

Pearson's linear correlation coefficient rho(a,b) is defined as: 

 

Values of the correlation coefficient can range from –1 to +1. A value of –1 indicates a perfect negative 
correlation, while a value of +1 indicates a perfect positive correlation. A value of 0 indicates no correlation 
between the columns. IDCube uses a square of the correlation coefficients. In this case, the correlation 
coefficient can range from 0 to +1. A value of +1 indicates a perfect positive or negative correlation 
between the bands, suggesting the redundancy of the bands. A value of 0 indicates no correlation between 
the bands. 

References: 
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Gibbons, J.D. Nonparametric Statistical Inference. 2nd ed. M. Dekker, 1985. 

Hollander, M., and D.A. Wolfe. Nonparametric Statistical Methods. Wiley, 1973. 
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3D Viewer 
NOTE: Plastic and Coin dataset is used as an example.  

Features: 

1. Builds and rotates 3D images where X, and Y are spatial coordinates and Z – is the spectral 
coordinate.  

2. Changes the dimensions for better representation of the datacube.  

3. Performs Isosurface and Alpha mapping. 

4. Performs orthogonal slicing.  

5. Performs 3D slicing.  

Steps:  

1. Select the 3D Viewer toolbox or a shortcut icon button from the Main Interface to start 3D Viewer. 

 

For effective visualization of files, the toolbox performs spatial and spectral binning (n=3) before 3D 
visualization. 
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3D View 
1. Click Generate 3D button. This command will activate a 3D INTERACTIVE panel on the right. 

 

2. Mouse control is activated: 

a. Rotate 3D View by clicking, holding, and moving the left button of the mouse. 

b. Zoom 3D View by clicking, holding, and moving the right button of the mouse.  

c. Zoom can also be activated by the scroll wheel. 

3. 3D INTERACTIVE panel enables the following options: 

a. Volume type. 

i. Volume render (default). Shows all data with or without the alpha values. Alpha values 
provide transparency to the object.  

ii. Isosurface. The isosurface function computes and draws a surface by connecting points 
of a constant value within a volume of space. Activates the following options (NOTE: 
Other functions will not work when Isosurface is selected).  

iii. Isovalue. This value defines the surface properties where each point has the same value 
(the slider shows the range from 0 to 1).  

iv. Surface Color. Shows the color of the isosurface (see below).  
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b. Alpha map: alpha value sets the face transparency for objects. Alpha Map uses a vector of 
values ranging from 0 to 1. This alpha map displays the lowest alpha data values as completely 
transparent and the highest alpha data values as opaque. There are preset sets of vectors:  

i. Linear. 

ii. Profile 1- 9  

iii. Custom. The user selects the alpha value and the intensity value. When this 
function is selected, two sliders corresponding to the alpha value and the 
intensity values are activated. Only a linear profile is currently implemented.  

iv. (an example of a Linear and Profile 1 is shown below). 

c. Dimension Control. Is used to multiply the size of the object in X, Y, and Z directions to 
visually increase/decrease the dimensions for better visualization. No changes are introduced 
to the actual values in the dataset.  

 

Linear Profile 1 (preset) Custom 
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d. Select a 3D Colormap under Generate 3D. Available colormaps are black&white, autumn, 
bone, cool, copper, gray, hot, pink, spring, summer, winter, jet, hsv, colorcube, flag, lines, 
prism, CT-bone, white, and contrast. 

3D Slice View 

Click Get 3D Slice button. This command will activate a SLICER OF AXES panel on the right. The 
panel has three slicers corresponding to the X, Y, and Z axes. 

 

Click Reset to return to the default view. 

Orthogonal Slice View 

Click the Get Orthogonal slice button. This command will activate an ORTHOGONAL SLICE SCALE 
CONTROL panel on the right. Enter the values to adjust the dimension (the value is used to multiply the 
dimension with default values equal to 1). It will only affect visualization. 
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Grab the intersection of the two lines and move it across the image to see different slices.  

 

To change the intensity of the image, left-click on the image and drag the cursor up or down. 
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Feature Finder 
NOTE: Plastic and Coin dataset is used as an example. 

Features: 

• Calculates and removes the background from the spectra.  

• Calculates the peak intensity, position, peak width, and area under the peak (positive and negative). 

• Visualizes the peak in the dataset. 

• Generates the new dataset for the peak of interest and saves it in the original directory. 

• The toolbox supports parallel computing to accelerate computation. 

 

 Steps:  

1. Select the area of interest. 

2. Correct the spectrum for background using None, Asymmetric Least Squares Smoothing, Savitzky-
Golay, or Bayesian EM methods  

 
3. Move the boundaries to select a spectrum and calculate spectral parameters: such as Peak 

Intensity, Peak Maximum, Peak Width, and Peak Area. 
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4. Press the Find Pixels buttons to visualize the pixels that have the peak features. This can be done 
by two different methods specified below. 

Method 1: Find Peaks by Peak Intensity. Change the values of the peak to any positive value less or 
equal to the identified peak intensity. Enter zero, if you would like to see the pixels in the image 
corresponding to the entire peak. Press Apply to Data (Peak). 

 

 

Method 2: Find Peaks by Peak Area. Leave the value intact. Press Find Pixels by Peak Area. 
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You can save the new datacube with the corresponding changes in the image by pressing Save the 
Datacube as a new dataset to the directory. 

Additional Information: 

Savitzky-Golay filter: The filter applies a type of sliding window to the data.  

ORDER: is an order of the polynomial. 

WINDOW: is the number of data points in the window at any one time. 

For example, Window = 11, and Order = 3 fit a polynomial of order 3 to 11 data points at a time and the 
ith data point will be approximated by the polynomial evaluated at the point corresponding to i. 

Asymmetric Least Squares Smoothing: This method uses a smoother with an asymmetric weighting of 
deviations to get a baseline estimator. In doing such, this processor quickly ascertains and corrects a baseline 
while retaining the signal peak information. 

SMOOTHNESS: defines how smooth the baseline should be (default 100). 

ASYMMETRY: defines how "low" the baseline should be. The range is from 0 to 1. Lower peaks require 
asymmetry approaching 0, while high peaks require asymmetry value approaching 1. 

ITERATIONS: defines the number of iterations to reach the converge (default 20). The calculation time is 
proportional to the number of iterations. 

Bayesian EM filter: The filter adjusts the variable background (baseline) of a signal with peaks by 
following three steps: 1) estimates the background within multiple shifted windows of width 200 separation 
units (s.u.) along the x-axis, 2) regresses the varying baseline to the window points using a spline 
approximation, and 3) adjusts the background of the input signal. 

WINDOWSIZE: sets the width for the shifting window. The default is 200 s.u., which means a background 
point is estimated for windows of 200 s.u. in width. 

STEPSIZE: sets the steps for the shifting window. The default is 200 s.u., which means a background point 
is estimated for windows at every 200 s.u. 

REGRESSION METHOD sets the method used to regress the window estimated points to a soft curve. The 
default is 'pchip'; i.e., shape-preserving piecewise cubic interpolation. Other options are 'linear' and 'spline' 
interpolation. 
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ESTIMATION METHOD sets the method used to find the likely background value at every window. 
Default is 'quantile', in which the quantile value is set to 10. An alternative method is 'em', which assumes 
a doubly stochastic model. 

SMOOTH METHOD sets the method used to smooth the curve of estimated points, useful to eliminate the 
effect of possible outliers. Options are 'none' (default), 'lowess' (Linear Fit), 'loess' (Quadratic Fit), or 
'rlowess' and 'rloess' (Robust Linear and Quadratic Fit). 

QUANTILE VALUE changes the default quantile value. The default is 0.10. 

NOTE: The baseline subtraction mode does not preserve the height of the tallest peak in the signal when 
subtracting the baseline. 

References: 

Lucio Andrade and Elias Manolakos, "Signal Background Estimation and Baseline Correction Algorithms 
for Accurate DNA Sequencing" Journal of VLSI, special issue on Bioinformatics 35:3 pp 229-243 (2003) 
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Fusion (MSI/HSI, pansharpening) 
NOTE: Hyperspec-VNIR Chikusei dataset is used as an example.  

Features: 

• Combines low-resolution hyperspectral dataset and high-resolution multispectral dataset to 
generate a high-resolution hyperspectral dataset. 

• *Future release* Evaluates the quality of fusion. 

Steps: 

1. Open Toolboxes → Fusion (MSI/HSI) in IDCube format. A new window will pop up. 

 

 
2. Click Browse... and locate the multispectral and hyperspectral datasets. 

 
3. Select an algorithm from the ALGORITHM SELECTION panel. Currently available options are: 
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a. Gram-Schmidt Adaptive algorithm. 

b. Smoothing filter-based intensity modulation with hypersharpening. 

c. Generalized Laplacian pyramid with hypersharpening. 

 
Click the green Perform Data Fusion button. Click the Plot Spectra buttons and touch the images to 
visualize the spectra. Click on the top of the image to expand the image.  

 
To save the fused dataset, right-click on the fused image and select Save as New Datacube. 

References: 

This toolbox includes three algorithms for fusing hyperspectral and multispectral data to obtain high-
resolution hyperspectral data. The toolbox is based on the following references: 

Review of fusion methods: N. Yokoya, C. Grohnfeldt, and J. Chanussot, "Hyperspectral and multispectral 
data fusion: a comparative review of the recent literature," IEEE Geoscience and Remote Sensing Magazine, 
vol. 5, no. 2, pp. 29-56, June 2017. 
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 GSA (Gram-Schmidt adaptive): N. Yokoya, C. Grohnfeldt, and J. Chanussot, "Hyperspectral and 
multispectral data fusion: a comparative review of the recent literature," IEEE Geoscience and Remote 
Sensing Magazine, vol. 5, no. 2, pp. 29-56, June 2017. 

SFIM-HS (Smoothing filtered-based intensity modulation with hypersharpening): J. G. Liu (2000) 
Smoothing Filter-based Intensity Modulation: A spectral preserve image fusion technique for improving 
spatial details, International Journal of Remote Sensing, 21:18, 3461-3472, DOI: 
10.1080/014311600750037499 

GLP-HS (Generalized Laplacian pyramid with hypersharpening): Selva, M.; Aiazzi, B.; Butera, F.; 
Chiarantini, L.; Baronti, S. Hyper-sharpening: A first approach on SIM-GA data. IEEE J. Sel. Top. Appl. 
Earth Obs. Remote. Sens. 2015, 8, 3008–3024. 

Hyperspec-VNIR Chikusei data converted to the IDCube format is available from our website. Visit 
https://www.idcubes.com/examples to download.  

  

https://www.idcubes.com/examples


v. 2.78   

327 
 

7.9. Machine Learning Tab  
The functions under the Machine Learning Tab include labeling and masking toolboxes that are necessary 
for the training of datasets. The functions also include supervised and non-supervised machine learning 
techniques. 

 

* not currently available for IDCubePro® users 

Create Label(s)    

NOTE: Rose Leaves dataset is used as an example.  
Features: 

• Enables user to label a single class with multiple labels.   

• Enables user to label multiple classes with a single label for each class.  

• The labels can be saved to use for the machine and deep learning applications implemented in 
IDCube. 

Steps: 

1. Select Create Labels from Machine Learning Tab.  

 

The image from the IMAGE DISPLAY panel (from the Main Interface) will automatically be shown.  

Tabs Function Additional info 

Machine Learning Creates Label(s) Pop-up toolbox 
 Creates Mask(s) Pop-up toolbox 
 Binary Tool Pop-up toolbox 
 k-Means Classifier (two methods) Dialogue window 
 Machine Learning Pop-up toolbox 
 Deep Learning*   Pop-up toolbox 
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2. The Label maker toolbox offers two options: 

a. Label a single class (in addition, a background class is generated automatically, thus a total 
of two classes are generated) 

b. Label multiple classes (in addition, a background class is generated automatically, thus 
N+1 classes are generated). 

Label a single class 
1. Click Label a Single Class pushbutton. The choice will be confirmed by the dropdown menu from 

the Selection Type. A Number of Labels window will be activated.  

2. Enter a number of labels you plan to have and click Apply. The background label will also be 
generated automatically. 

 
3. A pop-up will ask you to select the drawing tool. Click OK and select a tool (i.e., rectangle). 
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4. Draw the number of areas that belong to the same class. The labels will be numbered such as shown 

below and automatically shown in the LABELS panel after the number of labels reaches the 
specified number (i.e., 3). 

 
5. Click Save Label(s) and select the directory. The default directory is the location of the original 

dataset. NOTE: two files will be generated a png file and a m (or mat) file. Both files are 
necessary for machine and deep learning applications.  

Label Multiple Classes 
The steps are similar. In addition, you can use the Push Multiclass Label(s) function to visualize the 
selected labels on the left panel at any time as long as the number of drawn labels is less than specified in 
the Number of Labels field. 
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Click Save Label(s) and select the directory. The default directory is the location of the original dataset. 
NOTE: two files will be generated a png file and a m (or mat) file. Both files are necessary for 
machine and deep learning applications. 

Create Mask(s)  
NOTE: PAVIA dataset is used as an example 
Features: 

• Enables user to select masks with multiple labels.  

• The masked image can be saved to use for machine and deep learning applications implemented in 
IDCube. 

Steps: 

1. Open file in IDCube format. 

2. Select Machine Learning → Create Mask.  

 

3. From the new pop-up window Masking Tool, push the Activate button, enter the number of 
masks (default is 3) and press Apply.  
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4. Choose a drawing tool from the toolbar and select the area on the left image. You can zoom in if 
desired. The selected areas will be automatically converted into pixels with values equal to ONEs 
with the rest of the image (background) to ZEROs. The colors for the masked objects are random 
and selected by IDCubePro®. In this example, a Freehand tool has been selected. 

 

5. Press the Save mask(s) button. The user will be asked to provide the name of the file. Two files 
will be generated: png (color image) and m (in the format m x n x 3). These files can be used for 
machine and deep learning applications in IDCubePro®. 

6. Press the Clear mask(s) button to start a new task. 

NOTE: Future versions of the software will enable the user to adjust the selected area.   



v. 2.78   

332 
 

Binary Tool 
NOTE: PAVIA dataset is used as an example. 

Features: 

• Performs classification of the dataset using a binary method. Each pixel above a certain threshold 
is assigned to a value of ‘1’ (white color) while each pixel less than a threshold level has a value of 
“0” (black color).  

• Calculates the area above the threshold (see below). 

• That classified image can be saved as a labeled file for machine learning. 

Steps: 

1. Select Machine Learning → Binary Image. The calculation will start immediately and produce 
the binary matrix with the histogram. 

 
2. Move the boundaries on the HISTOGRAM panel to set new thresholds.  

 
3. Press Save the Label to generate a png file in your specified directory and (automatically) mat file. 

These files will be needed for the Machine Learning applications. 
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k-Means Classifier           
NOTE: PAVIA dataset is used as an example. 

Features: Performs classification of 3D datasets using k-Means clustering-based volume segmentation 
algorithms. Two types of the k-Means classifier are available: 

• Slice-based clustering k-Means classifier (frame-to-frame classifier) 

• Global clustering k-Means classifier (entire datacube).  

Slice-based frame-to-frame classifier 

Steps:  

1. Open the dataset in the IDCube format. 

2. Click the Machine Learning tab on the menu bar, select k-Means Classifiers, and select k-Means 
Slice-Based Clustering Classifier. 

 

3. The new dialogue window k-Means parameters will open. Enter the number of expected clusters 
(classes). The default number is 2. Enter the number of iterations (usually <100). 

4. Each color in the updated image corresponds to a different class (1 out of 10 in this example). Pixels 
with the color corresponding to label 1 on the colorbar belong to the first cluster, label 2 belongs to 
the second cluster, and so on for each of the k clusters. 

 

https://www.mathworks.com/help/images/ref/imsegkmeans3.html#mw_d9166c26-f57d-488d-a788-9d8d3a77a8ed
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5. Use Band/Channel sliders and other functions to further optimize the image.  

NOTE: The number of labels on the colorbar is identified automatically and could be equal to or less than 
the number of input clusters. 

k-Means Global Clustering Classifier 
1. Open the dataset in the IDCube format. 

2. Click the Machine Learning tab on the menu bar, and select k-Means Classifiers and k-Means 
Global Clustering Classifier.    

 

3. The new dialogue window k-Means parameters will open. Enter the number of expected clusters 
(classes). The default number is 2. Enter the number of iterations (usually <100). 

4. Each color in the updated image corresponds to a different class (1 out of 6 in this example). Pixels 
with the color corresponding to label 1 on the colorbar belong to the first cluster, label 2 belongs to 
the second cluster, and so on for each of the k clusters.  

https://www.mathworks.com/help/images/ref/imsegkmeans3.html#mw_d9166c26-f57d-488d-a788-9d8d3a77a8ed
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Since this algorithm is global across all bands/channels, the changes in the Band/Channel slider positions 
will not affect the image.  

NOTE: The number of labels on the colorbar is identified automatically and could be equal to or less than 
the number of input clusters. 

Additional Information: 

k-Means clustering is an unsupervised machine learning algorithm. It is the fastest and most efficient 
algorithm to categorize data points into groups even when very little information is available about data. 
IDCube employs a k-Means++ algorithm that chooses the initial values (or "seeds") for the k-Means 
clustering algorithm. The procedure initializes the cluster centers before proceeding with the standard k-
Means optimization iterations. 

References: 

Arthur, David, and Sergei Vassilvitskii. “K-Means++: The Advantages of Careful Seeding.” 
In Proceedings of the Eighteenth Annual ACM-SIAM Symposium on Discrete Algorithms, 1027–35. 
SODA ’07. USA: Society for Industrial and Applied Mathematics, 2007.  
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Machine Learning Classifier 
NOTE: Rose Leaves dataset is used as an example. 

Features: Performs limited classification of 3D datasets using machine learning algorithms. Training is 
conducted using a single file. The validation process is currently not supported. Confusion matrixes are 
only built for the training procedures.  
Steps: 

1. Open an IDCube file from the Main Interface. 

2. Click the Machine Learning tab and select Machine Learning Classifier from the menu. 

 
A new Machine Learning window will open. The window will present the image in the same mode as the 
main interface (such as RGB as shown below). The window will also provide information about the dataset 
(left upper corner).  

 
The toolbox enables the user to use two types of labeling files. Available options are: 

• Single class labels. This option enables using multiple labels of the same class. 

• Multiple class labels. This option enables using multiple classes with one label per class.  
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The algorithm also counts unlabeled parts of the images as background classes for both of these options, 
that the total number of classes for a single class label is equal to two: labeled + background.    

NOTE: IDCube treats the background data as a separate additional class. The labels of this class are 
identified automatically. 

In this example, we will use a file with two selected classes using one label for each class.  

3. Click Load Label Data and select a file previously saved from labeling. The file should have a .m 
(or .mat) extension and is automatically generated along with the .png file by using the Create 
Label tool. The labeled file with two labeled areas corresponding to different leaves will appear in 
the right corner. The number of classes (=3) corresponds to two labeled classes (in blue and red) 
and a background (black). 

 
4. Select a method from the dropdown menu.  

 

Currently available options are: 
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*) actual time is for the shown file on a desktop 64 GB RAM, Intel(R) Xeon(R) E-2286G CPU @ 
4.00GHz   4.01 GHz 

5. An example is given with the Naïve Bayes method.  After selecting this method, press the Train a 
model button. The training prediction model will appear as an image. The classified leaves seem 
to reproduce the actual shapes. The accuracy of the training is 76.1%, and the F1 score is moderate 
(46.7%).  

           
The produced Confusion Matrix can be opened in a separate window by clicking the green Zoom button. 
Class 0 is the background. Classes 1 and 2 are the leaves.  

The score might be improved by making the right click on the Training Predicted Image. 

6. After the training is complete, press Classify new dataset button  and open, 
for example, the original (not cropped) Rose_Leaves file.  

Machine Learning Method Training speed* Prediction speed Memory usage 

Naïve Bayes Very Fast (1.2 sec) Fast Small 
Linear Discriminant Analysis Very Fast (3.38 sec) Fast Small 
Binary Decision Tree Fast (6.56 sec) Fast Small 
Nearest Neighbor Slow (700 sec) Slow Large  
Feed Forward Neural 
Network 

Fast (11 sec) Moderate Medium to Large 

Support Vector Machine Slow (3300 sec) Very slow Medium 
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7. The results from this example where three individual classes are identified: the labeled classes 
(class 1, light green, class 2, black), and the background (class 3). (NOTE: The background class 
is identified automatically). 

8. Press the Overlay button to put all classes together. Although having the same dimension of the 
training set and the new datasets are not critical, having the same dimension enables overlay 
function by pressing the corresponding button. The overlay image below shows all three classes: 
white – background, purple (mostly left leaf), and light blue (mostly right leaf). 

 
Using Machine Learning with Linear Discriminant Analysis. 
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Press the Overlay button to combine classes together in one image. The overlay image below shows all 
three classes: white – background, purple (mostly left leaf), and light blue (mostly right leaf).   

 
Additional information 

Confusion Matrix for Binary Classification 

Confusion matrix is often used as an evaluation criterion for the machine learning model. It gives simple 
and efficient performance measures for the selected model. The most common performance metrics 
calculated from the confusion matrix are shown below and to the left of the confusion matrix and specified 
below. For simplicity, we can only consider a case, when the binary classification problem has only two 
classes positive and a negative (background) class. 

  
True Negative (TN): refers to the number of predictions where the classifier correctly predicts the negative 
class as negative. 
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False Positive (FP): refers to the number of predictions where the classifier incorrectly predicts the 
negative class as positive. 

False Negative (FN): refers to the number of predictions where the classifier incorrectly predicts the 
positive class as negative. 

True Positive (TP): refers to the number of predictions where the classifier correctly predicts the positive 
class as positive. 

Accuracy: provides the overall accuracy of the model, meaning the fraction of the total samples that were 
correctly classified by the classifier. To calculate accuracy, use the following formula:  

Accuracy = (TP+TN)/(TP+TN+FP+FN)×100, % 

Error (Classification Error or Misclassification): tells what fraction of predictions were incorrect.  

Error = (FP+FN)/(TP+TN+FP+FN)×100, % or (100-Accuracy,%) 

Precision: Defines what fraction of predictions as a positive class were actually positive. Calculated using 
the following formula:  

Precision = TP/(TP+FP) ×100, % 

Recall: Defines what fraction of all positive samples were correctly predicted as positive by the classifier. 
It is also known as True Positive Rate (TPR), Sensitivity, Probability of Detection. Calculated using the 
following formula:   

Recall = TP/(TP+FN)×100, % 

Specificity: Defines what fraction of all negative samples are correctly predicted as negative by the 
classifier. It is also known as True Negative Rate (TNR). Calculated using the following formula:   

Specificity = TN/(TN+FP) ×100, % 

F1-score: It combines precision and recall into a single measure. Mathematically it’s the harmonic mean 
of precision and recall. It can be calculated as follows: 

𝐹𝐹1𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠𝑠 = 2 ×
𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃 × 𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅
𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃𝑃 + 𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅𝑅

=
2𝑇𝑇𝑇𝑇

2𝑇𝑇𝑇𝑇 + 𝐹𝐹𝐹𝐹 + 𝐹𝐹𝐹𝐹
, % 

A perfect model has a precision of 100%, recall of 100%, and the F1-score of 100%. The metrics of the 
model can be improved by trying different methods.  
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7.10. Macros Editor Tab 

Macros Editor  
NOTE: Plastic and Coin dataset (cropped) is used as an example.  

Features: The Macros Editor is an interactive graphical user interface (GUI) designed to help you create 
and execute custom sequences of commands for automatic data processing.  

 

Step 1. Open a hyperspectral file and click Macros → Macros Processing. 

 
A new pop-up window Macros Editor will appear. 

 
 

Layout 

Upon launching the Macros Editor, you will find the main window divided into two sections:  

- The left side displays Available Commands grouped by categories in a tree structure.  

- The right side displays the Selected Commands that will be executed in order. 

At the bottom, you will find several buttons for controlling and managing your command sequences. 

Using the Macros Editor 

Step 2. Selecting Commands 

Navigate the command tree on the left by expanding the nodes to reveal the available commands. Click on 
a command to select it. For example, click Filtering and Enhancement and select Spatial Filter. 
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Step 2. Adding Commands to Sequence 

Once you have selected a command, click the Add button located in the middle of the GUI to add it to your 
sequence. The selected command will appear in the Selected Commands list on the right side of the GUI.  

There are three types of commands: 

1. Command that directly appear in the Selected Commands without any additional input from 
the user (i.e., flip horizontally) 

2. Command that requires an input from the user in the form of dialog box. For example when 
Spatial binning is selected, pressing the button Add will prompt the box asking to enter the 
bin number.  

 
After the input entered, the command will appear with the entered number in parenthesis. 
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3. Command that requires an interactive input, such as Spatial Crop that will ask the user to draw 

an interactive region of interest on the Main Interface Image Display Panel. After the region 
of interest is drawn, the command will appear with the entered area coordinates in parenthesis 

 
You can create any sequence of commands to tailor the processing to your specific needs. 

Removing Commands from Sequence 

To remove a command from your sequence, select it in the Selected Commands list and then click the 
Remove button. The command will be removed from your sequence but will remain available in the tree 
of commands on the left. 

Moving Commands Up and Down  

To move the command up or down the sequence list, select the command from the Selected Commands list 
and press Move Up or Move Down buttons. 

Saving and Loading Sequences 
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You can save your current sequence of commands for later use by clicking the Save button. Conversely, 
you can load a previously saved sequence by clicking the Load button.  

Clearing the Sequence 

To clear all commands from your current sequence, click the Clear button.  

Running the Sequence 

To execute your sequence of commands, click the Run button. All commands will be run in the order they 
appear in the Selected Commands list. After each step a message box stating that the command is complete 
will appear.  

Copying the Sequence 

To copy the list of your sequence of commands, click the Copy button and paste into as text format.  

Getting Help 

The  button in the upper right corner of the GUI will provide additional information about the Macros 
Editor and how to use it. 

 

Command Categories 

The Macros Editor organizes available commands into the same categories as the Main Interface: 

- Open File: Commands for opening files in the IDCube format. 

- Edit: Commands for editing data, such as flipping, rotating, cropping, etc. 

- Filtering and Enhancement: Commands for applying different filters and data enhancement 
techniques. 

- Contrast Enhancement: Commands for enhancing the contrast of your data. 

- Data Correction: Commands for correcting your data. 

- Reset: Commands for resetting the state of your data. 

The current version of IDCubePro, the Macros Editor offers almost forty functions. More commands will 
be added in the future releases. 

  



v. 2.78   

346 
 

 

7.11. Windows Tab 
Shows all open windows except the Main Interface. Enables the user to bring the window on top of the 
software. Automatically populates.  
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7.12. Help Tab 

 

About IDCubePro® and Terms of Use 
IDCubePro®, by HSpeQ LLC, St. Louis, MO, 63110, USA; Initial release September 2022.                                                                                                                                                                                                                                                                             

Cite: IDCube Pro, Hyperspectral Imaging Software, HSpeQ LLC.       

Tutorials 
Video tutorials to the software are located at the HSpeQ website https://www.idcubes.com/tutorials  or 
our YouTube Channel https://www.youtube.com/channel/UCgkuxZAkOSIDho2V9tvE5_g 

 

 

Report Bug 
You can report your problem online. Please be aware that your report generates the unique ID of your 
computer and sends us an Error Report Log (see the following section). We need this information to 
check for the source of the problem and find a solution.  

Tabs Function Additional info 

Help About IDCubePro® and Terms of Use Pop-up document 
 Tutorials Online videos 
 Report Bug Online form 
 Error Log Generated document 
 About HSpeQ Online (idcubes.com) 
 Contact Us Online form 

https://www.idcubes.com/tutorials
https://www.youtube.com/channel/UCgkuxZAkOSIDho2V9tvE5_g
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Error Report Log 
IDCubePro® automatically generates a report log and stores it on your computer. 
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About HSpeQ 
We invite you to visit our website at https://www.idcubes.com, where you can access information about 
us, find educational materials and get access to new downloads. By clicking on the picture below, you will 
be connected to the page.  

 
Contact us 
We are always interested to hear from our customers and constantly looking for new partners. This link 
https://www.idcubes.com/contact-us connects you to the easy-to-fill form website. You can also click on 
the picture below and you will be connected to this page. 

 

  

https://www.idcubes.com/
https://www.idcubes.com/contact-us
https://www.idcubes.com/what-we-do
https://www.idcubes.com/contact-us
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Appendix 1: Expressions That Can Be Used in 
IDCube 

Select the Custom Function radio button. This will automatically activate an interactive field where the 
user can enter an equation. After entering an equation, click Get Image.  

 
To save the entire datacube make Right Click on the image and click Save New Datacube in IDCube 
Format. If more than one wavelength is used in the custom function, only w1 will be used as a variable. 

 

Format and notation  
Type an equation using the following format: 

Examples:    w1+w2 

sin(w1+w2) 

sin(w1./w2) 

sin(w1.*w2)  (use dots for divisions and multiplications) 

Only up to three selected channels are supported. Use w1, w2, or w3 and their combinations. Combine any 
of the functions with other functions: 

Examples:    log(sin(sqrt(w1.*w2)))  

fftshift(erf(cos(w1))) 
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NOTE: some of the functions and operations are linked to the explanation materials available from 
https://www.mathworks.com/.    

Arithmetic Operators  

Trigonometric Functions  

Function Description Mathematical Expression Example 

sin Sine of the input sin(w1) 

cos Cosine of the input cos(w1) 

tan Tangent of the input tan(w1) 

asin Inverse sine of the input asin(w1) 

acos Inverse cosine of the input acos(w1) 

atan Inverse tangent of the input atan(w1) 

atan2 Four-quadrant inverse tangent of the input atan2(w1) 

sinh Hyperbolic sine of the input sinh(w1) 

cosh Hyperbolic cosine of the input cosh(w1) 

tanh Hyperbolic tangent of the input tanh(w1) 

asinh Inverse hyperbolic sine of the input asinh(w1) 

acosh Inverse hyperbolic cosine of the input acosh(w1) 

atanh Inverse hyperbolic tangent of the input atanh(w1) 

 

Log and Exponential Functions  

Function Description Mathematical Expression Example 

exp Exponential exp(w1) 

expm1 Compute exp(x)-1 accurately for small values of x expm(w1) 

log Natural logarithm log(w1) 

log10 Common logarithm (base 10) log10(w1) 

log1p Compute log(1+x) accurately for small values of x log1p(w1) 

log2 Base 2 logarithm and floating-point number dissection log2(w1) 

nextpow2 Exponent of next higher power of 2 nextpow2(w1) 

pow2 Base 2 power and scale floating-point numbers pow2(w1) 

reallog Natural logarithm for nonnegative real arrays reallog(w1) 

Function Description Mathematical Expression Example 

+ Addition w1+w3 

- Subtraction w1-w3 

.* Element-wise multiplication w1.*w3 

./ Element-wise right division w1./w3 

.\ Element-wise left division w1.\w3 

https://www.mathworks.com/
https://www.mathworks.com/help/matlab/ref/exp.html
https://www.mathworks.com/help/matlab/ref/expm1.html
https://www.mathworks.com/help/matlab/ref/log.html
https://www.mathworks.com/help/matlab/ref/log10.html
https://www.mathworks.com/help/matlab/ref/log1p.html
https://www.mathworks.com/help/matlab/ref/log2.html
https://www.mathworks.com/help/matlab/ref/nextpow2.html
https://www.mathworks.com/help/matlab/ref/nextpow2.html
https://www.mathworks.com/help/matlab/ref/pow2.html
https://www.mathworks.com/help/matlab/ref/pow2.html
https://www.mathworks.com/help/matlab/ref/reallog.html
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Function Description Mathematical Expression Example 

realpow Array power for real-only output realpow(w1) 

realsqrt Square root for nonnegative values realsqrt(w1) 

sqrt Square root sqrt(w1) 

 

Hyperbolic Functions  

Function Description Mathematical Expression Example 

sinh Symbolic hyperbolic sine function sinh(w1) 

cosh Symbolic hyperbolic cosine function cosh(w1) 

tanh Symbolic hyperbolic tangent function tanh(w1) 

coth Symbolic hyperbolic cotangent function coth(w1) 

sech Symbolic hyperbolic secant function sech(w1) 

csch Symbolic hyperbolic cosecant function csch(w1) 

Inverse Hyperbolic Functions  

Function Description Mathematical Expression Example 

asinh Symbolic inverse hyperbolic sine function asinh(w1) 

acosh Symbolic inverse hyperbolic cosine function acosh(w1) 

atanh Symbolic inverse hyperbolic tangent function atanh(w1) 

acoth Symbolic inverse hyperbolic cotangent function acoth(w1) 

asech Symbolic inverse hyperbolic secant function asech(w1) 

acsch Symbolic inverse hyperbolic cosecant function acsch(w1) 

Error Functions  

Function Description Mathematical Expression Example 

erf Error function erf(w1) 

erfc Complementary error function erfc(w1) 

Fast Fourier Transform (FFT) Functions  

Function Description Mathematical Expression Example 

fft Computes the discrete Fourier transform (DFT) of w1 using a fast 
Fourier transform (FFT) algorithm fft(w1) 

fft2 2-D fast Fourier transform, which is equivalent to computing fft(fft(X) fft2(w1) 

fftshift Rearranges a Fourier transform X by shifting the zero-frequency 
component to the center of the array. 

fftshift(w1) 

ifftshift Rearranges a fftshift back to the original transform output, undoing the 
result of fftshift 

ifftshift(w1) 

https://www.mathworks.com/help/matlab/ref/realpow.html
https://www.mathworks.com/help/matlab/ref/realsqrt.html
https://www.mathworks.com/help/matlab/ref/sqrt.html
https://www.mathworks.com/help/symbolic/sinh.html
https://www.mathworks.com/help/symbolic/cosh.html
https://www.mathworks.com/help/symbolic/tanh.html
https://www.mathworks.com/help/symbolic/coth.html
https://www.mathworks.com/help/symbolic/sech.html
https://www.mathworks.com/help/symbolic/csch.html
https://www.mathworks.com/help/symbolic/asinh.html
https://www.mathworks.com/help/symbolic/acosh.html
https://www.mathworks.com/help/symbolic/atanh.html
https://www.mathworks.com/help/symbolic/acoth.html
https://www.mathworks.com/help/symbolic/asech.html
https://www.mathworks.com/help/symbolic/acsch.html
https://www.mathworks.com/help/symbolic/erf.html
https://www.mathworks.com/help/symbolic/erfc.html
https://www.mathworks.com/help/matlab/ref/fft.html
https://www.mathworks.com/help/matlab/ref/fft2.html
https://www.mathworks.com/help/matlab/ref/fftshift.html
https://www.mathworks.com/help/matlab/ref/ifftshift.html
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Graphic, Image Processing, and Filtering functions  

Function Description Mathematical Expression 
Example 

Edge  Find edges in a 2-D grayscale image, Sobel is the default edge(w1) 

"Sobel" Finds edges at those points where the gradient of the image I is maximum, using the 
Sobel approximation to the derivative. 

edge(w1, ‘Sobel’) 

"Prewitt" Finds edges at those points where the gradient is maximum, using the Prewitt 
approximation to the derivative. 

edge(w1, ‘Prewitt’) 

"Roberts" Finds edges at those points where the gradient is maximum, using the Roberts 
approximation to the derivative. 

edge(w1, ‘Roberts’) 

"log" Finds edges by looking for zero-crossings after filtering with a Laplacian of Gaussian 
(LoG) filter. 

edge(w1, ‘log’) 

"zerocross" Finds edges by looking for zero-crossings after filtering with a filter that you 
specify, h 

edge(w1, ‘zerocross’, h) 

"Canny" Finds edges by looking for local maxima of the gradient of I. The edge function 
calculates the gradient using the derivative of a Gaussian filter. This method uses two 
thresholds to detect strong and weak edges, including weak edges in the output if 
they are connected to strong edges. By using two thresholds, the Canny method is 
less likely than the other methods to be fooled by noise, and more likely to detect 
true weak edges. 

edge(w1, ‘Canny’) 

"approxcanny" Finds edges using an approximate version of the Canny edge detection algorithm that 
provides faster execution time at the expense of less precise detection. Floating point 
images are expected to be normalized to the range [0, 1]. 

edge(w1, ‘approxcanny’) 

entropyfilt returns the image, where each output pixel contains the entropy value of the 9-by-9 
neighborhood around the corresponding pixel in the input image  

entropyfilt(w1) 

rangefilt returns an image, where each output pixel contains the range value (maximum value 
− minimum value) of the 3-by-3 neighborhood around the corresponding pixel in the 
input image. 

rangefilt(w1) 

bwconvhull(BW) Computes the convex hull of the desired objects in BW (black and white, 
binary mask) and returns, a binary convex hull image. Desired pixel 
connectivity conn = 4 or 8 

bwconvhull(BW,'objects',conn) 

bwconvhull(BW) Computes the convex hull of the all objects in BW (black and white, binary 
mask) and returns, a binary convex hull image. Desired pixel connectivity 
conn = 4 or 8 

bwconvhull(BW,'union',conn) 

im2bw Converts the grayscale image to binary image BW, by replacing all pixels in 
the input image with luminance greater than level with the value 1 (white) 
and replacing all other pixels with the value 0 (black). 

im2bw(w1,level) 

imbinarize Creates a binary image from 2-D or 3-D grayscale image by replacing all 
values above a globally determined threshold with 1s and setting all other 
values to 0s. By default, imbinarize uses Otsu's method,  

imbinarize(w1) 

 

Function Description Mathematical Expression 
Example 

imgradient Find gradient magnitude of 2-D image imgradient(w1) 

imbilatfilt Applies an edge-preserving Gaussian bilateral filter to the grayscale or RGB image with 
smoothing N.  

imbilatfilt(w1, N) 

https://www.mathworks.com/help/images/ref/edge.html?searchHighlight=edge&s_tid=srchtitle_edge_1#buo5g3w-1-h
https://www.mathworks.com/help/images/ref/imbilatfilt.html
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Function Description Mathematical Expression 
Example 

padarray Pads image with an amount of padding in each dimension specified by N padarray(w1,[N 
N],'both') 

'both' Pads before the first element and after the last array element along each dimension. padarray(w1,[N 
N],'both') 

'post' Pad after the last array element along each dimension. padarray(w1,[N 
N],'post') 

'pre' Pad before the first array element along each dimension. padarray(w1,[N 
N],'pre') 

watershed Transform the image treating it as a surface where light pixels represent high elevations 
and dark pixels represent low elevations 

watershed(w1) 

imclose imclose(w1,SE) performs morphological closing on the grayscale or binary image w1, 
using the structuring element SE (example SE =  strel('disk',10)) 

imclose(w1, 
strel('disk',10)) 

   

Other Special Functions  

Function Description Mathematical Expression Example 

gamma Gamma function gamma(w1) 

gammaln Logarithmic gamma function gammaln(w1) 

ellipke Complete elliptic integrals of first and second kind ellipke(w1) 

expint Exponential integral expint(w1) 

airy Airy function airy(w1) 

psi Digamma function psi(w1) 

lambertw Lambert W function lambertw(w1) 

zeta Riemann zeta function zeta(w1) 

 

Appendix 2. System Requirements for Graphics 
(PC) 

Recommended System Requirements 
For the best results with graphics, your system must have: 

• At least 1 GB of GPU memory and 16GB of RAM memory for the files less than 500MB. For 
larger files at least 32GB RAM memory is recommended.  

• Graphics hardware that supports a hardware-accelerated implementation of OpenGL 2.1 or later. 
Most graphics hardware released since 2006 has OpenGL 2.1 or later. If you have an earlier version 

https://www.mathworks.com/help/images/ref/padarray.html
https://www.mathworks.com/help/images/ref/watershed.html?s_tid=doc_ta
https://www.mathworks.com/help/images/ref/imclose.html#d123e133532
https://www.mathworks.com/help/images/ref/imclose.html#d123e133573
https://www.mathworks.com/help/symbolic/gamma.html
https://www.mathworks.com/help/symbolic/gammaln.html
https://www.mathworks.com/help/matlab/ref/ellipke.html
https://www.mathworks.com/help/matlab/ref/expint.html
https://www.mathworks.com/help/symbolic/airy.html
https://www.mathworks.com/help/symbolic/psi.html
https://www.mathworks.com/help/symbolic/lambertw.html
https://www.mathworks.com/help/symbolic/sym.zeta.html
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of OpenGL, most graphics features still work, but some advanced graphics features are unavailable. 
For the best performance, OpenGL 4.0 or later is recommended. 

• The latest versions of graphics drivers are available from your computer manufacturer or graphics 
hardware vendor. 

IDCubePro® is a DPI-aware application that takes advantage of your full system resolution. Our graphics 
look sharp and properly scaled on all systems, including Windows and Macintosh systems. 

Upgrade Your Graphics Drivers 
Graphics hardware vendors frequently provide updated graphics drivers that improve hardware 
performance. To help ensure that your graphics hardware works with IDCubePro®, upgrade your graphics 
drivers to the latest versions available. 
IDCubePro® can encounter low-level issues when creating graphics on your system. For example, plots 
will become corrupted, or your graphics hardware might run out of memory. You can encounter these issues 
while creating and working with 2D or 3D charts. These issues are often due to older graphics hardware or 
outdated graphics drivers. To resolve them, try the options described here. 

• On Windows® systems, check for driver updates on the website of your manufacturer. If no updates 
are provided, then check the website of your graphics hardware vendors, such as AMD, NVIDIA, 
or Intel. 

• On Macintosh systems, the graphics drivers are part of the operating system. Use the latest updates 
provided. 

• On Linux systems, use proprietary vendor drivers instead of open-source replacements. 

Finding a Renderer Implementation for Your System 
NOTE: this function might not be applicable for all computers.  

IDCubePro® displays graphics using a hardware-accelerated, basic hardware-accelerated, or software 
implementation of the graphics renderer. To determine which implementation IDCubePro® is using, press 
Help → Error Log report. This structure also provides the name of the graphics renderer. For example, if 
IDCubePro® is using hardware-accelerated OpenGL, the field returns 'OpenGL Hardware'. If it is using 
software OpenGL, the field returns 'OpenGL Software'. Your Error Log report will have this 
information. 

Hardware-accelerated graphics: 

GraphicsRenderer: 'OpenGL Hardware' 

Vendor: 'Intel' 

Version: '4.6.0 - Build 27.20.100.9171' 

RendererDevice: 'Intel(R) HD Graphics 620' 

Details: [1×1 struct] 

Software implementation of the graphics: 

GraphicsRenderer: 'OpenGL Software' 

Vendor: 'Microsoft Corporation’ 

https://www.amd.com/en/support
https://www.nvidia.com/Download/index.aspx
https://www.intel.com/content/www/us/en/support/detect.html


v. 2.78   

356 
 

Version: '1.1.0' 

RendererDevice: 'GDI Generic' 

Details: [1×1 struct] 

By default, IDCube tries to use a hardware-accelerated implementation if your graphics hardware supports 
it. In some cases, IDCubePro® automatically switches to a software implementation: 

• If your system does not have the necessary graphics hardware. 

• If you are using a graphics driver with known issues, an older graphics driver, or graphics 
virtualization. Update your graphics drivers to the latest versions available. 

• If a previous IDCubePro® session crashed due to a graphics issue. If the previous session was using 
software OpenGL and crashed, then subsequent sessions use a more stable version of software 
OpenGL that has fewer capabilities. 

Future upgrades will enable a user to specify an OpenGL implementation. 

Fix Out-of-Memory Issues 
Graphics hardware with limited graphics memory can cause poor performance or lead to out-of-memory 
issues. Improve performance and work around memory issues with these changes: 

• Use smaller figure windows. 

• Close other toolboxes. 

• Bin your images if possible. 
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Parallel Processing 
To deliver the best performance, some of the functions and toolboxes of IDCubePro® (i.e., t-SNE, Feature 
Finder, Machine Learning use parallel processing.  To visualize the performance and see the number of 
cores on your PC click ctrl+alt+del to activate Task Manager, select Performance tab and change the 
view to display all cores if you like. Right-click inside the CPU graph, choose Change graph to and select 
Logical processors. The picture below shows the activity in every core (total 8 cores).   
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Contact Technical Support 
If you cannot resolve the issues, please contact HSpeQ technical support at 
https://www.idcubes.com/contact-us and provide the Error Log report.  

 
 

  

https://www.idcubes.com/contact-us
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